# Table of Contents

## Chapter 1: Introduction
- Who is this User Guide For? ........................................ 10
  - User Guide Conventions ............................................. 10
- Terminology .......................................................... 11
- Product Overview ...................................................... 12
  - Create!form Workflow .................................................. 12
  - Create!form Components ............................................. 14
- Supported Platforms .................................................. 17
- Requirements .......................................................... 18

## Chapter 2: Implementation Guide
- Installation Components ............................................. 20
  - Design Components ................................................... 21
  - Create!form Designer .................................................. 21
  - Create!form Transform ............................................... 21
  - Create!form Director .................................................. 21
  - Server Components ................................................... 21
  - Create!form Server .................................................... 21
  - Create!form Director .................................................. 21
  - Delivery Components ................................................ 22
    - Create!send .......................................................... 22
  - Output Components ................................................... 22
    - Create!print ........................................................ 22
    - Create!pdf Server ................................................... 22
    - Create!fax and Create!email ..................................... 22
    - Create!archive ...................................................... 22
- Implementation Road Map ............................................ 23
- Configuration Options ................................................. 29

## Chapter 3: Installing
- Installation Requirements ........................................... 32
- Installing ............................................................. 33
- Starting ............................................................... 34
- Getting Help .......................................................... 35
- Licensing ............................................................... 36
Chapter 4: Setting Up Print Queues .............................................. 37

Overview ................................................................. 38
Project Directories ...................................................... 39
  Print Queue Project Directories ...................................... 39
  Default Project Directory ........................................... 39
  Resource Directory .................................................. 39

Transferring Projects .................................................. 41
Adding Print Queues .................................................... 42
  Selecting the Output Port ........................................... 42
  Sharing Print Queues ................................................ 42

Configuring Print Queues .............................................. 44
  Queue Properties .................................................... 44
  Project Directory .................................................... 46
  Default Project ...................................................... 46
  Merge Configuration ................................................ 46
  Output Formats ....................................................... 48
  No Matching Project ............................................... 54
  Configuring Multiple Print Queues ................................. 55

Managing Print Queues ............................................... 56
  Viewing Print Queues ................................................ 56

Chapter 5: Production Printing .......................................... 61

Basic Workflow ......................................................... 62
  Document Data Type ................................................ 63
  Locating the Project ................................................ 64
  Output Format ....................................................... 65

Advanced Topics ...................................................... 66
  Printing Multiple Copies ......................................... 66
  Splitting Documents ............................................... 67
  Tray Mapping ......................................................... 67
  Next Copy Projects ................................................ 67

Job Handling .......................................................... 69
  Failed Jobs .......................................................... 69
  Active Jobs .......................................................... 70
  Reprinting Jobs ....................................................... 70

Managing Printer Resources ......................................... 71
Pre-Loading Resources .......................................................... 71
Re-Loading Resources ......................................................... 71
Deleting Resources ............................................................ 72
Printer Reports ................................................................. 72
Types of Pre-Load Resources ............................................... 73

Appendix A: Glossary .......................................................... 75
Glossary .............................................................................. 76

Appendix B: Quick Guide ..................................................... 79
Quick Guide to Menu Commands ................................. 80
Quick Guide to Keyboard Shortcuts ......................... 81

Appendix C: Transferring Projects ................................. 83
Introduction ................................................................. 84
Connecting to the e-forms Server ................................. 85
Transferring Projects and Resources ......................... 86
Transferring Variable Subforms ................................. 87
Overwriting Files of Server ........................................ 88
Transfer History ........................................................... 89

Appendix D: Create!send ................................................. 91
Introduction ................................................................. 92
Support for Multiple Platforms ................................. 92
Create!send for OS/400 ................................................ 93
System Requirements .................................................... 93
Spool File Requirements ................................................ 93
Before Installing .......................................................... 94
Installing Create!send (OS/400) ................................. 94
OS/400 Spool File Attributes ..................................... 95
INTRODUCING CREATE!FORM SERVER

Create!form Server is the central server component of the Create!form™ Distributed Output Management (DOM) system. Create!form Server and related Create!form products are used to build your e-forms production system.

The following topics are covered in this chapter:

• Who is this User Guide For?
• User Guide Conventions
• Terminology
• Product Overview
• Supported Platforms
• Requirements
**Who is this User Guide For?**

This user guide is for people who administer Create!form Server, the server component of Create!form. It provides instructions for installing and operating Create!form Server on Windows platforms.

**User Guide Conventions**

Section headings are listed at the front of each chapter to assist you in finding the relevant information. In the electronic version of this document, clicking on these and other cross references will take you to the appropriate section. The following typographical conventions are used:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Convention Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Screen items, dialog options and buttons.</td>
</tr>
<tr>
<td><strong>cross reference</strong></td>
<td>Short-cut or reference to the document, chapter or section.</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Reference to other online manuals and technical notes.</td>
</tr>
<tr>
<td>Screen text</td>
<td>Commands entered by a user.</td>
</tr>
<tr>
<td>\Folder</td>
<td>Path names, directories and file names, e.g., C:\Program Files</td>
</tr>
<tr>
<td><strong>Key</strong></td>
<td>Keyboard keys. Two or more keys separated by the + symbol indicates that the first key or keys should be held down while pressing the last key, e.g. SHIFT + F1 means hold down the SHIFT key while pressing the F1 key.</td>
</tr>
<tr>
<td><strong>Item &gt; Sub-Item</strong></td>
<td>Menu selection; i.e., select the menu <strong>Item</strong> and then select <strong>Sub-Item</strong> from the drop-down list, e.g. **File&gt;**New.</td>
</tr>
<tr>
<td><strong>Numbering 1</strong></td>
<td>Step-by-step procedures. To perform an action, follow those instructions in the sequential order given.</td>
</tr>
</tbody>
</table>
Terminology

Throughout this user guide, you will see references to many different terms, some of which may be new to you. To familiarize yourself with the terminology used in this manual, please read the definitions provided in Appendix A: Glossary.
Product Overview

Create!form Server is part of the Create!form suite of products that allow users to prepare, format, produce, distribute and administer the transactional and document output of your enterprise server.

What would you like to know about?
- Create!form Workflow
- Create!form Components

Create!form Workflow

Create!form Server operates in conjunction with the print spooler native to the installation platform. The output from your enterprise server is spooled either directly to Create!form Server queues, or to specially configured print/output queues, where information is added to the job before being routed to Create!form Server. This process of tagging and routing jobs is performed by Create!send.

Create!form Server monitors the jobs submitted by the server application and Create!send, and processes the input file using the project defined for the print queue. Projects are designed using companion products Create!form Designer, Create!form Transform and Create!form Director. As jobs are submitted to different print queues, Create!form Server determines which project it should be processed with and builds an output file that can then be saved, published, printed, faxed, e-mailed or archived using other Create!form products – as shown in Figure 1.1, Create!form Workflow. The output file format is typically text, PostScript or PDF, depending on its intended destination, but other formats are supported.
Figure 1.1: Create!form Workflow
Create!form Components

The following Create!form products may be installed:

Create!form Designer

Create!form Designer is used to design form projects, which Create!form Server merges with the output of your enterprise server. The form project allows you to reformat and enhance the output of your enterprise server, incorporating logos, images and drawing objects, as well as formatted text.

Create!form Transform

Create!form Transform is used to design projects with which Create!form Server transforms the output of your enterprise server. The project allows you to restructure and reformat the output of your enterprise server, which may include text, CSV, XML and other file formats.

Create!form Director

Create!form Director is used to design projects with which Create!form Server splits and processes the output of the enterprise server, ready for merging, transforming, emailing, faxing and archiving.

The types of action that Create!form Director performs include:

- Splitting the spool file into multiple spool files
- Sending particular parts of the spool file to particular directories or queues
- Extracting data for use in reports
- Creating backup copies of the spool file
- Adding job ticket templates (JTTs) that determine various parameters used in processing by other Create!form products

Create!form Server

Create!form Server is the central processor which handles the output from your enterprise server, and applies the appropriate project designed with either Create!form Designer, Create!form Transform or Create!form Director. The output from Create!form Server can be printed, faxed, e-mailed or archived using other Create!form products.
Create!print

Create!print is called by Create!form Server to print the merged documents, and is installed automatically with Create!form Server on the e-forms server. Create!print is controlled and activated by Create!form Server without user interaction. A Create!print license is required for each print queue/device. To obtain additional Create!print licenses, contact your Create!form distributor.

Create!send

Create!send is a utility that inserts job information in the spool file as it is printed from your enterprise application. You can use Create!send to insert job header parameters that allow Create!form Server to process the job. Create!send is available for sending spool files from OS/400, UNIX, Windows and VMS platforms.

Create!email

Create!email lets you automatically email the merged documents. For more information on Create!email, contact your Create!form distributor.

Create!fax

Create!fax lets you automatically fax the merged documents. For more information on Create!fax, contact your Create!form distributor.

Create!archive

Create!archive lets you automatically archive the merged documents on an intranet or the internet, where they can be accessed under secure, password control. For more information on Create!archive, contact your Create!form distributor.

Create!barcode

Create!barcode is an optional module that takes a collection of files, typically a collection of invoices and purchase orders for a single client, and produces a single PDF. The bound document can then be sent to Create!form Server for processing.
Create!micr

Create!micr lets you print documents containing MICR (Magnetic Ink Character Recognition) text, which is used in the banking industry for check printing. The evaluation version of Create!micr can be installed from the installation CD.

Create!pdf server

Create!pdf server lets you create documents in PDF output format, which is typically required for sending documents to Create!email, Create!archive and PDF enabled print devices. Create!pdf server is installed with the Windows version of Create!form Server and requires a separate license. To obtain a license for Create!pdf server, contact your Create!form distributor.
Supported Platforms

Create!form Server can be installed on Microsoft® Windows platforms. Any jobs printed to a Windows print queue can be merged by Create!form Server. Additional components included with this package let you configure jobs sent from Windows, OS/400, UNIX or VMS host systems (Appendix D: Create!send), or you can define your own instructions for configuring spool file jobs sent from any server application.
Requirements

The following are required to install and use Create!form Server:

**Prerequisites**

- Basic familiarity with Windows concepts
- Basic familiarity with word processing or publishing software
- Familiarity with report printing on your enterprise server

**Enterprise server**

Create!form Server can work with the following types of spool files output by the enterprise server:

- Plain ASCII text files (with or without a job header)
- CSV data files
- XML transactional data files
- PeopleSoft EnterpriseOne reports (JDE PDF): B73.3.2 (cum 2) SP14.2 or B73.3.3 (Xe) and above

Depending on the capabilities of the program used, it may be possible to configure the server application to attach the job header parameters to the spool file, or you may need to install the Create!send utility, which is available for sending spool files from OS/400, UNIX, Windows and VMS platforms.

For more information, refer to the Chapter 2 Implementation General.

**e-forms server**

Before you can start printing, you must install and configure Create!form Server on the network e-forms server. Depending on your preferred output format, you may also need to install other Create!form components. You will find an overview of how to install and configure your e-forms production system in the Chapter 2 Implementation General.
IMPLEMENTATION GENERAL

The configuration of your Create!form e-forms production system will depend on the types of input and output you need to accept and generate.

The following topics are covered in this chapter:

• Installation Components
• Implementation Road Map
• Configuration Options
## Installation Components

A Windows Create!form installation may include the following components:

### Legend

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>l</td>
<td>required component installed from Create!form CD</td>
</tr>
<tr>
<td>H</td>
<td>auto-installed with other components</td>
</tr>
<tr>
<td>m</td>
<td>optional component available form Create!form CD</td>
</tr>
<tr>
<td></td>
<td>optional component available from other product CD</td>
</tr>
</tbody>
</table>

### Component Table

<table>
<thead>
<tr>
<th>Component</th>
<th>Function</th>
<th>Install on</th>
<th>Platform</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Create!form Designer</td>
<td>form projects</td>
<td>design workstation</td>
<td>Windows</td>
</tr>
<tr>
<td>H Create!form Transform</td>
<td>transform projects</td>
<td>design workstation</td>
<td>Windows</td>
</tr>
<tr>
<td>1 Create!form Director</td>
<td>pre-processing and publishing projects</td>
<td>design workstation</td>
<td>Windows</td>
</tr>
<tr>
<td>m Create!micr</td>
<td>check printing font</td>
<td>design workstation</td>
<td>Windows</td>
</tr>
<tr>
<td>Server Components</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Create!form Server</td>
<td>print queue management and merge engine</td>
<td>e-forms server</td>
<td>Windows</td>
</tr>
<tr>
<td>Delivery Components</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>m Create!send</td>
<td>spool file delivery</td>
<td>enterprise server</td>
<td>OS/400 UNIX, Windows, VMS</td>
</tr>
<tr>
<td>Output Components</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>H Create!print</td>
<td>PostScript output</td>
<td>e-forms server</td>
<td>Windows</td>
</tr>
<tr>
<td>H Create!pdf server</td>
<td>PDF and PCL output</td>
<td>e-forms server</td>
<td>Windows</td>
</tr>
<tr>
<td>Create!fax</td>
<td>fax output</td>
<td>e-forms server</td>
<td>Windows</td>
</tr>
<tr>
<td>Create!email</td>
<td>email output</td>
<td>e-forms server</td>
<td>Windows</td>
</tr>
<tr>
<td>Create!archive</td>
<td>archive output and management system</td>
<td>archive server</td>
<td>Windows</td>
</tr>
</tbody>
</table>

For more information on the optional components, refer to Product Overview, or contact your Create!form distributor.
Design Components

Create!form Designer

Create!form Designer is installed on a Microsoft Windows workstation with a network connection to the e-forms server.

Create!form Transform

Create!form Transform is installed on a Microsoft Windows workstation with a network connection to the e-forms server.

Create!form Director

Create!form Director is installed on Microsoft Windows workstation with a network connection to the e-forms server.

Server Components

Create!form Server

Create!form Server is installed on the Windows e-forms server and is the central processor that handles output from your enterprise server.

Create!form Director

Create!form Director can also be installed on the Windows e-forms server.
**Delivery Components**

**Create!send**

Create!send is installed on the enterprise server to deliver spool files to Create!form Server print queues.

**Output Components**

**Create!print**

A license is required for each output device.

**Create!pdf Server**

If required, you must obtain a license for Create!pdf server.

**Create!fax and Create!email**

If required, install and license the required components on the e-forms server.

**Create!archive**

If required, install and license on the archive server. The Create!archive port must also be installed on the e-forms server.
Implementation Road Map

This section provides a road map on how to install and configure your e-forms production system. For each step there is a reference to the relevant section in this manual, or to other product manuals, where you will find detailed instructions for the task described. Any optional steps are shown shaded gray; you must perform all other steps to successfully implement your e-forms production system.

**Important**

*If you are upgrading from an earlier version of Create!form Server, before you install the upgrade, please refer to the release notes located in the \Readme directory of the installation CD.*

Steps shown with a shaded background are optional.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
<th>Related Manual</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Install Create!form Designer.</td>
<td>Create!form Designer User Guide</td>
</tr>
<tr>
<td>2.</td>
<td>Install Create!form Transform.</td>
<td>Installed automatically with Create!form Director</td>
</tr>
<tr>
<td>3.</td>
<td>Install Create!form Director.</td>
<td>Create!form Director User Guide</td>
</tr>
<tr>
<td>4.</td>
<td>If you need to use the MICR font for printing checks/cheques and other specialized payment forms, install Create!micr on the design workstation.</td>
<td>Create!micr User Guide</td>
</tr>
</tbody>
</table>

**Install Server Components**

Create!form Server is installed on the e-forms server.

5. Install Create!form Server on the e-forms server. | Chapter 3, Installing |

**Install Output Components**

To generate output from Create!form Server, a compatible output product must also be available on the e-forms server.
### Implementation Road Map

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
<th>Guide</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.</td>
<td>PostScript output.</td>
<td>Create!print is installed automatically on the e-forms server with Create!form Director.</td>
</tr>
<tr>
<td>7.</td>
<td>PDF output.</td>
<td>Create!pdf server is installed automatically on the e-forms server with Create!form Director.</td>
</tr>
<tr>
<td>8.</td>
<td>If you need to output the merged document as a fax, install Create!fax on the e-forms server.</td>
<td>Create!fax User Guide</td>
</tr>
<tr>
<td>9.</td>
<td>If you need to output the merged document as an email, install Create!email on the e-forms server.</td>
<td>Create!email User Guide</td>
</tr>
<tr>
<td>10.</td>
<td>If you need to archive the merged document, install Create!archive on the archive server.</td>
<td></td>
</tr>
<tr>
<td>11.</td>
<td>If the archive server and e-forms server are separate machines, you must also install the Create!archive port on the e-forms server.</td>
<td>Create!archive User Guide</td>
</tr>
</tbody>
</table>

### Design Projects
Create designs for each of your projects.

<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
<th>Guide</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.</td>
<td>From Create!form Designer, design your form projects.</td>
<td>Create!form Designer User Guide</td>
</tr>
<tr>
<td>13.</td>
<td>From Create!form Transform, design your transform projects.</td>
<td>Create!form Transform User Guide</td>
</tr>
<tr>
<td>14.</td>
<td>From Create!form Director, design your Director projects.</td>
<td>Create!form Director User Guide</td>
</tr>
</tbody>
</table>

### Transfer Projects to the e-forms server
To put your projects into production, projects and other resources need to be available on the e-forms server.
<table>
<thead>
<tr>
<th>Step</th>
<th>Description</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>15.</td>
<td>From Create!form Designer, transfer projects from the design workstation to the e-forms server.</td>
<td>Appendix C, Transferring Projects</td>
</tr>
<tr>
<td>16.</td>
<td>From Create!form Transform, transfer projects from the design workstation to the e-forms server.</td>
<td>Appendix C, Transferring Projects</td>
</tr>
<tr>
<td>17.</td>
<td>From Create!form Director, transfer projects from the design workstation to the e-forms server.</td>
<td>Appendix C, Transferring Projects</td>
</tr>
<tr>
<td>18.</td>
<td>On the e-forms server, create a print queue for each installed output component and project combination.</td>
<td>Chapter 4, Adding Print Queues</td>
</tr>
</tbody>
</table>

**Add Print Queues**

Create!form Server uses standard Windows print queues on the e-forms server. The print queue determines the format and destination of the merged output.

**Configure Print Queues**

Once the print queue is available, you can enable the queue as a Create!form Server queue and define its properties.
**Select Default Projects**

If the required project is not specified in the job header, a default project can be specified, specific to each print queue. Do not set a default form project if the output queue will be used for more than one project, or if you are running Create!form Server version 6 in parallel with an earlier version.

**Install and Configure Delivery Components**

Create!form Server uses information attached to the spool file to determine which form project is to be merged with each job.
If you need to pre-process the spool file before it is merged at a Create!form Server print queue, Create!form Director can split and copy the original spool file, attaching a different job header to each of the copies or splits, and direct each to a different queue. If you require Create!form Director, you must complete steps 14 and 17 before proceeding to the next step.

On the enterprise server, where the job originates, the job header parameters can be attached to the spool file in a number of ways:

21. Install Create!send on the system where the application initiates the print operation (the server application), which could be on a Windows, OS/400, VMS or UNIX platform. Appendix D, Create!send

22. Depending on the capabilities of the program used, it may also be possible to configure the server application to attach the job header parameters to the spool file. Contact your supplier.

23. If you have installed Create!form Director, a delivery system is still required to send the spool file to a Create!form Director print queue and identify the project that Create!form Server will use to process the file. Select one of the options above.
**Commence Production Printing**

Once Create!form Server is installed and configured, jobs sent from the server application to Create!form Server print queues will be automatically handled by Create!form Server. A typical workflow for PostScript printer output is shown in Figure 2-2, Production printing.

1. The application on the enterprise server outputs the spool file to a Create!send print queue.
2. Create!send picks up the spool file, attaches the job header and sends it to a create!form Server print queue on the e-forms server.
3. Create!form Server picks up the spool file and merges it with the form project specified in the job header.
4. If a Create!form Director project is specified, the spool file is processed and the resulting parts are then sent to other Create!form Server print queues and destinations.
5. Create!print generates the PostScript output using the options set for the print queue.
6. The PostScript output is sent to the specified print device.

*Figure 2.2: Production Printing*

To start production printing, refer to Chapter 5, *Production Printing*. 
Configuration Options

Network Configurations

You can install the Create!form components on a network to suit your own network configuration and workflow requirements. The options range from installing the design, server and output components on a single PC and using a local printer, to separate installations on dedicated workstations and servers on a network.

Multiple e-forms servers

If required, Create!form Server may be installed on multiple e-forms servers and run concurrently. This will allow you to use the same set of shared resources (such as form projects and system files) across multiple systems.

To share the resources between systems, the resource directory setting (for more information refer to Chapter 4, Resource Directory) in each Windows installation must be the same.
Impersonating a Network User

This Create!form Server feature, available from the Windows Identity option in the Tools menu, enables the server’s spoolers process to run as an authenticated network user when running Create!form projects. This allows for secure access to certain network resources and can be extremely useful when having a Director project run which attempts to write a network share.
INSTALLING

Create!form Server is installed on the Windows e-forms server from the Create!form installation CD.

The following topics are covered in this chapter:

• Installation Requirements
• Installing
• Starting
• Getting Help
• Licensing
Installation Requirements

Create!form Server requires the following:

- Administrator privileges are required to perform the installation
- Microsoft Windows 2000/2003 Server
- 512 MB RAM
- 30 MB of free hard disk space
- Microsoft Internet Explorer 5.0 or greater
- Adobe Reader 4.05 or greater
- PostScript Level 2 printers or greater
- Microsoft TCP/IP Printing Services installed and started (if you use TCP/IP to connect to the e-forms server)

For information on installing the Microsoft TCP/IP Printing Services, refer to Windows Help.
Installing

The Create!form installation CD contains the Create!form Server application which must be installed on the e-forms server.

For more information on upgrading from an earlier version, refer to the upgrade notes located in the \Readme directory of the installation CD.

To install Create!form server

1. Log on as a user with administrator rights.

2. Insert the CD. The installation screen should be displayed automatically.

3. If it is not started automatically, run the CForm.exe program located in the root directory of the CD.

4. Click Install Products, then choose Create!form Server. The Create!form Server installation program will be started.

5. Continue through the installation program by pressing Next, and follow the on-screen instructions. Once installation is complete, you will return to the Install Products screen.

6. Continue installing additional products if required, or click Main Menu to finish.

7. From the Main menu, click Exit to close the Create!form install program.
Starting

To start Create!form server
- Click the Windows Start button and select Programs > Create!form > Create!form Server 6.

Create!form Server will be displayed and show all locally installed print queues.
Getting Help

Help is available in both Portable Document Format (PDF) and as online help.

To view and print the PDF User Guide
• Open the file Create!form 6.2 pdf with Adobe Reader from the \Manuals directory on the installation CD
• From the Windows Start menu, select
  Programs > Create!form > Manuals > Create!form server

To view the online help
• Start Create!form Server and select Help>Help Topics from the Main menu
Licensing

Before you can use Create!form Server, you must obtain a license key from your software distributor. You may be given a temporary license key if you are evaluating the product; however, for continued operation you will require a permanent license key.

In order to issue you a permanent license key, you must inform the distributor of your authorization code.

To view the Authorization code
1. From the Start menu select Programs > Create!form > Create!form Server 6. Create!form Server will start.
2. From the Main menu, select Tools > License Keys. The Create!form License Keys dialog will be displayed, with the authorization code shown at the top.

To enter the Create!form Server License key
1. Select Tools > License Keys to display the License Key dialog.
2. Click Create.
3. Enter the license key provided by your distributor and click OK.

Displaying License Details

To check that the license key information is correct and current, you can review the current status in the Create!form License Keys dialog.

To review the current status in the Create!form License Keys dialog
1. Select Tools > License Keys. The license key dialog will be displayed and contain a list of all license keys entered for Create!form products.
2. Select a license key from the list and click Display. The Create!form License Key Display dialog will list the products that are enabled by the selected license key.

Contact your software distributor for information on obtaining licenses for other Create!form products.
SETTING UP PRINT QUEUES

You must setup print queues and configure Create!form Server before you start production printing.

The following topics are covered in this chapter:

- Overview
- Project Directories
- Transferring Projects
- Adding Print Queues
- Configuring Print Queues
- Managing Print Queues
Overview

Documents sent to Create!form Server are managed using Windows print queues. You can add and configure as many print queues as you want. Depending on how you use Create!form Server and the output modules, you can dedicate different print queues to different types of documents, or different output modules.

The following flowchart summarizes the procedure used to add and configure Create!form Server print queues:

![Configuration flowchart]

Figure 4.1: Configuration flowchart
Project Directories

Create!form Server looks for resources in several locations.

What would you like to know about?

• Print Queue Project Directories
• Default Project Directory
• Resource Directory

Print Queue Project Directories

Each print queue can have its own project directory. In production printing, Create!form Server will look in this directory for any matching projects.

Default Project Directory

When defining a new print queue, the default project directory will be displayed.

To set the default project directory

1 From the main menu, select Tools > Server Options. The Options dialog will be displayed.

2 Type the path in the Default project directory field or click the Browse Folders icon and select the path.

3 Click OK.

Resource Directory

Create!form Server looks for other project resources in specific folders under the resource directory, located on the e-forms server. These resource folders include:

• CommonProject
• SystemResource
• Win32User

These resources are common to all Create!form print queues.
**Note**

You must exercise caution when changing the resource directory. If the resources cannot be found, Create!form Server will not be able to produce any output.

---

**To set the resource directory**

1. From the Main menu, select Tools> Server Options. The Options dialog will be displayed.
2. Type the path in the Resource directory field or click the Browse Folders icon and select the path.
3. Click **OK**.
Transferring Projects

In order for the projects to be used in production, you must transfer all project resources to the e-forms server. To transfer a project, start the design program you used to create the project and use the Tools > Transfer command.

The following table shows the location of the project resources on the design workstation and where they must be transferred to on e-forms server.

<table>
<thead>
<tr>
<th>Project Resource</th>
<th>Location on Design Workstation</th>
<th>Destination on the e-forms Server</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project file and DataMap</td>
<td>project directory</td>
<td>print queue project directory or common project directory</td>
</tr>
<tr>
<td>Subforms</td>
<td>project directory or common project directory</td>
<td>print queue project directory or common project directory</td>
</tr>
<tr>
<td>Fonts, tray mapping, environment variables, merge configurations and named destination</td>
<td>\SystemResource folder and sub-folders</td>
<td>\SystemResource folder and sub-folders</td>
</tr>
<tr>
<td>Bar codes</td>
<td>Not transferred</td>
<td>Installed with Create!form Server</td>
</tr>
</tbody>
</table>

For instructions on how to transfer projects with Create!form Designer, Create!form Transform and Create!form Director, refer to Appendix C, Transferring Projects.

Note

When transferring projects from the design workstation, the existing resources on the e-forms server, including environment variable, merge configuration and named destination configuration files, will be over-written.
Adding Print Queues

Create!form Server uses standard Windows print queues, which are then configured as Create!form Server print queues.

To add a new print queue

- Use the Windows Add Printer Wizard (for more information refer to Windows Help). Refer to the table below for information on selecting the printer port.

For additional information on setting up print queues, refer to:
- Selecting the Output Port
- Sharing Print Queues

Selecting the Output Port

The port you configure will depend on the output module you will be using with the print queue. The following table explains which port is required for which output module.

<table>
<thead>
<tr>
<th>Output Module</th>
<th>Output Port</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create!print</td>
<td>LPT1: to print to a local attached printer</td>
</tr>
<tr>
<td></td>
<td>TCP/IP port if printing to a network printer</td>
</tr>
<tr>
<td>Create!archive</td>
<td>CpArchivePort</td>
</tr>
<tr>
<td>Create!email</td>
<td>CpEmailPort</td>
</tr>
<tr>
<td>Create!fax</td>
<td>CpFaxPort</td>
</tr>
</tbody>
</table>

Sharing Print Queues

To enable jobs to be sent from the enterprise server to the Create!form Server print queue, you must share the print queue.
To set sharing and user access permissions on a print queue

Note

These procedures may vary with the version of Microsoft Windows.

1. From the Windows Print dialog, right-click on the print queue and select **Properties** from the shortcut menu.

2. From the `<name of printer>` Properties dialog, select the **Sharing** tab.

3. To enable print queue sharing, click the **Shared as** radio button and type a share name.

4. Select the **Security** tab. In the dialog displayed, it is recommended that you allow everyone to print, manage printers and manage documents. This is particularly important when submitting jobs from other platforms such as OS/400 or UNIX.

5. Click **OK** to continue.
Configuring Print Queues

Once you have added a print queue, you must configure it as a Create!form Server print queue.

To enable a print queue as a Create!form queue

1. Start Create!form Server. All local print queues will be displayed.

2. Right-click the print queue you want to enable and select Enabled from the shortcut menu.

All print queue settings are made from the Queue Properties dialog in Create!form Server (Queue Properties).

About Print Queue settings

- Project Directory
- Default Project
- Merge Configuration
- No Matching Project
- Reprinting
- Environment Variables

Queue Properties

To display print queue properties

1. Start Create!form Server. All local print queues will be displayed.

2. From Create!form Server, do one of the following to display the Queue Properties dialog.
   - Double-click on the print queue that you want to configure.
   - Select the print queue you want to configure and from the Main menu, select Queue > Properties.
   - Right-click on the print queue you want to configure and select Properties from the shortcut menu.

All configuration procedures that follow are performed from this dialog.
To configure a print queue

Before you start configuring a print queue, ensure that no jobs are currently being processed.

From the General pane:

1. In the Project directory field, type the path name of the folder where Create!form Server will look for matching projects, or click the Browse Folders icon and select the path.

2. In the Default project field, select the default project from the drop down list.

Note

Refer to Transferring Projects for information about where project resources are located on the e-forms server.

3. In the Default merger configuration field, select from the available merge configurations, or select Manage from the drop down list to create a new merge configuration.
4  In the Action when no matching project section, select how the job will be handled when no matching project is found.

From the Advanced pane:

5  Select whether the job is to be kept for reprinting, for how long, and whether the reprint job will be sent to a different queue.

From the Environment Variables pane:

6  Define any environment variables that you want to change the values in this queue from the values defined in the environment variables configuration file (Refer to Environment Variables for more information).

7  Click OK.

**Project Directory**

When a job is received, Create!form Server looks in the project directory for the matching project.

**Default Project**

When a job is received that does not specify a project, Create!form Server will attempt to use the default project. The default project must be located in either the project directory or the CommonProject directory located under the e-forms server resource directory (refer to Resource Directory for more information).

Refer to Locating the Project for more information on how Create!form Server determines what project to use.

**Merge Configuration**

The merge configuration controls how the spool file will be merged with the project, including various output options.

**To display and edit merge configuration settings**

1  From the Main menu, select Tools > Merge Configurations dialog. The merge configurations currently defined will be displayed in the Merge Configurations dialog. You can also access the Merge Configurations dialog from the General pane of the Queue Properties dialog.
2 Select the configuration you want to edit and click the Properties icon.

3 Edit the configuration settings as required. For more information about these settings refer to:
   - Output Formats
   - Job Ticket
   - Imaging
   - Printer Settings
   - Header/Trailer Files

4 Click OK.

To create a new merge configuration

1 From the Main menu, select Tools > Merge Configurations. The merge configurations currently defined will be displayed in the Merge Configuration dialog. You can also access the Merge Configurations dialog from the General pane of the Queue Properties dialog.

2 Click the Add Row button. The Create Merge Configuration dialog will be displayed.

3 In the Name field, type the name of the new configuration.

4 In the Based on field, select which of the available configurations you want to initially copy.

5 Click OK. The Merge Configuration - <name> dialog will be displayed. The initial settings in this dialog will be the same as the configuration you selected in the previous step.

6 Edit the configuration settings as required. For more information about these settings refer to:
   - Output Formats
   - Job Ticket
   - Imaging
   - Printer Settings
   - Header/Trailer Files
   - Banner and Trailer Pages
7 Click OK.

Output Formats

Each print queue can output merged documents in PostScript, PDF or PCL/Other. The option you choose will depend on the output module you use with that queue.

<table>
<thead>
<tr>
<th>Output module</th>
<th>Recommended output formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create!print</td>
<td><strong>PostScript</strong> when the printer is PostScript capable (recommended)</td>
</tr>
<tr>
<td></td>
<td>PCL when PostScript is not available</td>
</tr>
<tr>
<td></td>
<td>PDF when you are sending to a PDF capable print queue</td>
</tr>
<tr>
<td>Create!archive</td>
<td><strong>PostScript</strong> for Create!archive 2.7 or greater (recommended)</td>
</tr>
<tr>
<td>Create!email</td>
<td>PDF</td>
</tr>
<tr>
<td>Create!fax</td>
<td><strong>PostScript</strong></td>
</tr>
</tbody>
</table>

For more information on the format options, refer to the relevant format:

- PostScript Options
- PDF Options
- PCL/Other Options

PostScript Options

PostScript output enables you to specify whether you want all resources sent with each job or whether resources should be stored on the printer, which can speed up the printing process. Because of these benefits, PostScript output is recommended for printing jobs where possible.

The following options are displayed on the Postscript pane of the Merge Configuration dialog:

Resources

(none)

Select (none) to have Create!form Server interrogate each print job and send all resources required for that job for each print run. This is the default and must be used if the print queue does not have any storage capabilities or if the
printer is repeatedly being reset, or when outputting to Create!fax or Create!archive.

The other storage location options will pre-load image (.eps) subforms, bar codes and fonts with the first print job that is sent to the printer. For subsequent jobs processed on that queue, only new or updated subforms will be loaded to the print queue.

**Memory**

The Memory option will store resources in the printer’s volatile memory. The print queue will retain the loaded resources until the printer is switched off or reset.

**File System**

The File System option will store resources on the printer’s largest writable device. This may be a flash device or a hard disk. Resources will stay on the storage device until you remove them or the device is formatted.

**Specify**

You can also directly specify the storage device by typing the address in the field displayed. The address is device dependent. High-end printers that use a hard disk may require a directory path to be defined as the storage address. Please refer to your Network/Printer Administrator on what path is required.

The following are the recommended settings for the Create!form output modules:

<table>
<thead>
<tr>
<th>Output Module</th>
<th>Storage Location Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create!print</td>
<td>• Memory pre-loads printing resources to printer memory</td>
</tr>
<tr>
<td></td>
<td>• File System pre-loads printing resources to printer disk</td>
</tr>
<tr>
<td></td>
<td>• Specify pre-loads printing resources to specified storage address</td>
</tr>
<tr>
<td></td>
<td>• (none) if printer does not have a storage device</td>
</tr>
<tr>
<td>Create!archive</td>
<td>(none)</td>
</tr>
<tr>
<td>Create!email</td>
<td>(none)</td>
</tr>
<tr>
<td>Create!fax</td>
<td>(none)</td>
</tr>
</tbody>
</table>

**Omit end of job (04) marker**

Select the checkbox to omit the EOJ marker on OS/400 spool files.
**Printer Control file**

If required, select a tray mapping file. For information about defining tray mapping refer to chapter five, *Tray Mapping*.

**PDF Options**

PDF output is required for email and archive options, and PDF enabled printers. You must purchase Create!pdf server to use the PDF output format. For information on purchasing Create!pdf server, consult your Create!form distributor.

---

**Note**

*PostScript output can also be sent to the archive watch directory.*

Create!pdf server is, however, still required to convert the PostScript to *PDF*.

---

**PCL/Other Options**

Create!form Server can output the processed job in PCL (Printer Control Language) when PostScript is not supported by the print device, for example a Zebra label printer.

The following options are displayed on the PCL/Other pane of the Merge Configuration dialog:

**PCL options: Drivers**

Choose from the list of pre-defined print queue drivers. For maximum quality it is recommended that you use one of the listed drivers such as the HP PCL-XL (Color) driver. The output file size will vary depending on the driver you select.

You can also use the Window print driver specified for the print queue by selecting the (User Windows driver) option. Selecting this option can produce very large output files.

**Job Ticket**

Jobs can come from the enterprise server with a Create!send header or from Create!form Director with a .jtt file as a header. You can specify whether the queue should remove the header (and any parameters defined within it) or keep the header.
The following options are displayed on the Output pane of the Merge Configuration dialog:

**Job Ticket**

The option you choose will depend on the output module you use with the queue.

<table>
<thead>
<tr>
<th>Output module</th>
<th>Job ticket setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create!print</td>
<td>Remove</td>
</tr>
<tr>
<td>Create!archive</td>
<td>Remove</td>
</tr>
<tr>
<td></td>
<td>Note for Create!archive 3.0: If you are using encryption parameters and the output is set to PostScript, then this should be set to Keep.</td>
</tr>
<tr>
<td>Create!email</td>
<td>Keep - email details are retained.</td>
</tr>
<tr>
<td>Create!fax</td>
<td>Keep - fax details are retained.</td>
</tr>
</tbody>
</table>

**Imaging**

You can re-position and re-size a merged document so that it prints exactly as you want. This may be required when the destination printer is changed (e.g. due to an equipment failure) and the new printer has different printable margins, or when the print media is changed.

The following options are displayed on the Printer pane of the Merge Configuration dialog:

**Shift**

- To shift an image horizontally on the page, enter the distance (in points) you wish to shift the image in the Shift and X field. A positive value will shift the image to the right, a negative value will shift the image to the left.
- To shift an image vertically on the page, enter the distance (in points) you wish to shift the image in the Shift and Y field. A positive value will shift the image down, a negative value will shift the image up.

**Note**

1 inch = 72 points

*e.g. Letter size = 8.5" x 11" = 612 x 792 points*
1 cm = 28.35 points

\[ \text{e.g. A4 size } = 21 \text{ cm} \times 29.7 \text{ cm} = 595.35 \times 842 \text{ points}. \]

**Scale**
- To stretch or reduce the image horizontally on the page, enter the scaling factor in the Scale and X field.
- To resize the image vertically on the page, enter the scaling factor in the Scale and Y field.

A value less than 1 will reduce the size of the image, while a value greater than 1 will increase the size of the image. A value of 0 or 1 will not change the size of the image. When resized, the image will remain centered on the page (unless the Shift option is also used).

**Printer Settings**
The following options are displayed on the Printer pane of the Merge Configuration dialog:

**Ignore duplexing**
Select the checkbox to print single-sided.

**Center guttered pages**
Select the checkbox to center pages that have a guttered page style.

**Pages per sheet**
Select the number of pages printed on one sheet.

**Rotate landscape pages by 180°**
Select the checkbox to rotate printing of landscape page styles.

**Header/Trailer Files**
Header and trailer files can be added to the merged document to provide additional instructions for the printer. For example, a PJL (Printer Job Language) header file can be sent to turn on PostScript emulation, change the print resolution and turn on color management options; a PJL trailer file can be sent to reset the printer back to normal print mode.

Refer to your printer manual for supported PJL commands.
Header and trailer files must be stored in the `\SystemResource\Device` folder under the Resource Directory.

The following options are displayed on the Printer pane of the Merge Configuration dialog:

**Header file**
Select a header file from the available files.

**Trailer file**
Select a trailer file from the available files.

**Banner and Trailer Pages**
You can attach subform files (*.cff6) as banner and trailer pages on each print job using the following options on the Banner pane of the Merge Configuration dialog:

---

**Note**
*For more information on creating subforms and how variables are evaluated in subforms, refer to the Create!form Designer user guide.*

---

**Banner page**
- **Form**
  Create!form Server will look for subforms first in the project directory, and then in the common project directory.
- **Input tray**
  Select the printer input tray for the banner page.

**Trailer page**
- **Form**
  Create!form Server will look for subforms first in the project directory, and then in the common project directory.
- **Input Tray**
  Select the printer input tray for the banner page.
No Matching Project

When a spooled file is sent to a Create!form Server print queue and no matching project is found, the job cannot be merged. The job can either be logged as a failed job or passed through, unmerged, to the output port. When a job fails, the print queue is displayed with a red icon and the failed job is held in the queue awaiting further action by the operator. (For more information refer to chapter five, Failed Jobs.)

Reprinting

After documents are sent to a Create!form Server print queue, they can be kept or deleted. Keeping documents enables you to perform various functions using the Reprint Manager. The functions include the ability to view, reprint or redirect documents.

For information on starting and using the Reprint Manager, refer to chapter five, Reprinting Jobs.

Depending on how long you want to keep documents for, you should check that your hard drive space is adequate. Documents can be kept for a maximum of 30 days.

Environment Variables

Environment variables are common to all projects in the production environment. Environment variables may be the same for all output destinations, or can be changed for individual print queues. Typical uses of environment variables include setting values that are used in all projects, like a company name, or using different projects depending on whether the destination is a printer, fax, email or archive server port.

Environment variables are stored in the EnvironmentVars.data file in the SystemResource folder, which will be sent to the e-forms server when the project is published.

To create an environment variable

1. From the Main menu, select Tools > Environment Variables. The Environment Variables dialog will be displayed.
2. To create a new environment variable, click the Add Row button.
3. Type the name of the environment variable in the Name field.
4. Type the value of the environment variable in the Value field.
5 Click OK.

**Configuring Multiple Print Queues**

Create!form Server lets you partially configure multiple print queues simultaneously. (The options associated with the particular output format are the only options that you must specify individually for each print queue.)

You can also copy the settings of one print queue onto several other print queues.

**To configure multiple print queues**

1 In Create!form Server, hold down the shift key to select multiple print queues.

2 From the Main menu select Queue>Properties. The Queue Properties - Multiple Selection dialog will be displayed.

3 Make the required changes and click OK. You will be prompted to confirm that you want to make the changes to all selected print queues.
Managing Print Queues

Viewing Print Queues

All locally installed print queues are displayed in Create!form Server as either large icons, small icons, or in list mode.

In list mode, you can sort print queues by:

• Name, which sorts the print queues alphabetically
• Status, which sorts the print queue in the following order:
  • Create!form Server enabled print queues that are in error
  • Create!form Server enabled print queues
  • Other types of Create!form print queues
  • Non Create!form print queues

To change the view mode or sort order

Select the required option from the View menu or the shortcut menu.

Print queue icons

All print queues that are configured for use with a Create!form product will be tagged with colored icons to indicate their status. The following table explains the three colored icons:

Table 4.1

<table>
<thead>
<tr>
<th>Icon</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Green Icon" /></td>
<td>The green icon indicates that the print queue has been configured with Create!form Server.</td>
</tr>
</tbody>
</table>
Testing Print Queues

When you have finished configuring your print queue(s), you can test if Create!form Server has been set up correctly for each queue, by performing a test merge that is sent to the designated output port. Any print queue that has been enabled can be tested, as long as you have the appropriate output license.

To perform a test merge to a selected print queue

1. Double-click on the configured print queue to open the Queue Properties dialog.
2. Click the Test button. The Select Test File dialog will be displayed.
3. Select an input file that is compatible with the default project.
4. Click Open. The test job will be sent to the port in use by the print queue.

Viewing the Status of Print Jobs

You can view the status of documents as they are being processed by Create!form Server, in the same way you would any other document being printed in Windows.

To view the documents currently in a print queue

Do one of the following

- Select the print queue and from the Main menu, select Queue>Open Printer
- Right-click the print queue and select Open Printer from the shortcut menu

You can also open print queues from the Windows Printers dialog.
Log File Options
Create!form Server can record different types of activity for each configured print queue. Log files are normally stored in the \<install dir>\Temp directory.

- Global log file settings for all Create!form products, such as how long to keep log files for
- Which events should be recorded for each Create!form Server print queue

To set the global logging options
1. Select Tools>Log File Settings from the Main menu. The Log File Settings dialog will be displayed. Any changes made to fields in the Global log file settings section will affect all installed Create!form products.
2. Click Browse to change the location for storing log files in the Path field.
3. Enter the number of days to store log files. Create!form Server stores log files for a specific period of time, depending on what is set in the Remove log files after days field. By default, this value is set to 7 (i.e. remove log files that are older than 7 days). Selecting 0 in this field will cause log files to be removed at the end of the day on which they were created. Previous log files have the date appended to the filename, for example: <print queue name>yyyyymmdd.log where yyyyymmdd represents the log file date.
4. Select whether to log warning messages if the disk is nearing capacity. By default, Create!form Server places a message in the log file when the disk becomes 90% full. If you want to continue logging without checking disk capacity, enter 0 in the Log a warning message if disk is % full field.
5. Select whether to stop logging if the disk is nearing capacity. By default, Create!form Server will no longer store log files once the disk is 95% full. If you want to continue logging without checking disk capacity, enter 0 in the Stop logging if disk is % full field.
6. Click OK.

To set logging options for a print queue
1. Select the print queue.
2. From the Main menu select Tools>Log File Settings dialog. The Log File Settings dialog will be displayed.
3. In the <print queue name> events to be recorded section, set the level required for logging.
4  Click OK.

Enabling Database Access for Lookup Variables

If your form projects use lookup variables that call data from databases that have some password requirements, you will need to enable access to the database(s) from Create!form Server. For information on lookup variables, refer to the Create!form Designer user guide.

To provide Create!form Server with access to database(s)

1  From the Create!form Server Main menu, select Tools>Server Options. The Options dialog will be displayed.

2  In the Databases section, click the Add Row button.

3  In the Database column, type the name of the database or the DSN of the database. This will be the same name you use for the database when you create the lookup variable in Create!form Designer.

4  In the Connection string column, type the connection string used to access the database and enter any passwords required to access the database. Create!form Server will remember these passwords for production printing.

5  Click OK.
SETTING UP PRINT QUEUES

- Managing Print Queues
PRODUCTION PRINTING

Tools are provided to assist you with the task of managing your production printing system.

The following topics are covered in this chapter:

• Basic Workflow
• Advanced Topics
• Job Handling
• Managing Printer Resources
Basic Workflow

Create!form Server runs within the Windows print spooler system. As such, it is active as long as the Windows print spooling system and its services, such as the print spooler and TCP/IP Print Server services, are active. Once a print queue on e-forms server has been configured, Create!form Server will automatically process any documents sent to it.

The following flowchart describes the basic production workflow of incoming job files being processed by Create!send and Create!form Server. For more information about particular steps, refer to the cross-referenced sections or products.
Document Data Type

When a job is submitted to a print queue, one of its attributes is its data type. This attribute is based on the application that generated and submitted the document.

If the data type is RAW, the document is then sent to the server to be processed.
If the data type is not RAW, it is assumed that the document is already formatted and it is passed directly through to the output port.

**Locating the Project**

If the input file has a Create!form job header, Create!form Server will look for the project specified in the header. Create!send (Appendix D: Create!send) and Create!form Director are used to set job headers.

If the input file does not have a Create!form job header, Create!form Server will look for the default project specified for the print queue (Chapter Four, Default Project). When looking for a matching project, Create!form Server first looks in the print queue directory. If it cannot find any matching projects in that directory, it will look in the CommonProject directory located under the e-forms server resource directory (Chapter Four, Resource Directory).

![Flowchart](image-url)  

*Figure 5.2: The logic applied when locating projects*
Output Format

The output of the processed document is determined by the format defined in the merge configuration specified by the project, or the default merge configuration of the print queue (Chapter Four, Output Formats).
Advanced Topics

What would you like to know about?

- Printing Multiple Copies
- Splitting Documents
- Tray Mapping
- Next Copy Projects

Printing Multiple Copies

You can specify that Create!form Server prints multiple copies via the following methods:

- The number of copies contained within the input file, set when you print the input file from your enterprise server
- The value in the %cpParam:-c<copies> parameter in the Create!form job header, set by Create!send
- The “Duplicate” settings in the project, set in the project.

To determine the number of copies, where contradictory copy settings are specified, Create!form Server will use the first value in the following order of precedence:

- The number of duplicates contained within the input file
- The number of duplicates specified in the Create!form job header
- The duplicate settings in the project

Example

Two duplicates will be printed when:

- The input file contains no duplicates
- The job header specifies two duplicates
- The matching project specifies four duplicates
Splitting Documents

Use Create!form Director projects to split input files into component documents and direct each component to separate output ports.

Tray Mapping

Tray mapper files ensure that when you send a print job to a PostScript printer, the trays are correctly mapped. You can create tray mapper files, using the tray mapper utility, which is automatically installed with Create!form Designer.

To create a tray mapper file

1. From the Start menu, select Programs > Create!form > Utilities > Create!print tray mapper. The Select Printer dialog will be displayed.

2. Select either:
   - the print queue from the list of locally installed printers, or
   - the PostScript Printer Definition (PPD) file for the printer

3. Click OK.

   A tray mapper file called <print queue driver name>.pcf_ps will be created and placed in the <resource dir>\SystemResource\Device directory.

When a PostScript print job is sent to a print queue, Create!form Server will look for a tray mapper file that matches the print queue driver name in the <resource dir>\SystemResource\Device directory, and embed the file in the print job.

Next Copy Projects

Within a Create!form project you can specify that a spool file is re-processed, using a different form project. For information on defining next copy projects, refer to the Create!form Designer User Guide.
Note

The collation setting in the first project overrides the collation option settings in all subsequent next copy projects.
Job Handling

Create!form Server processes jobs using the standard Windows spooling system. Jobs will be validated, merged and printed in the same order as they were submitted to the queue. Any failed jobs will be paused, with the next job in the queue being submitted for processing. This job handling process is applied through multiple print queues. For example, if jobs were submitted to multiple Create!form Server configured print queues, they will be processed simultaneously, provided they are sent to different port destinations.

The print queue options such as printer or document priorities, ports and scheduling are under the control of the Windows spooling system. However, device settings such as paper types, duplex, tray selections, are controlled by the Create!form project settings defined in the form project with Create!form Designer.

Failed Jobs

When an error is encountered during the print process, the job will be held in the print queue. In the Status column, Error-paused will be displayed. Windows will also display the print queue icon on the System Tray. When this occurs, it is recommended that you open the print queue log file to identify the cause of the error.

To view a print queue log file

1. From Create!form Server, you can view a log file in several ways:
   - Right-click the print queue and select View Log from the shortcut menu
   - Select the print queue and from the Queue menu, select View Log
   - Double-click the print queue and, from the Queue Properties dialog, click View Log

The amount of information displayed in the log file is based on the logging level you set (Chapter Four, Log File Options).

In most cases, jobs fail because either:

- Create!form Server is unable to locate the matching form project, or
- A license key error is encountered
Active Jobs

Within each Create!form Server enabled print queue, you can handle active jobs using standard Windows print queue commands to pause, resume, restart and cancel print jobs.

To handle jobs in the print queue

1. From Create!form Server, right-click on the print queue, and select Open Printer from the shortcut menu. The <name of printer> dialog will be displayed.

2. From the <name of printer> dialog, right-click on the print job and select from the available commands.

Reprinting Jobs

If you have selected to keep jobs on the print queue for reprinting (Chapter Four, Reprinting) you can use the Reprint Manager utility to:

- Search for documents
- View a merged document
- View a document as an unmerged spool file
- Reprint documents
- Redirect documents to other print queues
- Delete documents

To open Reprint Manager

1. From the Create!form Server window, right-click on the print queue and select Reprint Manager from the shortcut menu. Reprint Manager will be displayed for that print queue.

2. For help with Reprint Manager functions, click the Help button, or from the Main menu, select Help > Help Topics.

Note

In Create!form Server version 6 or later, when previewing merged documents from Reprint Manager, you can only print from Adobe Reader if you have a valid Create!pdf server license.
Managing Printer Resources

To efficiently manage the resources required for printing, it is possible to store all or selected resources in the printer’s memory, on the printer’s flash device or the printer’s hard disk. This eliminates the need for resources to continually be downloaded to the printer at print time and will therefore reduce network traffic.

If storage space permits, it is recommended that resources are pre-loaded to the printer device.

Pre-Loading Resources

Resources can be pre-loaded to the printer device through the merge configuration used by the project/queue. The resources are included with the first print job that is sent to the printer. For subsequent jobs processed on that queue, only new or updated subforms will be loaded to the printer.

To pre-load printer resources

1. From the Main menu, select Tools > Merge Configurations. The merge configurations currently defined will be displayed in the Merge Configurations dialog.
2. Select the configuration to edit and click the Properties icon.
3. Edit the Resources options on the Postscript pane of the Merge Configuration dialog as described in Chapter Four, Output Formats.
4. Click OK to save any changes made.

Re-Loading Resources

The pre-load option enables the loading and storing of resources the first time a job is sent to the printer. To re-load resources after a printer failure or when you are changing printers, you can force a pre-load. If the queue has been paused, or is currently being held, the job will take its place in the queue.
To re-load resources

- From Create!form Server, select the print queue icon and from the Main menu select Queue> PostScript Printer Resources> Reload Resources.

Deleting Resources

You can delete Create!form resources from a printer using Create!form Server.

To remove Create!form resources from a printer device

- From Create!form Server, select the print queue icon and from the Main menu select Queue>PostScript Printer Resources>Delete Resources.

Printer Reports

A number of reports are available, which provide information about the printer and resources that have been pre-loaded.

Printer information report

The printer information report provides information about the printer, including

- PostScript version
- printer memory
- printer resolution
- printable margins
- optional features installed
- details of any printer storage device installed.

Before downloading resources to the printer, it is recommended that you print this report.

You can generate a printer information report for any printer, regardless of whether it has been configured for use with Create!form Server.

Resource listing

Not supported in version 6.
System file version report
The system file version report gives information about each of the system files on the printer device including the version number and file size.
You can only print this report for a printer that has been configured as a Create!form Server writer.

To generate a printer report
• From Create!form Server, select the print queue icon and from the Main menu select Queue > PostScript Printer Resources >Print Report.
The report will be printed on the selected printer.

Types of Pre-Load Resources
The following table describes the resources that can be pre-loaded on a PostScript printer

<table>
<thead>
<tr>
<th>Resources</th>
<th>Files on e-forms server</th>
<th>Locations on printer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subforms</td>
<td>All .eps subforms referenced by project located in print queue directory and common form project directory</td>
<td>&lt;disk&gt;\create\IMG</td>
</tr>
<tr>
<td>Bar codes</td>
<td>&lt;install dir&gt;\SystemResource\Barcode*.dct_pcs</td>
<td>&lt;disk&gt;\create\BARC</td>
</tr>
<tr>
<td></td>
<td>Only those resources required by the project being printed will be pre-loaded</td>
<td></td>
</tr>
<tr>
<td>Fonts</td>
<td>&lt;install dir&gt;\WIN32User\FONTS.DATA</td>
<td>&lt;disk&gt;\create\FONT</td>
</tr>
</tbody>
</table>

Note
Form projects, .cff6 subforms and tray dictionaries are sent with each print job and are not pre-loaded.
Managing Printer Resources
GLOSSARY

This appendix provides a list of commonly used Create!form terms.
# Glossary

The following table explains many of the terms specific to Create!form

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>archive server</td>
<td>The computer system on which Create!archive is installed.</td>
</tr>
<tr>
<td>Create!form Print queue</td>
<td>A Windows print queue configured for use by Create!form Server.</td>
</tr>
<tr>
<td>common project directory</td>
<td>The directory used to store shared project resources.</td>
</tr>
<tr>
<td>design workstation</td>
<td>The Windows PC on which Create!form Designer is installed, where form projects are created.</td>
</tr>
<tr>
<td>e-forms server</td>
<td>The computer system on which Create!form Server and companion products are installed, where spool files are merged with form projects.</td>
</tr>
<tr>
<td>enterprise server</td>
<td>The computer system that hosts the ERP system or other server applications, where spool files originate.</td>
</tr>
<tr>
<td>form project</td>
<td>A Create!form project, or form project, is merged with the output of your server application, to reformat and enhance the output, incorporating logos, images and drawing objects. Projects are designed using Create!form designer.</td>
</tr>
<tr>
<td>job header</td>
<td>Instructions added to a print job by Create!send or Create!form Director for processing by Create!form Server.</td>
</tr>
<tr>
<td>input file</td>
<td>See spool file.</td>
</tr>
<tr>
<td>emerging</td>
<td>The process of merging a spool file with a form project.</td>
</tr>
<tr>
<td>output format</td>
<td>The format of the print job output by Create!form Server.</td>
</tr>
<tr>
<td>output port</td>
<td>The printer port a print queue is configured to send jobs to. Maybe a physical printer, or a Create!form output module.</td>
</tr>
<tr>
<td>project</td>
<td>See form project.</td>
</tr>
<tr>
<td>project directory</td>
<td>The directory where Create!form Server.</td>
</tr>
<tr>
<td>print queue</td>
<td>A Windows operating system printer queue definition. A print queue can be associated with a physical or network printer, or a Create!form output module.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>resource directory</td>
<td>The directory where the project resources common to all Create!form print queues are stored.</td>
</tr>
<tr>
<td>server application</td>
<td>A software program that generates spool files, usually located on the enterprise server.</td>
</tr>
<tr>
<td>spool file</td>
<td>The print job produced by your server application that is sent to the e-forms server for processing by Create!form Server.</td>
</tr>
<tr>
<td>subform</td>
<td>A subform is a user defined graphical object referenced by a project. Subforms may be .eps (encapsulated PostScript) or .eff6 (a Create!form graphic) format.</td>
</tr>
</tbody>
</table>
Glossary
This chapter provides a quick reference to menu commands and how to select screen items from the keyboard.

The following topics are covered in this chapter

- Quick Guide to Menu Commands
- Quick Guide to Keyboard Shortcuts
# Quick Guide to Menu Commands

The following commands are available from the main menu.

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Queue Properties</td>
<td>Configure a Create!form print queue.</td>
</tr>
<tr>
<td>Queue Enabled</td>
<td>Enable as a Create!form print queue.</td>
</tr>
<tr>
<td>Queue Open Printer</td>
<td>View jobs on selected print queue.</td>
</tr>
<tr>
<td>Queue Reprint Manager</td>
<td>Start Reprint manager utility on selected print queue.</td>
</tr>
<tr>
<td>Queue View Log</td>
<td>Display log file for selected Create!form print queue.</td>
</tr>
<tr>
<td>Queue PostScript Printer Resources</td>
<td>Reload and delete resources on selected PostScript printer.</td>
</tr>
<tr>
<td>View Large Icons</td>
<td>Show print queues as large icons.</td>
</tr>
<tr>
<td>View Small Icons</td>
<td>Show print queue as small icons.</td>
</tr>
<tr>
<td>View List</td>
<td>List print queues.</td>
</tr>
<tr>
<td>View Arrange Icons</td>
<td>Arrange print queues by name or by status.</td>
</tr>
<tr>
<td>Tools Server Options</td>
<td>Set default directories and database connections.</td>
</tr>
<tr>
<td>Tools Log File Settings</td>
<td>Set log file reporting level.</td>
</tr>
<tr>
<td>Tools License Keys</td>
<td>Display License information.</td>
</tr>
<tr>
<td>Tools Named Destinations</td>
<td>Create and edit named destinations.</td>
</tr>
<tr>
<td>Tools Environment Variables</td>
<td>Create and edit environment variables.</td>
</tr>
<tr>
<td>Tools Merge Configurations</td>
<td>Create and edit merge configurations.</td>
</tr>
<tr>
<td>Help Topics</td>
<td>Display this document in Adobe Reader</td>
</tr>
<tr>
<td>Help Create!form on the Web</td>
<td>Visit the Create!form web site.</td>
</tr>
<tr>
<td>Help About</td>
<td>Version and copyright information.</td>
</tr>
</tbody>
</table>
Quick Guide to Keyboard Shortcuts

The following functions are available from the keyboard.

**To select any menu command with the keyboard**

1. To select the menu bar, press ALT.
2. Press the underlined letter in the menu name that contains the command you want.
3. In the menu that appears, press the underlined letter in the command name that you want. You can also navigate with the arrow keys.

**To select any option on an active dialog with the keyboard**

<table>
<thead>
<tr>
<th>Press</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>Select next option or option group.</td>
</tr>
<tr>
<td>Shift + Tab</td>
<td>Select previous option or option group.</td>
</tr>
<tr>
<td>Ctrl + Tab</td>
<td>Switch to next dialog tab.</td>
</tr>
<tr>
<td>Ctrl + Shift + Tab</td>
<td>Switch to previous dialog tab.</td>
</tr>
<tr>
<td>Alt + letter</td>
<td>Select an option with an underlined letter.</td>
</tr>
<tr>
<td>Alt + Down</td>
<td>Open a selected drop-down list.</td>
</tr>
<tr>
<td>arrow keys</td>
<td>Move between options in an open drop-down list.</td>
</tr>
<tr>
<td>letter key</td>
<td>Select an item in a drop-down list with the corresponding first letter</td>
</tr>
<tr>
<td>Spacebar</td>
<td>Perform the action assigned to the selected command button (dotted outline).</td>
</tr>
<tr>
<td>Enter</td>
<td>Perform the action assigned to the default command button (bold outline).</td>
</tr>
<tr>
<td>Esc</td>
<td>Cancel the command and close the active dialog.</td>
</tr>
</tbody>
</table>

When selecting items in the window

<table>
<thead>
<tr>
<th>Press</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>End</td>
<td>Select last item.</td>
</tr>
<tr>
<td>Home</td>
<td>Select first item.</td>
</tr>
<tr>
<td>Press</td>
<td>To</td>
</tr>
<tr>
<td>----------</td>
<td>---------------------------------------</td>
</tr>
<tr>
<td>Up</td>
<td>Select item above.</td>
</tr>
<tr>
<td>Down</td>
<td>Select item below.</td>
</tr>
<tr>
<td>Shift-F10</td>
<td>Display shortcut menu.</td>
</tr>
</tbody>
</table>
This chapter describes how to transfer projects and their associated resources to the e-forms server.

The following topics are covered in this chapter.

• Introduction
• Connecting to the e-forms Server
• Transferring Projects and Resources
• Transferring Variable Subforms
• Overwriting Files of Server
• Transfer History
Introduction

A project, and its associated resources, must be transferred to the e-forms server before it can be used in production printing. Projects must be transferred from the design programs used to create each project: Create!form Designer, Create!form Transform, and Create!form Director.
Connecting to the e-forms Server

Before transferring resources, you must establish a network connection between the design workstation and the e-forms server.

To enable transferring resources from the design workstation to the e-forms server, the Create!form directories on the e-forms server must first be shared, and then made available on the design workstation as a mapped drive.

To connect to the e-forms server

1. On the e-forms server, share the Create!form install directory and set permissions for other users to access this folder over the network.

2. On the design workstation, map the Create!form install directory as a network drive.

For information on sharing and mapping folders on the network, refer to Windows Help.
Transferring Projects and Resources

When you transfer a project, all the resources directly referenced by the project will be transferred, including the project file, the DataMap file, subforms and fonts; however any subforms that may be referenced by a variable subform must be selected and transferred separately (For more information refer to Transferring Variable Subforms.).

To transfer a project to the e-forms server

1. Start the design program used to create the project.
2. From the Main menu, select Tools > Transfer. The Transfer to Server dialog will be displayed.
3. In the Project/subforms to upload field, click Select to display the Open dialog with which you can locate the project (cfp6, ctp6, or cdp6) you want to transfer.
4. In the Server project directory field, click Browse and locate the print queue project directory where the project and subforms will be stored on the e-forms server.
5. In the Server resource directory field, click Browse to locate the server resource directory, where other resources will be stored on the e-forms server.
6. Select the prompt to overwrite files, checkbox to select overwriting of files at the server destination.
7. Select Transfer to transfer the selected resources to the e-forms server.
8. Select close.
Transferring Variable Subforms

Subforms referenced by a variable subform are not explicitly defined in the project. You must select and transfer the subform files that may be referenced by variable subforms separately.

**To transfer subforms to the e-forms server**

1. Start Create!form Designer.
2. From the main menu, select Tools > Transfer. The Transfer to Server dialog will be displayed.
3. In the Project/subforms to upload field, click **Select** to display the open dialog with which you can locate the subform files (.eps and .cff6) you want to transfer. You can select and transfer more than one field at a time.
4. In the Server project directory field, select the same destination you selected when transferring the project.
5. In the server resource directory field, select the same destination you selected when transferring the project.
6. Select the **Prompt to overwrite files** checkbox to select the overwriting of files at the server destination.
7. Select Transfer to transfer the selected resources to the e-forms server.
8. Select **Close**.
Overwriting Files of Server

When transferring files to the server, the Prompt to Overwrite files option on the Transfer to Server dialog has the following action.

<table>
<thead>
<tr>
<th>When transferring...</th>
<th>Files on the server will be...</th>
</tr>
</thead>
<tbody>
<tr>
<td>• EnvironmentVars.data</td>
<td>You will be prompted to overwrite files on server.</td>
</tr>
<tr>
<td>• mergeconfig.data</td>
<td></td>
</tr>
<tr>
<td>• destinations.data</td>
<td></td>
</tr>
<tr>
<td>• Prompt to overwrite files is cleared</td>
<td>Files on server will be overwritten without prompting</td>
</tr>
<tr>
<td>• Files exist on server</td>
<td></td>
</tr>
<tr>
<td>• Files on server are older</td>
<td></td>
</tr>
<tr>
<td>• Prompt to overwrite files is cleared</td>
<td>Files on server will not be overwritten</td>
</tr>
<tr>
<td>• Files exist on server</td>
<td></td>
</tr>
<tr>
<td>• Files on server are newer</td>
<td></td>
</tr>
<tr>
<td>• Prompt to overwrite files is selected</td>
<td>You will be prompted if you want to overwrite files on server</td>
</tr>
<tr>
<td>• Files exist on server</td>
<td></td>
</tr>
</tbody>
</table>
Transfer History

After transferring a project, the number of files uploaded to the server will be displayed on the Transfer to Server dialog. To view which files have been transferred, click the drop-down list below the upload message.

You can view a detailed transfer history of all server project directories by opening the log file TransferHistory.txt located in the \<install.dir>\Temp folder.
TRANSFERRING PROJECTS
- Transfer History
-
This chapter describes how to install and use Create!send to add job headers to spool files before sending them to Create!form Server or Create!form Director.

The following topics are covered in this chapter.

- Introduction
- Create!send for OS/400
- Create!send for UNIX
- Create!send for Windows
- Create!send for VMS
Introduction

Create!send is a utility program for delivering spool files to Create!form Server. You must install Create!send on the enterprise server, where the spool file is initiated.

The enterprise server prints to specially configured Create!send print queues (OS/400 and Windows) or utilizes a Create!send command procedure (UNIX and VMS). Create!send attaches a job header to the beginning of spool files and sends the job to Create!form Server for processing.

Support for Multiple Platforms

Create!form Server print/output queues, on your Windows e-forms server, can receive spool files generated by Create!send from the following platforms:

• OS/400 (Create!send for OS/400)
• UNIX (Create!send for UNIX)
• Microsoft window NT4/2000/2003/XP (Create!send for Windows)
• VMS (Create!send for VMS)

For instructions on installing and using Create!send for your platform, refer to the appropriate section.
Create!send for OS/400

System Requirements

Create!send (OS/400) uses IBM API’s and user exit programs that are not available prior to OS/400 version V5R1M0. This operating system release is the minimum required for Create!send (OS/400).

Create!send works in conjunction with an existing output queue. As spool files are printed to the associated output queue, the IBM Writer activates Create!send. The properties of the Create!send writer associated with the output queue are used to attach the defined job header parameters (Defining a Create!send Writer).

---

**Note**

*In order to automatically attach a job header to jobs sent to the Create!send writer, the associated IBM Writer must also be started.*

---

Spool File Requirements

Create!send (OS/400) supports *SCS and *USERASCII spool files.

- *SCS spool files are transformed to ASCII after a job header has been added, which tells Create!form Server what resources to use when it processes the file. With OS/400 applications, the Form Type specified for the spool file determines the form project that will be used by Create!form Server.

- *USERASCII spool files are passed through as they are read. No transform of data takes place and no job header is added for Create!form Server to process.
Before Installing

Before proceeding, you will need to have created, configured and tested a Create!form Server print queue on your Windows e-forms server (Chapter Four, Setting Up Print Queues). This is the print queue where Create!send will send the print jobs.

Installing Create!send (OS/400)

The Create!form installation CD contains the Create!send (OS/400) application which is installed on the OS/400 application server via FTP.

To install Create!send (OS/400) via FTP

1. Sign on as QSECOFR, then create a savefile in the QGPL library of your AS/400:
   CRTSAVF QGPL/savefilename
   Where savefilename is the name of the savefile you wish to create.
   For example: CRTSAVF QGPL/CSND60

2. Start an FTP session from the PC to the AS/400 by entering the name or IP address of your AS/400.
   For example: C:\> FTP myas400

3. Complete the required signon and enter the password. Specify a BINARY transfer mode.
   ftp> BINARY

4. FTP the required file (ILCRTSND) from the \Create!send\OS400 directory on the installation CD to the savefile created in step 1.
   For example: ftp> PUT ILCRTSND QGPL/CSND60

5. Restore the library on the AS/400 from the savefile in QGPL.
   For example: RSTLIB SAVLIB(ILCRTSND) DEV(*SAVF) SAVF(QGPL/CSND60)

6. Add ILCRTSND to your library list:
   ADDLIBL ILCRTSND

7. From an OS/400 command screen, execute the command to install the AS/400 library required for Create!send:
INSCRTSND

8. Follow the on-screen prompts to complete the installation.

9. The savefile may be deleted once installation is complete:
   DLTF FILE(QGPL/CSND60)

10. The install library may also be deleted when finished
    DLTLIB LIB(ILCRTSND)

OS/400 Spool File Attributes

Most OS/400 spool file attributes are retained and used by Create!send. For example, the form type attribute is used to identify the form project (Form Type References) and copies are printed according to the spool file copies value.

Defining a Create!send Writer

To automatically attach job header parameters, you must define a Create!send writer that is associated with a local or remote queue. When you first create a new Create!send writer, the associated output queue is automatically modified. Before creating or deleting Create!send writers, please check the associated output queue and ensure that no jobs are currently being processed.

To define a Create!send writer

1. From a command screen, execute the command to start Create!send (OS/400)
   STRSND

2. From the Create!send menu, select option 2 (Work with Create!send writers).
   A list of previously defined Create!send writers will be displayed.

3. Press f6 (create) to define a new Create!send writer.

4. In the Writer field, press f4 to select the output queue that outputs to the Create!form Server print queue on the Windows e-forms server. Locate the required output queue in the list, and type 1 in the Option column and press
enter. Alternatively, type the name of the output queue directly into the Writer field.

5 In the Type field, select from the following options

- If sending to Create!form Server or Create!form Director on the Windows e-forms server, type *SERVER.
- If printing to a printer that has been pre-loaded with Create!flash, enter *FLASH.
- If spool files should be sent without a header, enter *NONE.

6 The EOJ Flag, PJL flag and Printer path fields are ignored when the Type is set to *SERVER.

7 In the Process Bold/Underline field, enter *YES to preserve overstrike control characters in the original spool file. In the Pre version 2 support field, enter *NO.

8 In the ASCII code page field, type the OS/400 ASCII code page number the spool file data will be translated to. The default value is the system code page. If you need to use a different code page, type the required code page number in this field, for example, type 819 for ANSI 8-bit Latin 1, or 905 for Latin 3 multilingual or 915 for ISO/ANSI 8-bit Cyrillic.

When the DBCS encoding option (see below) is set to any value other than *NONE, this field will contain the ASCII code page value for the selected language.

9 In the EBCDIC code page field, type the OS/400 EBCDIC code page number the spool file data will be translated from. The default value is 37, which is equivalent to a system CCSID of 65535 (no translation). If your spool file does not use the system CCSID, type the required code page number in this field. To use the system CCSID, enter a value of 0 in this field.

When the DBCS encoding option (see below) is set to any value other than *NONE, this field will contain the EBCDIC code page value for the selected language.

10 When translating DBCS data, change the DBCS encoding value to the DBCS language required

- *NONE - no DBCS translation will be performed.
- *CHS - Chinese Simplified
- *CHT - Chinese Traditional
• *JPN - Japanese
• *KOR - Korean

Depending on the selection made here, the spool file will be translated according to the IBM code page defaults for that selection. The ASCII and EBCDIC code pages above will be set automatically by the program. If you require DBCS code page translation other than the IBM default CCSIDs for that language, type the required values in the EBCDIC and ASCII code page fields.

11 In the Printer Path field, select from the following options
• If Type is set to *SERVER, printer path is ignored.
• If Type is set to *FLASH, enter the printer device name.

12 Press enter to confirm your settings and return to the main menu.

A new writer will be created using the specified properties. The Create!send writer will be identified by the name of its output queue.

---

**Note**

*If you choose an output queue that is already configured as a Create!form Server writer, the output queue will be changed to a Create!send writer (the User Data Transform program will be changed to SND100), and will no longer be associated with the Create!form Server writer properties.*

---

**To display or modify an existing Create!send writer**

1 From the Create!send menu, select option 2 (Work with Create!send writers). A list of existing Create!send writers will be displayed.

2 Locate the Create!send writer you wish to view or modify and type 5 in the Option column to Display the current settings, or type 2 in the Option column to Change its properties. Press enter to continue. You can make changes to any of the fields in the Create!send writer properties, apart from the selected output queue.

3 Press enter to return to the main menu.

**To delete a defined Create!send writer**

1 From the Create!send menu, select option 2 (Work with Create!send writers).
Create!Send for OS/400

2 Locate the Create!send writer you wish to remove and type 4 in the Option column and press enter to continue.

3 You will be prompted to confirm that you wish to remove the selected writer. Press enter to confirm, or f12 (cancel) to exit without removing the writer.

When you remove a Create!send writer, the output queue is not removed; however, the SND100 User Data Transform program is removed from the queue.

Form Type References

The OS/400 Form Type spool file attribute is used by Create!send to determine which form project is to be used for merging and thus, what parameter should be included within the job header.

To match form type parameters with Create!form projects, a form type reference entry is defined in Create!send.

To define a form type reference

1 From the Create!send menu, select option 1 (Work with form type references). A list of existing form type reference entries will be displayed.

2 Press f6 (create) to add a new form type reference. The Create Form Type Reference screen will be displayed.

3 In the Form Type field, type the name of the form type that is assigned to the spool file, for example, type *STD.

4 In the Writer field, press f4 to select the Create!send writer that will apply to this reference. Locate the required writer in the list, type 1 in the Option column and press enter. To use the same form type reference for all Create!send writers, enter *ALL in the Writer field.

5 In the Form Project field, type the name of the form project you want to associate with the selected form type.

6 Press enter to return to the main menu.

When you print to the Create!send output queue, Create!send will read the Form Type attribute of the spool file. It then checks the form type references to see if an entry exists for that form type, which is applicable to the Create!send writer being used.
If a match is found, it will attach the %cpParam: -s<project> parameter to the job header (Appendix E, Job Tickets), identifying the matching form project from the form type reference entry.
Note

If no matching form type reference record is found, Create!send assumes that the form type attribute of the spool file is also the name of the form project and sets job header parameter accordingly.

To modify an existing form type reference

1. From the Create!send menu, select option 1 (Work with form type references). A list of existing form type reference entries will be displayed.

2. Locate the form type reference you want to modify and type 5 in the Option column to display the settings, or type 2 in the Option column to modify. Press enter to continue.

3. When you have completed the changes, press enter to return to the main menu.

To delete an existing form type reference

1. From the Create!send menu, select option 1 (Work with form type references). A list of existing form type reference entries will be displayed.

2. Locate the form type reference you want to remove, type 4 in the Option column and press enter.

3. You will be asked to confirm that you wish to remove the selected form type reference. Press enter to confirm or f12 (cancel) to exit without removing the entry.

Form Type Order of Precedence

When a form type reference is created that refers to *ALL writers, the selected form type and form project will apply to all Create!send writers unless a specific writer is referenced individually.

The following shows the order in which form types will be used by Create!send

1. The form type reference identified for a specific Create!send writer.

2. The form type reference identified for *ALL Create!send writers.

3. The IBM Form Type attribute associated with the spool file.
Create!send for UNIX

Create!send (UNIX) is a shell script program which is installed onto your UNIX server. When the Create!send command is executed with a list of parameters, this utility attaches a job header at the beginning of the spool file and outputs it to the selected device.

Before Installing

Before proceeding, you will need to have created, configured and tested a Create!form Server print queue on your Windows e-forms server (Chapter Four, Setting Up Print Queues). This is the print queue where Create!send will send the print jobs.

On the UNIX server, you should ensure that printing from your UNIX print queue to the Create!form Server print queue, on the Windows e-forms server, is configured and working.

Supported OS Versions

The following versions of UNIX are supported:

- AIX 4.2
- HP-UX B10.20
- Solaris 2.5.1 (SunOS5.5.1)
- Red Hat 9.0 Linux
- SuSE 9.2 Linux

Installing Create!send (UNIX)

To install Create!send (UNIX) on your system, you need to install the file crtesend, which is located in the \Create!send\Unixserver directory of the installation CD.
To make the file accessible

1. Using the `mkdir` command, set up the following directory (if it does not already exist):
   ```
   mkdir /usr/Createform/crtsend (or similar)
   ```

2. Use an FTP BINARY file transfer method to transfer `crtesend` and `cfs_start.ps` to the `usr/Createform/crtsend` directory on your UNIX server.

3. Ensure that this directory is included in the PATH environment.

4. Make the Create!send file executable using the command:
   ```
   chmod 111 crtesend
   ```

Using Create!send (UNIX)

Create!send is activated by using the `crtesend` command. Once activated, it will send an input file with a job header to your printer.

There are two basic ways to execute the command:

- Where the output is specified as a parameter, and the input is standard in:
  ```
  crtesend -d<printer> {options} <inputfile>
  ```
  For example:
  ```
  crtesend -dprt05 -sinvoice test.txt
  ```

- Where the input file is redirected to `crtesend` and piped to the output destination:
  ```
  crtesend {options} < <inputfile> | <outputfile>
  ```
  For example:
  ```
  crtesend -sinvoice < test.txt | lp -dprt05
  ```

Both examples send the file `test.txt` to printer `prt05` with a job header for Create!form Server, specifying that the job uses the form project called “invoice”. 
Create!send (UNIX) Script Parameters

Parameters are passed in the command line using the following syntax:

crtesend <printfile name> <parameter1 parameter2, .... >

The script parameters available are listed below:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>-C&lt;copies&gt;</td>
<td>Sets the number of copies. This will over-ride the duplicates setting in the project (Chapter Five, Printing Multiple Copies); however, collation is controlled by the project settings.</td>
</tr>
<tr>
<td>-s&lt;project&gt;</td>
<td>Create!form Server: sets the name of the project the spool file will be merged with. Create!form Director: sets the name of the project to be used.</td>
</tr>
<tr>
<td>-d&lt;printer&gt;</td>
<td>Sets the print queue (connected to the Create!form Server print queue on the e-forms server).</td>
</tr>
</tbody>
</table>

Note

The Create!send (UNIX) script parameters do not necessarily match the job header parameters (Appendix E: Job Tickets) created by the execution of the command line. For example, the -d<printer> parameter is a command line parameter and there is no corresponding %cpParam: structure created in the job header.

Example

Command Line

crtesend test.txt -sinvoice -c2 -dMyPrinter
Resulting Job Header

%cpBegin
%cpSystem: HP/UX
%cpUser: Joe Senior
%cpParam:-c2
%cpParam:-sINVOICE
%cpEnd
<data from test.txt>

This job will be sent to the printer ‘MyPrinter’ which is targeting a local or remote print queue connected to the Create!form Server print queue on the e-forms server. Create!form Server will then process this file using the form project Invoice and print 2 copies.
Create!send for Windows

Before Installing

Before proceeding, you will need to have created, configured and tested a Create!form Server print queue on your Windows e-forms server (Chapter Four, Setting Up Print Queues). This is the print queue where Create!send will send the print jobs. This is referred to in the instructions below as the CfServer print queue.

Installing Create!send (Win32)

Create!send (Win32) is installed from the Create!form installation CD. The files are located in the \Create!send\Win32 directory of the installation CD. You must have administrator privileges in order to perform the installation.

To install Create!send

1 Insert the Create!form CD in your CD drive.

2 Navigate to the \Create!send\Win32 directory and double-click on the file Setup.exe.

3 Follow the on-screen instructions to install Create!send (Win32).

At the end of the installation, a short-cut to Create!send is added to the following locations in each Windows user profile

• Start Menu
• Send To folder
Connecting to Create!form Server Print Queues

Create!form Server print queues must be shared on the network to allow spool files to be printed from any workstation using Create!send.

Once the Create!form Server print queue (also referred to as a “printer”) is available as a shared device, you can then connect the print queue to each local workstation where spool files originate.

Manual Printing Method

This method allows you to attach job headers to saved spool files by running the Create!send application and then manually selecting the spool file, the Create!form Server print queue and the parameters to be included in the job header.

With this method, no further configuration of Create!send is required once it has been installed. The following instructions use the sample files provided with Create!form, however, the same process applies to sending all data files.

Figure D.1: The Create!send process using the manual printing method.
For this example, set the CfServer print queue project directory to the samples
directory \<install dir>\Samples. Refer to Project Directory for more
information.

4 From Windows Explorer, browse for the sample text file StdInvoice.txt in
the samples directory.

5 Select StdInvoice.txt and right-click on the file to display the shortcut menu.
Select Send To from the menu and choose Create!send Win32.
The Create!send Win32 dialog will be displayed.

6 Within the dialog, set the following options
   • Form Project
      Click Browse and select the StdInvoice.cfp6 project in the Sample
directory.
   • Destination Printer
In the Name field, select the Create!form Server print queue CfServer. Details about the selected print queue will be displayed.

- **Page Range**
  Not supported in version 6 projects.

- **Copies**
  Enter the number of copies to be printed in the Number field. Collation options are ignored. Print job collation options must be set in the project.

- **Target Product:**
  Select Create!form Server.

7 Click Print to send the spool file to the Create!form Server print queue.

---

**Note**

*You can also send a spool file by starting Create!send Win32 from the Windows Start button.*

Create!send attaches a job header similar to the following

```ini
%cpBegin
%cpSystem:SYSTEMNAME
%cpUser:UserName
%cpFileName:stdinvoice.txt
%cpParam:-sSTDINVOICE
%cpEnd
<text file>
```

When this job reaches the Create!form Server print queue on the e-forms server, the spool file will be processed using the StdInvoice form project. For a complete list of job file header structures supported by Create!form Server, refer to Appendix E, *Job Tickets*.

---

**Direct Printing Method**

You can configure local print queues to use the Create!send port and print directly from the application to the print queue. When a job is printed to a
print queue that uses the Create!send port, Create!send is automatically activated and a job header is created using the default configuration. The job header can be defined by the user before it is sent or defined automatically depending on the settings. Once the job header has been created, the spool file is sent to the chosen print queue, which is connected to the Create!form Server print queue on the network. Create!form Server on the Windows e-forms server will process the print job using the parameters specified in the job header.

By configuring a local printer to use the Create!send port, you can set default parameters that will automatically be used to create job headers each time you send a print job to the defined print queue.

To use direct printing, follow the instructions in Creating a Create!send Queue to install and configure a Create!send queue. Once the Create!send queue has been configured, you can print directly from your application to the Create!send print queue. Any spool files sent to a Create!send print queue will cause Create!send to attach a job header and send the entire job on to the Create!form Server print queue and merged with the specified project.
Creating a Create!send Queue

Before creating a Create!send print queue, you must connect a local print queue to the Create!form Server print queue on the e-forms server. The print queue name CfServer is used for convenience in the following instructions.

To create a Create!send print queue

1. Using the Add Printer Wizard, add a local print queue with the following settings:
   - Local or Network Printer
     Select Local printer. Do not select the option to detect a Plug and Play printer.
   - Select the Printer Port
     Create a new Create!send port. You can accept the default port name or enter a name that better describes the intended use for the port.
   - Driver
     Select the Generic/Text Only printer driver.
   - Name of Printer
     Type in a name that describes the intended use for the print queue; the name CSend is used for convenience in the following instructions.

2. Once the port is added, the Create!send Win32 dialog will be displayed. The settings you choose here will determine the default configuration for all jobs sent to the CSend print queue:
   - Select Create!form server as the Target product.
   - Select CfServer as the Destination printer.
   - In the Form Project field, select the default project.
   - Modify any other parameters as required.
   - Select the type of operation to use
     - Verbose: The Create!send dialog will be displayed for each job that is sent to this queue, allowing the default values to be changed at the time the print job is sent.
     - Silent: Create!send will run in silent mode, automatically using the default values. No user intervention is available to modify the configuration at print time.

3. Click OK to save the default configuration.
Any spool files sent to a CSendMessage queue will cause Create!Send to attach a job header and send the entire job on to the CfServer print queue.

**Using Multiple Create!Send Print Queues**

You can create multiple Create!Send queues and configure each queue with different settings in order to process different types of print jobs.

For example, for Invoice spool files you might want to print them using the form project “Invoice1”. On a print run for Statements, you may want to use a different form project and print an additional copy.

One solution is to select ‘Verbose’ as the Operation mode, so that each time a job is sent to the Create!Send print queue, the dialog will be displayed where you can accept or change the settings.

Alternatively, you can create multiple Create!Send print queues, each with a specific configuration that is required for a specific job. To help identify the different print queue configurations, use a print queue name that describes the intended use of the print queue. You can then create a print queue for each type of print job. To merge print jobs correctly, simply print the job to the appropriate print queue.
Create!send for VMS

Create!send (VMS) is a DCL command procedure that runs on your VMS server to attach job headers to VMS spool files.

Before Installing

Before proceeding, you will need to have created, configured and tested a Create!form Server print queue on your Windows e-forms server (Chapter Four, Setting Up Print Queues). This is the print queue where Create!send will send the print jobs.

On the VMS server, you should ensure that printing from your VMS print queue to the Create!form Server print queue on your Windows e-forms server is configured and working.

Installing Create!send (VMS)

To install Create!send (VMS)

1. Create a new directory on your system to store the Create!send files.
   
   For example
   
   create/dir YOURDISK:[YOURDIR.PROCEDURES]

2. Locate the files crtesend.com and cfsstart.ps in the \Create!send\VMSServer directory of the installation CD.

3. Copy the files to the Create!send directory on your system.
   
   For example
   
   copy CRTESEND.COM YOURDISK:[YOURDIR.PROCEDURES]CRTESEND.COM
   
   copy FS_START.PS YOURDISK:[YOURDIR.PROCEDURES]CFSSTART.PS

4. Assign a global symbol in your startup DCL to allow execution of the Create!send command file.
   
   For example
   
   $ crtesend=’@YOURDISK:[YOURDIR.PROCEDURES]CRTESEND.COM”

5. Assign a directory to the symbol ‘TEMPDIR’ for the spooling of temporary files created by Create!send.
For example:
$ tempdir =="YOURDISK:[YOURDIR.TEMP]"

**Using Create!send (VMS)**

Create!send (VMS) can be activated using the crtesend command assigned as a global symbol. Once activated, Create!send can send an input file with a job header to your printer.

**To execute the command**

1. Specify the data file, the print queue and the print options
   $ crtesend <inputfile> -d<printer> {options}
   For example:
   $ crtesend test.txt -dprt05 -sinvoice
   This sends the file test.txt to printer prt05 with a job header that specifies the form project Invoice.

For information on job header parameters supported by Create!form Server, refer to Appendix E, *Job Tickets*.

**Create!send (VMS) Command Parameters**

Command parameters are passed in the command line using the following syntax:

crtesend <printfile name> <parameter1 parameter2 .... >

The parameters available are listed below:
Note

The Create!send (VMS) command parameters do not necessarily match the job header parameters (Appendix E) created by the execution of the command line. For example, the -d<printer> parameter is a command line parameter and there is no corresponding %cpParam: structure created in the job header.

Sample Job Headers

Command Line

$ crtesend test.txt -sINVOICE -c2 -dMyPrinter

Resulting Job Header

%cpBegin
%cpParam:-sINVOICE
%cpEnd
<data from test.txt>

This will be sent to the printer ‘MyPrinter’ which is targeting a local or remote print queue configured as a Create!form Server writer. Create!form Server will then process this file using the form project INVOICE and print 2 copies.
- CREATE!SEND
  - Create!send for VMS
  -
  -
JOB TICKETS

This appendix provides a reference to job ticket structures supported by Create!form Server.

The following topics are covered in this chapter

• Job Ticket Variables
• Job Ticket Parameters
# Job Ticket Variables

The following job ticket variables are supported by Create!send

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>%cpBegin</td>
<td>First line of job header.</td>
<td>Appears at top of spool file.</td>
</tr>
<tr>
<td>%cpParam: &lt;PARAMETER&gt; &lt;VALUE&gt;</td>
<td>Sets options for processing job.</td>
<td>Refer to <a href="#">Job Ticket Parameters</a>.</td>
</tr>
<tr>
<td>%cpEnd</td>
<td>Last line of job header.</td>
<td>Followed by the input file data.</td>
</tr>
</tbody>
</table>

Sample Create!send header file:

```plaintext
%cpBegin
%cpSystem: SYSTEMNAME
%cpUser: UserName
%cpFileName: stdinvoice.txt
%cpParam: -sSTDINVOICE
%cpEnd
<text file>
```
Job Ticket Parameters

The syntax and usage of the supported job ticket parameters (%cpParam) are summarized below:

%cpParam:-<PARAMETER><VALUE>

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>-c&lt;copies&gt;</td>
<td>Sets the number of copies. Over-rides duplicates setting in the project (Chapter Five, Printing Multiple Copies). Collation is controlled by the project settings.</td>
</tr>
<tr>
<td>-s&lt;project&gt;</td>
<td>Create!form Server: sets the name of the project the spool file will be merged with. Create!stream: sets the name of the script to be used.</td>
</tr>
</tbody>
</table>
| -distup<user password> | Create!archive and Create!email: specifies the user password required to open the PDF. For example: %cpParam:-distupNewWorld  
When a user attempts to open the PDF, they will be prompted for the specified password. The password is case-sensitive. |
**JOB TICKETS**

*Job Ticket Parameters*

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Usage</th>
</tr>
</thead>
</table>
| `-distmp<master password>` | Create!archive and Create!email: specifies the master password required for modifying the security settings of the PDF. For example: %cpParam:-distmpSysAdmin  
When the user attempts to change the security settings, they will be prompted for the specified password. The password is case-sensitive. |
| `-distso<permissions>` | Create!archive and Create!email: specifies what permissions the PDF has. The code is represented as follows:  
1000  do not allow printing  
0100  do not allow adding or changing notes or form fields  
0010  do not allow changes to the document  
0001  do not allow selecting text and graphics  
Using a combination of these codes, you can allow or disallow each of the features you require. The following example enables printing, but disables all other options: %cpParam:-distso0111  
By combining security options with a master password, you can prevent users from being able to make changes to these settings. |
INDEX

A
Active (print) Jobs 70
Adding Print Queues 42
Selecting the Output Port 42
To add a new print queue 42
Appendix A
Glossary 75
Appendix D
Create!send 91
Defining a Create!send 95
Form Type References 98
Appendix E
Job Tickets 117

B
Basic Workflow
Document Data Type 63
Locating the Project 64
Output Format 65

C
Chapter 1
Introducing Create!form Server 9
Chapter 2
Implementation Guide 19
Chapter 3
Installing 31
Chapter 4
Setting Up Print Queues 37
Chapter 5
Production Printing 61
Configuration Options 29
Impersonating a Network User 30
Multiple e-forms servers 29
Network Configurations 29
Configuring Multiple Print Queues 55
   To configure multiple print queues 55
Configuring Print Queues 44
   Banner and Trailer Pages 53
   Center Guttered Pages 52
   Environment Variables 54
   Header/Trailer Files 52
   Ignore Duplexing 52
   Imaging 51
   Job Ticket 50
   Merger Configuration 46
   No Matching Project 54
   Output Formats 48
   Pages per Sheet 52
   PCL/Other Options 50
   PDF Options 50
   PostScript Options 48
   Reprinting 54
   Rotate landscape pages by 180 52
   Scale 52
   To create a new merge configuration 47
   To Create an environment variable 54
   To display and edit merge configuration settings 46
   To enable a print queue as a Create!form queue 44
Configuring Print Queues
   Default Project 46
   Project Directory 46
Create!archive 15
Create!barcode 15
Create!fax 15
Create!form Components 13
Create!form Designer 14
Create!form Director 14
Create!form Server 14
Create!form Transform 14
Create!form Workflow 12
Create!mail 15
Create!micr 16
Create!pdf server 16
Create!print 15
Create!send 15

D
Delivery Components 22
  Create!send 22
Design Components 21
  Create!form Designer 21
  Create!form Director 21
  Create!form Transform 21
Displaying License Details 36
  To review the current status in the Create!form License Keys dialog 36

E
Enabling Database Access for Lookup Variables 59
  To provide Create!form Server with access to database(s) 59

F
Failed (print) Jobs 69

G
Getting Help 35
  To view and print the PDF Use Guide 35

I
Implementer Road Map
  Install and Configure Delivery Components 26
Implementation Road Map 23
  Add Print Queues 25
  Commence Production Printing 28
  Configure Print Queues 25
Design Projects 24
Install Output Components 23
Select Default Projects 26
Transfer Projects to the e-forms server 24
Install Server Components 23
Installation Components 20
Installation Requirements 32
Installing 33
To install Create!form server 33

License 36
To enter the Create!form Server License key 36
To view the Authorization code 36

Managing Print Queues 56
Log File Options 58
To set the global logging options 58
Managing Printer Resources 71
Deleting Resources 72
Pre-Loading Resources 71
Re-Loading Resources 71
master password
secure PDF files 120

Next Copy Projects 67

Output Components 22
Create!archive 22
Create!fax and Create!email 22
Create!pdf server 22
Create!print 22
P
Print Queue Default Project Directories 39
   To set the default project directory 39
Print Queue Icons 56
Print Queue Project Directories 39
Printer Reports 72
Printing
   Advanced Topics 66
   Job Handling 69
Printing Multiple Copies 66
Product Overview 12
Production Printing
   Basic Workflow 62

Q
Queue Properties 44
   To configure a print queue 45
   To display print queue properties 44

R
Reprinting Jobs 70
Requirements 18
   e-forms server 18
   Enterprise server 18
   Prerequisites 18
Resource Project Directory 39

S
security
   disable changes 120
   disable notes 120
   disable printing 120
   disable selection 120
Server Components 21
   Create!form Director 21
Setting Up Print Queues
  Overview 38
Sharing Print Queues 42
  To set sharing and user access permissions on a print queue 43
Splitting Documents 67
Starting 34
  To start Create!form server 34
Supported Platforms 17

T
Terminology 11
Testing Print Queues 57
  To perform a test merge to a selected print queue 57
Transferring Projects 41
Types of Pre-Load Resources 73

U
User Guide Conventions 10
user password
  secure PDF files 119

V
Viewing Print Queues 56
  To change the view mode or sort order 56
Viewing the Status of Print Jobs 57
  To view the documents currently in a print queue 57

W
Who is This User Guide For 10