Table of Contents

Chapter 1: Introducing Create!form Transform .......................... 13
  Who is this Guide For? .............................................. 14
  Create!form Transform Features ................................. 15
  Design Prerequisites ................................................. 16
  Production Prerequisites ............................................. 17
  Getting Help ............................................................ 18
  User Guide Conventions ............................................. 19

Chapter 2: Installing ...................................................... 21
  Installation Requirements ............................................. 22
  Installing Create!form Transform ..................................... 23
  Starting Create!form Transform ...................................... 24

Chapter 3: Getting Started .................................................. 25
  What is a Project? ....................................................... 26
  Project Directories .................................................... 27
    Project Directory ................................................... 27
    Common Project Directory ........................................ 27
  Creating a Project ..................................................... 29
    New Project Wizard ................................................. 29
    Input File Type ..................................................... 30
    Using an Existing Project as a Template ......................... 30
    DataMap Options ................................................... 31
    Project Type ......................................................... 31
      Standard Project ................................................. 31
      Simple Project .................................................. 32
      Overlay Project .................................................. 32
    Design Flowchart .................................................. 33
    Saving a Project .................................................... 38
    Opening a Project ................................................. 39
    Printing and Previewing Projects ................................ 40
    Packing Projects .................................................... 41
    Transferring Projects to the e-forms Server ..................... 42

Create!form Transform
### Managing Project Files

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>43</td>
</tr>
</tbody>
</table>

### Chapter 4: Viewing and Navigating

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Understanding the Screen Elements</td>
<td>46</td>
</tr>
<tr>
<td>Design Window</td>
<td>48</td>
</tr>
<tr>
<td>Input Window</td>
<td>48</td>
</tr>
<tr>
<td>Project Tree</td>
<td>49</td>
</tr>
<tr>
<td>Input Tree</td>
<td>49</td>
</tr>
<tr>
<td>Thumbnail View</td>
<td>49</td>
</tr>
<tr>
<td>Input File Source View</td>
<td>49</td>
</tr>
<tr>
<td>Status Bar</td>
<td>50</td>
</tr>
<tr>
<td>Navigating in a Project</td>
<td>51</td>
</tr>
<tr>
<td>Jumping Directly to a Set or Page</td>
<td>51</td>
</tr>
<tr>
<td>Moving Between Sections</td>
<td>53</td>
</tr>
</tbody>
</table>

### Chapter 5: Input Design

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before You Start</td>
<td>56</td>
</tr>
<tr>
<td>Using the Create!form Sample Projects</td>
<td>56</td>
</tr>
<tr>
<td>Selecting a Different Input File</td>
<td>56</td>
</tr>
<tr>
<td>Viewing the Input File Source</td>
<td>57</td>
</tr>
<tr>
<td>Key Input Design Concepts</td>
<td>58</td>
</tr>
<tr>
<td>What is a DataMap?</td>
<td>58</td>
</tr>
<tr>
<td>What is a Set?</td>
<td>59</td>
</tr>
<tr>
<td>What is a Section?</td>
<td>59</td>
</tr>
<tr>
<td>What is a Data Variable?</td>
<td>59</td>
</tr>
<tr>
<td>What is a Derived Variable?</td>
<td>60</td>
</tr>
<tr>
<td>DataMap Types and Options</td>
<td>61</td>
</tr>
<tr>
<td>Embedded and Shared DataMaps</td>
<td>61</td>
</tr>
<tr>
<td>DataMap Options When Creating a New Project</td>
<td>62</td>
</tr>
<tr>
<td>DataMap Options While Designing a Project</td>
<td>62</td>
</tr>
<tr>
<td>Edit an Embedded DataMap</td>
<td>63</td>
</tr>
<tr>
<td>Edit a Shared DataMap</td>
<td>63</td>
</tr>
<tr>
<td>Use a Shared DataMap</td>
<td>64</td>
</tr>
<tr>
<td>Embed a DataMap</td>
<td>64</td>
</tr>
<tr>
<td>Designing for CSV Input Files</td>
<td>66</td>
</tr>
<tr>
<td>CSV File Structure</td>
<td>66</td>
</tr>
<tr>
<td>Input File Properties</td>
<td>68</td>
</tr>
</tbody>
</table>
Defining Sets ................................................................. 69
Defining Sections ........................................................... 69
Working with Data Variables .............................................. 70
Data Variables in the Input Header Section ......................... 71
  Data Variables in Detail Sections ..................................... 71
  Changing the Properties of Columns ................................ 71
  Changing the Input Data Format ...................................... 71
  Copying Data Variables to the Project ............................... 72
Designing for Text Input Files ----------------------------- 73
  Input Sections ........................................................... 75
  Examining How Sections are Populated ............................. 76
  Design Principles ...................................................... 76
    Designing From the Top-Down .................................... 76
    Design Flowchart ................................................ 77
  Setting the Input Page Size ........................................ 78
    How the Page Size is Calculated ................................ 80
    Other Input File Settings ......................................... 80
  Defining Sets .......................................................... 82
  Working with Data Variables ........................................ 83
    Set Input Data Formats ............................................ 83
    Create Data Variables ............................................ 83
    Copy Data Variables to the Project ............................... 86
    Create Data Variables in a Detail Section ..................... 86
    Make Data Variables Expandable ................................ 87
  Common Input Section Tasks ......................................... 88
    Display and Edit Input Section Properties ..................... 88
    Controlling When an Input Section is Generated ............... 91
    Working with Multiple Input Sections ........................... 91
    Deleting Input Sections .......................................... 92
  Working With the Input File Header Section .................... 92
  Working with Input Header Sections ................................ 93
    Adjust the Input Header Section Size ............................ 93
    Make an Input Header Section Expandable ....................... 94
    Add Input Header Sections ....................................... 95
    Rules for Creating Multiple Input Header Sections ................ 97
  Working with Detail Sections ....................................... 97
    About Defining Detail Sections .................................. 98
    Add Detail Sections .............................................. 99
    Make a Detail Section Expandable ................................ 100
    Rules for Creating Multiple Detail Sections .................... 101
  Working with Input Footer Sections .............................. 101
    Adjust the Input Footer Section Size ............................ 102
    Add Input Footer Sections ....................................... 102
    Rules for Creating Multiple Input Footer Sections ............ 104
Designing for XML Input Files ......................... 105
  XML File Structure .................................................. 106
### Chapter 6: Project Settings

- **Project Properties**
  - Collate Options
  - Duplicates
  - About Format Styles
    - Set the Default Format Style for New Objects
- **Project Page Style**
- **Project Background**

### Chapter 7: Sections

- **About Sections**
- **Data Sections**
  - Data Section Display Options
- **Header and Footer Sections**
  - Create Set Headers and Footers with the Wizard
  - Continuation Header and Footer Sections
  - Create and Remove Header and Footer Sections
  - Create Header and Footer Sections From an Input Section
  - The Display Order of Header and Footer Sections
- **Alternate Sections**
- **Inserted Sections**
- **Setting Section Properties**
# Chapter 8: Tables

- **About Tables** ........................................... 144
- **Working with Tables** .................................. 145
  - Create Tables with the Wizard ......................... 145
  - Create a Table ........................................ 145
  - Change Table Properties ................................ 146
  - Delete a Table ......................................... 147
- **Table Properties** ........................................ 148
  - Table Levels .......................................... 148
  - Sorting Modes ......................................... 149
  - Header and Footer Sections ............................ 149
  - Grouping Options ..................................... 150
  - About Parent/Child relationships ..................... 151
  - Setting Table Pagination Controls ................... 152

# Chapter 9: Objects

- **About Objects** .......................................... 154
  - About Objects and Sections ............................ 154
  - Selecting Objects in Different Views ................. 155
  - Using Variables to Control Objects .................. 155
  - Window Display Preferences ........................... 156
- **Creating Objects** ...................................... 157
  - Adding Text to the Page ................................ 157
  - Copy Data Variables from an Input Section .......... 160
  - Drag and Drop Variables from the Input Window .... 161
  - Adding Subforms ...................................... 162
Chapter 10: Variables

About Variables ................................................. 190
Data Variables and Derived Variables ...................... 191
User Variables ......................................................... 192
Global User Variables ............................................. 194
System Variables ....................................................... 195
Lookup Variables ....................................................... 197
Environment Variables .............................................. 200
Input (CSV) Window Preferences ........................................ 231
Input (JDE PDF) Window Preferences .................................. 232
Input (JDE PDF) Window Sections Preferences ..................... 233
Input (Text) Window Preferences ........................................ 234
Input (Text) Window Sections Preferences .......................... 235
Input (XML) Window Preferences ....................................... 236

Spelling and Language .................................................. 237
Languages ......................................................................... 238
User Dictionaries ............................................................ 238
Colors ............................................................................. 240

Appendix A: Glossary ..................................................... 241

Glossary ........................................................................... 242
INTRODUCING CREATE!FORM TRANSFORM

Create!form Transform is a design component of the Create!form™ Distributed Output Management (DOM) system, that allows you to build customized data transformations, which can be applied to text, CSV, XML and other input file formats.

• Who is this Guide For?
• Create!form Transform Features
• Design Prerequisites
• Production Prerequisites
• Getting Help
• User Guide Conventions
**Who is this Guide For?**

This user guide is for people who design projects with Create!form Transform.
Create!form Transform Features

With Create!form you can customize your documents without making modifications in your enterprise server. The following examples introduce some of the features that Create!form Transform offers:

**Text files**
You can add, remove and reposition data on a page; change the page length and width; or remove pagination altogether.

**Transactional data**
You can convert XML transactional data, as formatted text or CSV files, into a format suitable for processing by other system components.

**Database updates**
You can update any database with the contents of a text or XML file, by converting the data into a CSV data file.

**Database extraction and merging**
You can extract the contents of any database, either by looking up the records directly in the database, or by processing an extracted CSV data file, and merge the extracted data with the contents of other documents.
Design Prerequisites

The following are required before you can begin designing your project:

- Basic familiarity with Windows concepts
- Basic familiarity with word-processing software
- Adobe Reader version 4 or greater for viewing the user guide.

Refer to the Installation Requirements for more information on system and hardware requirements.
Production Prerequisites

Before you can start printing you must install and configure Create!form Server on the network e-forms server. For more information see the Create!form Server user guide. Depending on your preferred output format, you can also install the Create!archive, Create!fax or Create!email output modules.
Getting Help

Help is available in both Portable Document Format (PDF) and as online help.

To view and print the PDF user guide
- Open the file Create!form Transform 6.3.pdf with Adobe Reader from the Manuals directory on the installation CD, or
- From the Windows Start menu select:
  Programs > Create!form > Manuals > Create!form Transform

To view the online help
- Start Create!form Transform and select Help > Help Topics from the Main menu
User Guide Conventions

Section headings are listed at the front of each chapter to assist you in finding the relevant information. In the electronic version of this document, clicking on these and other cross references will take you to the appropriate section.

The following typographical conventions are used:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Convention Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Screen items and buttons.</td>
</tr>
<tr>
<td>Item &gt; Sub-Item</td>
<td>Menu selection; i.e., select the menu Item and then select the Sub-Item from the drop-down list, e.g., File &gt; New.</td>
</tr>
<tr>
<td>Numbering 1</td>
<td>Step-by-step procedures. To perform an action, follow these instructions in the sequential order given.</td>
</tr>
<tr>
<td>Note</td>
<td>Additional information relating to the topic.</td>
</tr>
<tr>
<td>Cross reference</td>
<td>Short cut or reference to the document, chapter or section described after the symbol.</td>
</tr>
<tr>
<td>Important</td>
<td>Critical information relating to the topic.</td>
</tr>
</tbody>
</table>
INTRODUCING CREATE!FORM TRANSFORM

- User Guide Conventions

-
Chapter 2: Installing

INSTALLING

Create!form Transform is installed on a Windows workstation from the Create!form installation CD.

The following topics are covered in this chapter:

• Installation Requirements
• Installing Create!form Transform
• Starting Create!form Transform
Installation Requirements

Create!form Transform requires the following:

• Microsoft Windows 2000/2003/XP/Vista Business
• Microsoft Internet Explorer 5.0 or greater
• Adobe Reader 4 or greater (for viewing the User Guide)
• approximately 30 MB of free hard disk space
• a PostScript level 2 or greater printer is recommended
Installing Create!form Transform

Create!form Transform is installed automatically when you install Create!form Director.
Starting Create!form Transform

From the Windows Start menu

- Click the Start menu and select:

  Programs > Create!form > Create!form Transform

Refer to Chapter Four, Viewing and Navigating, for more information on screen elements and toolbars.

Refer to Chapter Three, Getting Started, for more information on getting started with Create!form Transform.
Your design is recorded in a project, which contains information about how the input data will be mapped to the output, and the layout of the text on the output page. Each project consists of several files, located in a number of folders which are required whenever the project is opened, saved, moved or transferred.

The following topics are covered in this chapter:

• What is a Project?
• Project Directories
• Creating a Project
• Design Flowchart
• Saving a Project
• Opening a Project
• Printing and Previewing Projects
• Packing Projects
• Transferring Projects to the e-forms Server
• Managing Project Files
What is a Project?

A transform project (or project) is a record of the way you want to reformat and reorganize input data files. Because your enterprise server may output a variety of different documents, you will need to create a project for each of these variations.
Project Directories

The project files are stored in the following folders:

• Project Directory
• Common Project Directory

The project also uses resources from a number of system folders.

Project Directory

Each project has a project directory. This is the location where you save the project and where its components are stored. When Create!form Transform is installed, a default project directory is created: <install dir>\WorkDir. This is where you will be prompted to save all new projects. During the installation or at a later time, you can change this default project directory.

To change the default project directory

1 From the Main menu, select tools > Preferences. The Preferences dialog will be displayed.

2 From the General pane, set the Default Project directory.

3 Click OK.

It is recommended that you use separate directories for design projects and production projects. For example, use \WorkDir for your design work and create a new directory \ProdDir for completed, live projects.

Common Project Directory

Project components that are shared between projects are stored in the common project directory. When Create!form Transform is installed a default common project directory is created: <Install dir>\CommonProject. You can specify another location for the common project directory at any time.
To change the common project directory

1. From the Main menu, select Tools > Preferences. The Preferences dialog will be displayed.

2. From the General pane, set the Common project directory.

3. Click OK.
Creating a Project

Before creating a project, you must choose a suitable input file. The input file should be representative of the files likely to be encountered in a production environment and should contain all possible variations of content and format. The elements and structures of the input file, which you identify during the input design process, are recorded in a DataMap. Refer to Chapter Five, Input Design, for more information.

The New Project Wizard will guide you through the process of creating a new project. You will be given a number of options by the wizard, which may include:

- Input File Type
- Using an Existing Project as a Template
- DataMap Options
- Project Type
- Output Structure Options

To complete your design, follow the steps described in the Design Flowchart relevant to the input file type you have selected.

New Project Wizard

The New Project Wizard will guide you through the process of creating a new project.

To start the New Project Wizard

1. From the Main menu, select File > New, or click the New Project button. The New Project Wizard dialog will be displayed. Refer to Input File Type for more information.

2. From the Type drop-down, select the type of source file from the available file types.

3. From the File/Data source drop-down, select the input source file you wish to open, from the current project directory. If the file you want is not listed, click to display the Select Input File dialog. Locate the input file from this dialog and click Open to select the file.
30 GETTING STARTED

Creating a Project

4 Click Next. The sequences and display of dialogs displayed by the wizard will vary depending on the type of input file selected in the first dialog.

5 Continue to follow the wizard instructions and click Finish when you have completed all options.

For descriptions of these options refer to:

- Using an Existing Project as a Template
- DataMap Options
- Project Type
- Output Structure Options

Note

The project created by the wizard will be configured according to the options you select; you can, however, change the project by adding or removing features during the design process.

Input File Type

The New Project wizard will give you the option of selecting from the available input file types. The input files types supported by Create!form include text, CSV, XML and JDE-PDF. Refer to Chapter Five, Input Design, for more information.

Using an Existing Project as a Template

You can use another project as a template when you create the project with the new project wizard, or later by select the Project > Apply Design Template command. The new project will be an exact copy of the template project including the DataMap and the output design. To successfully apply a template, the input files in both projects must be the same type and have the same structure. When you apply a template to an existing project, the output design will be lost.
DataMap Options

The New Project wizard gives you the option of creating a new DataMap, copying the DataMap from another project, or using a shared DataMap.

Create a new DataMap

- Choose the Create a New DataMap option if you have not previously created a DataMap for an input file of this type and structure.

If a suitable DataMap does exist, you can choose to either copy the DataMap, or if it has already been shared, you can share the DataMap with other projects.

Copy a DataMap from another project

- Choose the Copy a DataMap from another project option if you need to modify the DataMap in any way.

Select a shared DataMap

- Choose the Select a Shared DataMap option if the DataMap can be used without modification.

Refer to DataMap Types and Options for a full description of these options.

Project Type

When you are working with a text input file, you can choose the type of project you want to create. The New Project wizard gives you the option to:

- Create a Standard Project
- Create a Simple Project
- Create an Overlay Project

Standard Project

Create a standard project when the input file structure is variable or requires repagination, table sorting, sub-totaling, substantial reformatting, or summary reporting. In a standard project you can utilize Create!form Transform’s many features to map any data from the input file to the project, and then reformat and manipulate the input data in the project.
Output Structure Options

In a standard project you have the option of creating sets and tables in the project.

Set Headers and Footers

Choose the Set headers and footers option if the input file contains groups of pages. For example, a print run might contain multiple invoices for the same customer. The invoices for one customer would form a set. Refer to Defining Sets for more information.

Tables with Headers and Footers

Choose the Table with headers and footers option if the body of each page contains repeating line items that you want to sort and subtotal in the project, or if you require floating headers and footers. Refer to Chapter Eight, Tables, for more information.

Simple Project

Create a simple project if only minimal reformatting of the input data is required. In a simple project, one output page is generated for every input page, but you can still selectively map the contents of the input page and then re-position, re-order and reformat as required on the output page.

Overlay Project

Create an overlay project if you don’t want to change the layout, design and formatting of the input file, and need only to add text to the output pages. In an overlay project the entire input page is mapped directly to the output page.
Design Flowchart

The following flowcharts list the steps required to create projects for the main input file types:
Figure 3.1: An overview of the design processes for CSV input files.
Figure 3.2: An overview of the design processes for text input files.
Figure 3.3: An overview of the design processes for XML input files.
JDE PDF

Define sets
Refer to Defining Sets for more information

Define Input Sections

Copy Data Variables to the output

Set the project properties and format styles
Refer to Project Settings for more information

Organize Sections in the project

Create Tables for repeated data sections

Add and format text
Refer to Objects for more information

Figure 3.4: An overview of the design processes for JDE PDF input files.
Saving a Project

You should save your work regularly. You can store projects in any directory, but Create!form Transform looks in only two directories for the files used in each project:

- The `<Install dir>\CommonProject` directory, which typically contains items common to various projects
- A project directory dedicated to particular objects. You can create as many projects directories as you want. On install, one project directory exists, called `<Install dir>\Workdir`.

---

Note

*When moving a project to another location, save it as a packed project file type. Refer to Packing Projects for more information.*

---

To save a project

- From the Main menu, select File > Save, or click on the Main toolbar. If you are saving a project for the first time, the Save as dialog will be displayed. Unless you have selected the Save to common project directory checkbox, Create!form Transform will save the project and the DataMap to the current project directory. Refer to Managing Project Files for more information about the files created by Create!form Transform.
Opening a Project

To view, edit, print or transfer a project, you must open the project with Create!form Transform.

**To open a project**

1. From the Main menu, select File > Open. The Open dialog will be displayed and show files from the current project directory. To display files in the /CommonProject directory, select the Look in common project directory checkbox.

2. Select the project and click **Open**.
Printing and Previewing Projects

Projects can be printed locally, using the data from the input file. The output can also be previewed on-screen in Notepad, or another text editor.

**To print a project**

1. From the Main menu, select File > Print. The Print dialog will be displayed.
2. Select the required printing options and/or view an on-screen preview.
   - Select a printer
   - Select the page range
   - Choose whether to show variable values or names, or whether to hide them
   - Choose whether you want duplicate copies, or whether you want to use the project settings for duplicates. Refer to Duplicates for more information.
3. Click Print.

Local print settings will not affect how the project behaves in production printing.

**To preview the project**

- From the Main menu select File > Print Preview.

The settings made on the Print dialog are used when previewing the project. If the preview does not appear as expected, check the settings on the Print dialog.
Packing Projects

Because projects are made up of several different files (the project file, input data file, DataMap, and subforms), Create!form Transform allows you to save all associated files into a single packed project. The entire project can then be easily moved and opened on any computer.

**To save a project as a packed project**

1. Open the project.
2. From the Main menu, select File > Save As. The Save As dialog will be displayed.
3. In the Save as type field, select Packed Project files.
4. Click Save.

The packed project is saved with the specified name, with an .tpp6 extension. To send the packed project, simply email it as an attachment.

To open a packed project, from the Open dialog, select Packed Project file from the Files of type field.
Transferring Projects to the e-forms Server

Before the project can be used for production printing, you must transfer the project and its associated resources to the e-forms server.

To transfer a project to the e-forms server

1. From the Main menu, select Tools > Transfer. The Transfer to Server dialog will be displayed.

2. Select the project to be transferred to its destination.

You will find a complete discussion on transferring projects and the options displayed on the Transfer to Server dialog in the Create!form user guide.
Managing Project Files

Create!form Transform creates and uses a number of different file types that can be identified by their icons and filename extensions.

**Table 3.1:**

<table>
<thead>
<tr>
<th>File Type</th>
<th>Icon</th>
<th>Extensions</th>
<th>Created By</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project</td>
<td>.ctp6</td>
<td></td>
<td>File&gt;Save and File Save As</td>
</tr>
<tr>
<td>Project Backup</td>
<td>.ctp6bak</td>
<td></td>
<td>Refer to General Preferences for more information</td>
</tr>
<tr>
<td>DataMap</td>
<td>.dmp6 (text)</td>
<td></td>
<td>File &gt; Save and File &gt;Save As</td>
</tr>
<tr>
<td></td>
<td>.cmp6 (CSV)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>.xmp6 (XML)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>.jmp6 (JDE PDF)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DataMap Backup</td>
<td>.dmp6bak etc</td>
<td></td>
<td>Refer to General Preferences for more information</td>
</tr>
<tr>
<td>Packed Project</td>
<td>.tpp6</td>
<td></td>
<td>Refer to Packing Projects for more information</td>
</tr>
<tr>
<td>Subform</td>
<td>.cff6</td>
<td></td>
<td>Tools &gt; Create Subform &gt; Design New</td>
</tr>
<tr>
<td>Input File</td>
<td>various</td>
<td></td>
<td>external source</td>
</tr>
</tbody>
</table>

The project files may be located in either the project directory or the common project directory.

Care should be taken when deleting, moving, or renaming project files as this may corrupt the project. Whenever you move, copy or send a project to another location, you should pack the project first.
GETTING STARTED

- Managing Project Files
Create!form Transform allows you to interact with and navigate through your projects with familiar, graphical and easy to use interface, which can be customized to suit your needs.

- Understanding the Screen Elements
- Navigating in a Project
Understanding the Screen Elements

The Create!form Transform interface can be customized to suit your needs. The following topics describe the function of the different windows and views in detail.
Note that the appearance and position of each element may vary, depending on screen size and the current view and customization settings.

*Figure 4.1: The Create!form Transform screen*
**Design Window**

The Design Window has two viewing modes, the Graphics View and the Listing View. To switch between them, click the Graphics View or the Listing View on the Main toolbar. The sections of the project are displayed as tabs at the bottom of the Design Window.

- The Graphics View displays what the project will look like when you print it, and allows you to select, edit and manipulate objects. The Graphics View of the Design Window is where you will perform most of your project design tasks.

- The Listing View is a non-graphical representation of all objects in the selected section, along with key information about each object. The Listing View enables you to easily identify objects when the Graphics View is crowded. You can select, edit and work with all objects in the Listing View in the same way as the Graphics View.

You can change the sort order of the Listing View by clicking on the column heading you wish to sort by. If the X-Origin or Y-Origin is displayed in the red text, it indicates that part (or all) of the object is off the page layout area.

You cannot hide the Design Window, but you can customize its look and feel. Refer to Design Window Preferences and Design Window Sections Preferences for more information.

**Input Window**

The Input Window displays the input file. When you float the cursor over data in the input file, the name of the data variable will be displayed (Text and JDE PDF input files only.) This can help you to select the correct variable when copying to the Design Window.

To show or hide the Input Window, click the Input Window on the Main toolbar or select View > Input Window from the Main menu. Several task shortcuts are available by right-clicking on items in the Input Window.

Refer to User Preferences to customize the look and feel of the Input Window.
**Project Tree**

The Project Tree displays the logical structure of the project. It contains a list of all sections and all objects, including their properties. Several task shortcuts are available by double-clicking and right-clicking on items in the Project Tree.

To show or hide the Project Tree, click the Project Tree on the main toolbar or select View > Project Tree.

**Input Tree**

The Input Tree displays the logical structure of the input file. It provides details about the input file as a whole and individual sections within it. Several task shortcuts are available by double-clicking and right-clicking on items in the Input Tree.

To show or hide the Input Tree, click the Input Tree on the Main toolbar or select View > Input Tree from the Main menu.

**Thumbnail View**

The Thumbnail View provides a thumbnail of each page of the project, allowing you to scan the formatting of multiple pages.

To show or hide the Thumbnail View, click the Thumbnails on the Main toolbar or select View > Thumbnails from the Main menu.

Refer to Thumbnail Preferences to customize the look and feel of the Thumbnail View.

**Input File Source View**

The Input File Source View displays the raw input file.

To show or hide the Input File Source View, select View > Input File Source from the Main menu.
Status Bar

The Status bar provides a variety of information about the project as a whole and the current location within the project.

Figure 4.2: The Status bar

Shortcuts are available by double-clicking on the section and background tabs.
Navigating in a Project

The section tabs on the Status bar only appear for sections that are displayed on the current page of the active window. To locate occurrences of some sections using the tabs, you may need to browse the pages of the project.

To navigate to other pages or sections of the project
Click the appropriate button from the Navigation toolbar. The action will be applied to the active window.

By default when you browse to a particular section in the Design or Input Window, the corresponding section in the other window will be displayed. This synchronization can be turned off and on. Refer to Input (CSV) Window Preferences for more information.

Jumping Directly to a Set or Page

To go to a set specified page number
1. From the Main page menu, select Page Go To. The Go To Page dialog will be displayed.
2. Enter the page number to go to, or select the page number from the drop-down.
3. Click OK. The page select will be displayed.
To go to a specified set number

1. From the Main menu, select Set Go To. The Go To Set dialog will be displayed.

2. Enter the set number to go to, or select the set number from the drop-down.

3. Click OK. The first page of the set selected will be displayed.
Moving Between Sections

In order to edit and format sections, they must be selected. You can select sections in the following ways:

- Click on the section.
- Press the arrow keys to move up or down one section in the current window.
- Press the TAB key to move to the next occurrence of that section and SHIFT + TAB to move to the previous occurrence of that section.
- Click on the section tab on the Status bar. All sections that are displayed on the current page will have tabs.
- Select the section in the Project Tree and the Input tree. This is the only way you can edit the properties of a section if it is not set to display.
- Use the buttons on the Navigation toolbar.
54 * VIEWING AND NAVIGATING
  - Navigating in a Project
  -
  -
Chapter 5: Input Design

Input Design

The input design process involves identifying and labelling the different parts or elements of the input file. The way in which you identify, label and organize the data in the input file is recorded in the DataMap.

The following topics are covered:

- Before You Start
- Key Input Design Concepts
- DataMap Types and Options
- Designing for CSV Input Files
- Designing for Text Input Files
- Designing for XML Input Files
- Designing for JDE PDF Input Files
- Creating Derived Variables
Before You Start

The following topics contain information about some basic procedures, which you may find useful:

- Using the Create!form Sample Projects
- Selecting a Different Input File
- Viewing the Input File Source

Before proceeding to the details of designing a particular file type, you must also be familiar with:

- Key Input Design Concepts
- DataMap Types and Options

Using the Create!form Sample Projects

Sample input files have been provided with the installed software so that you can practice performing the tasks described in this user guide. The samples can be found in the `<install dir>\CF6Samples\Tutorials` folder. You can view the text, CSV, and XML sample files with any text editor. You should complete each task in sequence as later tasks may assume that earlier tasks have already been completed.

Selecting a Different Input File

If the input file you chose for the input design is unsuitable, or if you want to test your input design on another sample file, you can select a new input file at any time.

To select a different input file

1. From the Main menu, select Project > Select Input File. The Select Input File dialog will be displayed.
2. Navigate to the folder where the file is located and select the new input file.
3. Click Open. The project will refresh with the new data.
Viewing the Input File Source

To view the input file source, select the View > Input File Source command from the main menu.
Key Input Design Concepts

Before you begin your design, you must be familiar with the following key concepts:

- What is a DataMap?
- What is a Set?
- What is a Section?
- What is a Data Variable?
- What is a Derived Variable?

What is a DataMap?

The input design process involves identifying and labeling the different parts or elements of the input file such as header data, line items and footer text. The input file may be an unstructured text file, for which you must create rules that identify each part of the file; or, the file may be structured like the CSV and XML formats, which are largely self-defining, but may still require some editing and relabeling. The way in which you identify, label and organize the data in the input file is recorded in the DataMap. You must define a DataMap for every project; however, where the input file structure is the same, you can share the same DataMap between several projects.

The information recorded in the DataMap will include:

- The properties of the input file
- How sets are defined
- How sections are defined
- How data variables are defined
- How derived variables are defined

Refer to DataMap Types and Options for more information about creating, editing, and sharing DataMaps.
What is a Set?

Where the input file contains sequential related pages or blocks of data, such as account statements for multiple customers, you can group these pages or data together as sets.

During production printing, each set can be treated as a self-contained document. Defining sets also allows you to make use of various pre-defined system conditions, which can be used to apply different formats, or insert extra pages at the start and end of each set.

What is a Section?

A section describes a repeated group of data in the input file. For example, in a text file, the rows that contain header text at the top of each page will form a section, while in a CSV file, each row will form a section.

By describing all the different types of data in the input file in this way, the information contained in each section can be more easily reorganized and reformatted in the project.

What is a Data Variable?

Input sections can be composed of several different types of information. For example, the input header sections might contain names, addresses, dates and various reference numbers. A data variable specifies a particular field of data in each section.

Input data cannot be displayed or used in the project unless the data has been identified as a data variable in the input file. The process of defining data variables will vary according to the type of input file you are processing. For more information, refer to the relevant input format type in the sections that follow.
What is a Derived Variable?

You can combine and manipulate data variables in user defined expressions that are called derived variables. Examples of how derived variables can be used include:

- To retrieve a substring of characters from a data variable
- To concatenate two or more data variables into one string of characters
- To convert the format of dates
- To find abbreviations and substitute with the expanded text
- To derive values from an arithmetic formula using one or more data variables

Derived variables will appear as data variables in the project.
Refer to Creating Derived Variables for more information on the properties of derived variables and how they are defined.
DataMap Types and Options

You can use either an embedded DataMap, or share a DataMap with other projects, which can be selected when you create the project, or later while designing the project.

What would you like to know about?

• Embedded and Shared DataMaps
• DataMap Options When Creating a New Project
• DataMap Options While Designing a Project

Embedded and Shared DataMaps

A DataMap can be either:

• **Embedded**
  
  An embedded DataMap is associated with a single project, and can be edited and saved without reference to other projects. When you create a new DataMap, or copy a DataMap from another project, the DataMap status is set to embedded.

• **Shared**
  
  A shared DataMap can be used by multiple projects. Any changes made to a shared DataMap will affect every project that uses it.

To confirm the status and name of a DataMap

1. From the Main menu, select the Project > DataMap command. The Change DataMap dialog will be displayed.

2. The status of the DataMap is displayed, and
   - if the status is shared, the name of the shared DataMap is also shown.
   - if the status is embedded, the name of the DataMap can be determined by adding the appropriate extension to the stem of the project name e.g., if the input file type is CSV, the project MyProject.ctp6 creates an embedded CSV type DataMap with the name MyProject.cmp6. Refer to Managing Project Files for more information about file names.
DataMap Options When Creating a New Project

The New Project wizard gives you the option to:

- **Create a new DataMap**
  
  Choose this option if you have not previously created a DataMap for the type of input file you are working with.

- **Copy a DataMap from another project**
  
  Choose this option if you have previously created a DataMap in another project for the same input file, which you want to modify for the new project.

- **Select a shared DataMap**
  
  Choose this option if you are able to use a DataMap from another project without modification. You must share the DataMap before it can be selected. Refer to To share a DataMap with other projects for more information.

DataMap Options While Designing a Project

In an existing project, you can edit the DataMap or change the status of the DataMap in several ways.

**What do you want to do?**

- Edit an Embedded DataMap
- To copy a DataMap from another project
- To share a DataMap with other projects
- Edit a Shared DataMap
- Use a Shared DataMap
- Embed a DataMap

**Note**

You must exercise care when changing the DataMap in an existing project, to ensure that the input sections, data variables and derived variables defined in the new DataMap are compatible with your existing design.
Edit an Embedded DataMap

You can edit an embedded DataMap at any time. The DataMap will change whenever the input design is changed.

To copy a DataMap from another project
1. From the Main menu, select the Project > Change DataMap command. The Change DataMap dialog will be displayed.
2. Select the Copy from another DataMap option.
3. Click Select and locate the DataMap file you want to copy.
4. Click OK.
The existing DataMap will be overwritten and the status remains embedded.

To share a DataMap with other projects
1. From the Main menu, select the Project > Change DataMap command. The Change DataMap dialog will be displayed.
2. Select the Share this DataMap as option.
3. The name of the shared DataMap is displayed, and can be edited.
4. Click OK.
The DataMap will be moved to the \CommonProject directory and renamed. The DataMap will be changed to shared.

Edit a Shared DataMap

You can edit a shared DataMap from any project that uses the DataMap. A warning will be displayed when you open additional projects that share the same DataMap.

When you edit a shared DataMap, the changes will be applied to all projects that use the same DataMap. A warning will be displayed before the edited DataMap is applied to other open projects.
Use a Shared DataMap

Before you can use a shared DataMap, you must first share the DataMap from the original project. Refer to To share a DataMap with other projects for more information.

To use a shared DataMap
1. From the Main menu, select the Project > DataMap command. The change DataMap dialog will be displayed.
2. Select the Select a Shared DataMap option.
3. Click Select and locate the DataMap file you want to use. Shared DataMaps are stored in the \CommonProject directory.
4. Click OK.
The DataMap status will be changed to shared.

To select a different shared DataMap
1. From the Main menu, select the Project > Change DataMap command. The Change DataMap dialog will be displayed.
2. Select the Select a different shared DataMap option.
3. Click Select and locate the DataMap file you want to use. Shared DataMaps can be stored in project directories and the common project directory.
4. Click OK.

Embed a DataMap

In a project that uses a shared DataMap, you can embed either the shared DataMap, or a DataMap from another project.

To embed a DataMap
1. From the Main menu, select the Project > Change DataMap command. The Change DataMap dialog will be displayed.
2. Select one of the following options:
   • Embed DataMap into project
   • Embed copy of another DataMap into project
3 If selecting another DataMap, click Select and locate the DataMap file you want to use.

4 Click **OK**.

The DataMap is copied into the Project Directory and named according to the project stem and DataMap type. The DataMap status will be changed to embedded. Refer to Managing Project Files for more information.
Designing for CSV Input Files

The input design process for CSV files involves identifying the row and column structure of the CSV input file; this information is recorded in the DataMap. A DataMap for an CSV input file is denoted by .cmp6 file name extension.

What would you like to know about?
- CSV File Structure
- Input File Properties
- Defining Sets
- Defining Sections
- Working with Data Variables

To create the CSV sample project
1 To start the wizard, click the New Project button on the Main toolbar.
2 From the Type drop-down, select CSV from the available file types.
3 Click to display the Select Input File dialog and select the file Chapter5Sample.csv from the <install dir>\CF6Samples\Tutorials folder.
4 Click Next.
5 Select the Create a new DataMap radio button and click Next. A new DataMap will be created.
6 Ensure the Set headers and footers checkbox and the Table with headers and footers checkbox are cleared and click Next.
7 Click Finish. The new sample project will be displayed in the Input Window.

CSV File Structure

A CSV file contains repeated rows of data, with each field in a row separated by a particular character called the delimiter. Typically fields are separated by a comma, but other characters can be used, including spaces and tabs. The file may also contain a header section, and a column heading row. The important
elements of a CSV file are demonstrated in sample comma delimited file below:

Note that text values that contain the delimiter character are enclosed by quotation marks, which is referred to as the text qualifier.

**Paginated CSV Files**

If the CSV input file is paginated and contains page header and footer sections, you must treat the input as a text file, in which you will be able to define the page length and separately identify the detail sections from the header and footer sections. In a text input file, you can create a data variable that contains the entire data row, and then use the retrieve function to extract the delimited field values as user variables. Designing for Text Input Files for more information.
Input File Properties

The input file properties determine how the structure of the CSV input file will be interpreted.

To change the input file properties

1. Select the Input Window by clicking anywhere inside the input window frame.
2. From the Main menu, select Input > File Properties. The Input File Properties dialog will be displayed.

3. In the Delimiter section, select a delimiter character and a text qualifier.
4. In the Header section, select the number of header rows and indicate whether the file contains a column heading row.
5. In the Data format section, select the format used for date and decimal values in the input file.
6. Click OK.

The changes will be applied to the input file and the input window will be refreshed.
Defining Sets

You can use the following means to determine when a new set starts:

- The entire input file can be treated as one set (default setting)
- When the value in one or more columns changes
- One set per row

To define sets

1. From the Main menu, select Set > Define. The Define Set dialog will be displayed.
2. Select one of the radio button options to determine when a new set starts:
   - Treat entire spool file as one set
   - When values change in marked columns:
     - Select one or more columns
   - One set per row
3. Click OK.

Defining Sections

Sections are created automatically from the structure defined by the Input File Properties dialog:

- **InputFileHeader**
  The optional section at the top of the file that contains header text.
- **Detail**
  The repeating rows in the body of the file that contain the delimited data.

The sections created are displayed in the Input Window.
Working with Data Variables

Data variables are created automatically from the structure defined by the Input File Properties dialog. The data variables created are shown in the Input Tree view.

What would you like to know about?

- Data Variables in the Input Header Section
- Data Variables in Detail Sections
- Changing the Properties of Columns
- Changing the Input Data Format
- Copying Data Variables to the Project
Data Variables in the Input Header Section

In the input header section, a data variable will be created for each header line.

Data Variables in Detail Sections

In detail sections, a data variable will be created for each column. The column heading will be used as the data variable name.

Changing the Properties of Columns

You can change the name, type and other properties of columns that define data variables.

To change the properties of a column
1. In the Input Window, click the column heading you wish to edit. The Column Properties dialog will be displayed.
2. To change the column heading and the name of the data variable, type a new name in the Name field.
3. In the Type field, select text, numeric or date as the data type.
4. To repeat the last non-blank value in blank fields, select the Repeat previous value if blank checkbox.
5. Click OK.

Changing the Input Data Format

Create!form Transform interprets dates and numeric data in the input file using the data formats defined by the input file properties. For example, you can change the decimal separator to a comma, or the date order from year-month-day to month-day-year.

To change the input data format
1. From the Main menu, select Input >File Properties. The Input File Properties dialog will be displayed.
2. From the Date order drop-down, select the required date format.
3 From the Decimal symbol drop-down, select the required numeric format.

4 Click OK.

**Copying Data Variables to the Project**

Data variables defined in the Input Window can be displayed in the project by dragging the data variable into the Design Window.

**To copy a data variable to the project**

1 In the Input Window, select the data variable.

2 Drag-and-drop the selected variable from the Input Window across into the Design Window.

Refer to **Creating Objects** for more information on adding text variables and other objects to the project.
Designing for Text Input Files

The input design process for text files involves identifying and labelling the different parts or sections of the input file such as header text, line items and footer text. You must create rules that identify each of these parts of the input. These rules are recorded in the DataMap. A DataMap for a text input file is denoted by the .dmp6 file name extension.

The information recorded in the DataMap includes:

- Classification of rows on each page into input sections
- Input file page properties
- Grouping of pages as sets
- Mapping of the contents of input sections as data variables
- Definition of derived variables

What would you like to know about?

- Input Sections
- Examining How Sections are Populated
- Design Principles
- Setting the Input Page Size
- Defining Sets
- Working with Data Variables
- Common Input Section Tasks
- Working with Input Header Sections
- Working with Detail Sections
- Working with Input Footer Sections

To create the text sample project

1. To start the wizard, click the New Project button on the Main toolbar.
2. From the Type drop-down, select Text from the available file types.
3. Click to display the Select Input File dialog and select the file Chapter5Sample.txt from the <install dir>\CF6Samples\Tutorials folder.
4 Select the Create a New DataMap radio button and click Next. A new DataMap will be created.

5 Click Next.

6 Select the Standard radio button and click Next. This option will permit you to fully define the structure of the input file.

7 Ensure the Set headers and footers checkbox is selected, and the Table with headers and footers checkbox is cleared and click Next. Sets will be automatically created in the project. No tables will be created.

8 Click Finish. The new sample project will be displayed in the Input Window.

Figure 5.4: Input Window showing the sample project input file.

Horizontal ruler measures page width in characters.

Vertical ruler measures page length in lines.

The page is divided into sections. Section boundaries are shown as dashed lines.
Input Sections

There are four types of sections used to define the structure of the input file:

**Input file header section**: A non-repeating section at the start of the file that contains header text (Refer to Working With the Input File Header Section for more information).

**Input header section**: A section at the top of each page that contains header text (Refer to Working with Input Header Sections for more information).

**Detail section**: Used to define repeating rows within the body of the page (Refer to Working with Detail Sections for more information).

**Input footer section**: A section at the bottom of each page that contains footer text (Refer to Working with Input Footer Sections for more information).

The following graphic displays the way you would define the sections of the sample file that are repeated on each page of the input file. The input file header section occurs once, at the start of the file.

Refer to Display and Edit Input Section Properties for information on how each section in the input file has a different set of properties.
Examining How Sections are Populated

To assist you in the design process, you can examine all the instances of a section in the input file with the **Input > Show All Instances** command. In this view mode, all non-blank characters in all instances of the selected section will be marked with an “X”.

![Figure 5.6: Examining all instances of a section in the input file](image)

**Design Principles**

Create!form Designer can handle a variety of input file structures, from simple tables to complex and irregular forms. This section introduces the design principles that form the foundation for the procedures described later in this chapter.

**Designing From the Top-Down**

The most important principle, when preparing the input file, is to approach the design from the top-down. As depicted in the Design flowchart, start with the input header section on the first page and make any adjustments needed to the section before looking at the next section. Scan the page from the top-down and locate the first anomaly. Resolve the anomaly, then move down the page to the next anomaly. When the design is correct on the first page, view the second page, again from the top-down. Proceed through the file until the design is complete from start to finish — from top to bottom.
Design Flowchart

The following flowchart describes the main tasks associated with input design.

![Design Flowchart Diagram]

*Figure 5.7: Input Design Flowchart*
Setting the Input Page Size

Create!form Designer can handle fixed or variable page lengths, and widths of up to 2048 characters. You can define the input file page length in the following ways:

- By a form feed character (default setting)
- The page has a fixed number of lines
- By a page number
- By a specified character

The input page size is set from the Input File Properties dialog.

![Input File Properties](image)

For information on other input file properties refer to Other Input File Settings.

Figure 5.8: Input page size options on the Input file Properties dialog
To define the input file page width and length

1. From the Main menu, select Input > File Properties. The Input File Properties dialog will be displayed.

2. In the Lines field, type the page length in lines.

3. In the Columns field, type the line width in characters.

If you are unsure of the page length or line width, click the Recalculate button to scan the input file and find the maximum page length and line width in the file. Refer to How the Page Size is Calculated for details on how to calculate page size.

4. In the End of page section, select one of the following radio button options:
   - **Form feed**
     A new page will be generated whenever a form feed character is encountered.
   - **Fixed number of lines**
     A new page will be generated according to the Lines field above.
   - **Characters**
     A new page will be generated when the specified characters or character string is encountered.

In the **Characters** field, type the character or character string. If the string is in a specific location, type the starting position of the string in the at column field; all other occurrences of the string will be ignored.

Select the appropriate radio button to determine how the character string will be applied.

Select define the first line of a page if the new page begins at the start of the line containing the string.

Select define the last line of the page if the new page begins at the start of the next line following the line containing the string.

Select terminate the page if the new page begins at the next character following the string.

5. Click **OK**.
How the Page Size is Calculated

Once Create!form designer has calculated the page size for a project, it remains unchanged until the Page size fields are edited, or the Recalculate button is selected.

When creating standard and simple projects

When creating a new standard or simple project, Create!form designer will read the first 10 pages of the file to determine the maximum lines and columns per page. If the number of lines is less than the current default value, the default will be used. If the number of columns is less than the current default value, the default will be used.

When creating an overlay project

When creating a new overlay project, Create!form designer will read the first 10 pages of the file to determine the maximum lines and columns per page. The calculated page size is always used and the default values are ignored.

When recalculating the page size

When you click the Recalculate button, Create!form designer will read the first 10 pages of the file to determine the maximum lines and columns per page. The calculated page size is displayed and the default values are ignored.

To change the default number of lines and columns

1. In the Lines and Columns fields, type the new default values.
2. Review the other settings in the Input File Properties dialog and set default values as appropriate.
3. Click the Set as Default button.

The default settings may be applied when a new standard or simple project is created (see above) or whenever the Reset from Default button is selected.

Other Input File Settings

In addition to page size settings, the following properties are also set from the Input File Properties dialog:

- **Data format**: Sets the formats used by data variables. Refer to Set Input Data Formats for more information.

- **Ignore leading blank pages**: Select to ignore blank pages at the start of the input file.
- **File starts with document header:** Creates an input file header section. Refer to *Working With the Input File Header Section* for more information.

- **Ignore bold and underline formatting**
  When processing OS/400 spool files (typically in overlay projects), if the spool file contains bold and underline overstrike control characters, you can choose to either ignore overstriking or convert the overstrike characters into PostScript. Previously this option could only be set in the writer properties on the server.

![Image of Input File Properties dialog](image-url)
To define input file properties
1. From the Main menu, select Input > File Properties. The Input File Properties dialog will be displayed.
2. Select options as required.
3. Click OK.

Defining Sets

Defining sets involves specifying when a new set will start. Typically a new set commences every time the page numbering restarts, but you can also specify that a new set commences when data such as the customer number or invoice number changes.

You can use the following means to determine when a new set starts:
- At the start of each page in the input file (default setting)
- When the page number in the input file is equal to 1
- When the value of a specified character string on the input page changes
- When a specified condition tests TRUE
- The entire input file can be treated as one set

To define sets
1. From the Main menu, select Set > Define. The Define Set dialog will be displayed.
2. Select one of the radio button options to determine when a new set starts:
   - **One set per input page**
   - **When page number = 1 at**
     In the Input Window, click-and-drag a box around the page number. The character position and length of the page number field will be displayed in the Define Set dialog.
   - **When value changes at**
     In the Input Window, click-and-drag a box around the value. The character position and length of the value field will be displayed in the Define Set dialog.
• **On condition**
  Click the Edit button to display the Condition Builder dialog. A new set will start when the condition tests TRUE. Refer to *Conditions* for more information.
• Treat entire spool file as one set.

3  Click OK.

**Working with Data Variables**

**Set Input Data Formats**

Before you start creating data variables, you must set the data formats that Create!form Designer will use to recognize dates and numeric data in the input file. For example, you can change the decimal separator to a comma, or the date order from year-month-day to month-day-year.

**To change the input data format**

1  From the Main menu, select Input > File Properties. The Input File Properties dialog will be displayed.
2  From the Date order drop-down, select the required date format.
3  From the Decimal symbol drop-down, select the required numeric format.
4  Click OK.

**Create Data Variables**

To selectively map particular data from the input, for use in the project, you must create data variables around the data.

**To create a data variable**

1  In the Input Window, select the section containing the data you want.
2  Click-and-drag a box around the area that contains the information you want to store in the variable. The Data Variable Properties dialog will be displayed.
3 In the Name field, type a name for the data variable. The variable name must start with an alphabetic character and then be followed by any combination of alphabetic (a-z, A-Z) and numeric (0-9) characters and underscores. Names are not case sensitive. Naming of variables is entirely at the discretion of the user; however the convention of naming variables to represent the data they contain is recommended. You should think of a name that you will be able to recognize and distinguish from all other data variables in the section.

4 Select a data type from the Type drop-down list.

5 Click OK.

The area defining the variable will appear highlighted.

---

**Note**

*Use the Show All Instances command to examine the extents of a data variable in all instances of the section in the input file.*

---

**To change the size and position of a data variable**

1 In the Input Window, select the data variable.

2 Click-and-drag the resize handles to change the box size, or click-and-drag inside the box to reposition the box.

Refer to *Selecting and Editing Objects in Graphics View* for more information about editing graphic objects.
To display and edit data variable properties

1. Display the Data Variable Properties dialog by doing one of the following:
   - Double-click the data variable in either the Input Window or the Input Tree.
   - Right-click the data variable in either the Input Window or the Input Tree and select Properties from the shortcut menu.

   ![Data Variable Properties dialog](image)

   - **Figure 5.11: The Data Variables Properties dialog**

2. With the Data Variable Properties dialog you can:
   - Change the name of the data variable by typing a new name in the Name field.
   - Select the data type from the Type drop-down. Refer to Set Input Data Formats for more information.
   - Change the position and size of the data variable in the Row, Column, Depth and Length fields. Row and column positions are defined relative to the origin (top left corner) of the selected section.
   - Select the Trim spaces checkbox to remove leading and trailing spaces from the text string.
   - Select the Expandable checkbox to make the data variable expand with the section. Refer to Make Data Variables Expandable for more information.
**To delete a data variable**

1. Select the data variable in the Input Window or Input Tree.
2. Press the Del key.

**Copy Data Variables to the Project**

Data variables defined in the Input Window can be displayed in the project by dragging the data variable into the Design Window.

**To copy a data variable to the project**

1. In the Input Window, select the data variable.
2. Drag-and-drop the selected variable from the Input Window across into the Design Window.

Refer to Adding Text to the Page for more information about adding text to the project.

**Create Data Variables in a Detail Section**

Any data variables created in one occurrence of the detail section will be applied automatically to all other occurrences of the same detail section.

Refer to Create Data Variables for more information.
The area defining the variable will appear highlighted and will be displayed in each occurrence of the same detail section.

---

**Note**

*Use the Show All Instances command to examine the extents of a data variable in all instances of the section in the input file. Refer to Examining How Sections are Populated for more information.*

---

**Make Data Variables Expandable**

Data variables defined in expandable sections can be made to expand as the section expands (Refer to Make an Input Header Section Expandable and Make a Detail Section Expandable for more information). For example, you could define an expandable data variable on the first row of an expandable detail section so that when the section expands to two or more rows, the data variable will contain the extra rows. An expandable data variable will always expand to the bottom of the section.
To define an expandable data variable

1. Create a data variable (Refer to Create Data Variables for more information.) in an unexpanded occurrence of an expandable input section. The Data Variable Properties dialog will be displayed.

2. Type the data variable name in the Name field, and edit other properties as required.

3. Select the Expandable checkbox.

4. Click OK.

Common Input Section Tasks

The following tasks are applicable to all input sections (header, detail and footer).

What do you want to know about?

- Display and Edit Input Section Properties
- Controlling When an Input Section is Generated
- Working with Multiple Input Sections
- Deleting Input Sections

For tasks specific to each section type, refer to:

- Working With the Input File Header Section
- Working with Input Header Sections
- Working with Detail Sections
- Working with Input Footer Sections

Display and Edit Input Section Properties

Input section properties can be displayed so that you can:

- Change the name of the section
- Change the size of the section
- Control where this type of section is applied in the input file
- Control when this type of section is generated
• Define which sections can follow this section
• Control the order in which following sections are tested

When you change the properties of a section, the changes are applied to all occurrences of that section in the file.

To display the Input Section Properties dialog
Do one of the following:
• With the section active, select Input > Section Properties from the Main menu.
• Double-click the selected section.
• Right-click the selected section and select Section Properties from the shortcut menu.
• Double-click the section tab on the Status bar.
Designing for Text Input Files

Figure 5.14: The Input Section Properties dialog

Refer to Add Input Header Sections, Add Detail Sections or Add Input Footer Sections for more information on how to use conditions.

Refer to Expressions and Conditions for more information on how to use the Condition Builder.

Refer to Make an Input Header Section Expandable or Make a Detail Section Expandable for more information on creating expandable sections.

Refer to Controlling When an Input Section is Generated for more information.

Use these controls to add or remove sections from the Followed By list.

Use these controls to change the order in which sections are tested in the Followed By list.

The Followed By list. Refer to Working with Multiple Input Sections for more information on how to use the Followed By list.

Click to display the sections available to be added to the Followed By List.
Controlling When an Input Section is Generated

You can use the Generate Section options in the Input Section Properties dialog to control when an input section is generated in the project. If the section is not generated, the position on the input page where the section would have been displayed is reserved. Changing the Generate Section options will not alter the sequence in which sections are applied to the input page.

To control when an input section is generated

1. In the Input Window, double-click the section. The Input Section Properties dialog will be displayed.
2. Select one of the radio buttons in the Generate Section field:
   - Always — the section will always be generated if valid.
   - Never — the section will never be generated even if valid.
   - If not empty — the section will only be generated if it contains printable characters.

Working with Multiple Input Sections

In cases where input pages begin with different header text, or end with different footer text, or contain different line items, you can define and use additional input sections that accommodate these anomalies. Note that:

- All input header sections are listed in the input headers control list. Refer to Add Input Header Sections for more information.
- All detail sections are listed in the Followed By list on the relevant Input Section Properties dialog.
- All input footer sections are listed in the input footers control list. Refer to Add Detail Sections for more information.

For each page, the logic of which section appears where, is summarized in the following flowchart:
Deleting Input Sections

You can delete the selected input section with the Input>Delete Section command. If the section is not visible on the current page, select the section in the Input Tree. You should exercise great care when deleting an input section, as this can disrupt the logic and continuity of how other sections are applied.

Working With the Input File Header Section

You can create an input file header section to contain non-repeating data at the start of the input file.
To create an input file header section
1. From the Main menu, select Input > File Properties. The Input File Properties dialog will be displayed.
2. Select File starts with document header checkbox.
3. Click OK.

To adjust the input file header section size
1. Select the input file header section.
2. Click-and-drag the resize handle on the bottom of the section to reduce or increase the section size.

You can also double-click the section in the Input Window and set the number of rows from the Input Section Properties dialog.

Working with Input Header Sections

What do you want to do?
- Adjust the Input Header Section Size
- Make an Input Header Section Expandable
- Add Input Header Sections

What do you want to know about?
- Rules for Creating Multiple Input Header Sections

Adjust the Input Header Section Size

Typically when you start a new project, the default size of the input header section will be too big or too small for the header text in the input file. You must adjust the input header section so that it contains all the header text and only the header text.
Note

*Use the Show All Instances command to examine all instances of the section in the input file. Refer to Examining How Sections are Populated for more information.*

To adjust the input header section size

1. Select the input header section.
2. Click-and-drag the resize handle on the bottom of the section to reduce or increase the section size.

Make an Input Header Section Expandable

By default, input header sections have a set size. That is, all instances of that section will have the same size regardless of their content. Where the size of the text in an input header section varies between instances, you can make the section dynamically expand around the relevant text. The section becomes “expandable”.

To make an input header section expandable

1. In the Input Window, double-click the input header section. The Input Section Properties dialog will be displayed.
2. In the Size field, type the minimum size of the section in rows.
3. Select the Expandable checkbox.
4. Click OK. The section size will be reset to the minimum size.

Select the first detail section below the input header section and identify which data variable can be used to test when this detail section is valid. The data variable will be used to build a condition that tests TRUE in the detail section and FALSE in the expanded rows of the input header section.

5. Double-click the first detail section below the input header section. The Input Section Properties dialog will be displayed.
6. Click the button next to the Condition field. Use the Condition Builder to create a valid condition, using the identified variable, for this detail section. Refer to Chapter 11, *Expressions and Conditions*, for more information.
7 Click **OK**. The input header section will now automatically expand in size, testing each row below the section, until the condition in a following detail section tests TRUE.

8 Ensure that all sections that are permitted to follow the header section, contain a suitable condition that will distinguish header rows from detail rows.

The sections that are permitted to follow the input header section are listed in the **This section can be followed by** field on the input header Input Section Properties dialog — also referred to as the Followed By list. The input header section will not expand if any of the sections in the Followed By list do not contain a condition, or the condition always tests TRUE.

---

**Note**

*You can also make data variables expandable in an expandable section. Refer to Make Data Variables Expandable for more information.*

---

**Add Input Header Sections**

In cases where the content of the input header section changes between pages, or an expandable header section cannot be used, you can add additional header sections. Only one input header section can be used on a page.

**To create an additional input header section**

1 From the Main menu, select Input > Input Headers. The Input Headers Control List dialog will be displayed.

2 Click the Add Row button. The New Header Section dialog will be displayed.

3 In the Name field, type the new input header section name.

4 In the Size field, type the number of rows required.

5 Using the controls provided, add one or more detail sections to the This section can be followed by list.

If there are no sections in the Followed By list, or if the sections listed are not valid when tested, no detail sections will be created on the page.

6 Click **OK** to close the New Header Section dialog. Do not close the Input Headers Control List dialog.
The input headers control list will now have two input header sections defined. Both input header sections are unconditional (the Condition field is empty on the Input Section Properties dialog). If the first input header in the list is unconditional, it will always be created. So the first input header must be conditional. If the condition tests TRUE then the first input header is applied, if the test fails then the second input header is applied.

7 Click the button next to the first input header in the control list. The Input Section Properties dialog will be displayed.

8 Click the Edit button next to the Condition field. Use the Condition Builder to create a valid condition for this input header section. If you wish to use a data variable in the condition, you must create the data variable first. Refer to Chapter 11, *Expressions and Conditions*, for more information.

9 Check that the detail sections in the This section can be followed by list are valid and in the correct order.

10 Click **OK** to close the Input Section Properties dialog.

11 Click the button on the second (unconditional) input header to display the Input Section Properties dialog.

12 Check that the detail sections in the This section can be followed by list are valid and in the correct order.

13 Click **OK** to close the Input Section Properties dialog.

14 Click **OK** to close the Input Headers Control List dialog.

The definition of the new input header section will be applied to the entire file.

---

**Note**

*The Condition Builder makes available a number of useful system variables and conditions, for example the condition Sys.FirstPageOfDoc will test TRUE on the first page of the document.*

---

**To delete an input header section**

Care should be taken whenever a input header section is deleted as this will alter not only which input header section is applied, but may also change the way detail sections are applied to the rest of the page. Always review the Followed By lists on the other input header sections, and the order of the input headers control list, before deleting a input header section.

1 From the Main menu, select Input > Input Headers. The Input Headers Control List dialog will be displayed.
2 Select the input header section in the control list.
3 Click the Delete Row button.
4 Confirm that you wish to delete this section.
5 Click **OK**.

The change will be applied to the entire file.

**Rules for Creating Multiple Input Header Sections**

The procedures detailed in **Add Input Header Sections** can be applied when adding further input header sections. The rules applying to multiple input header sections are:

- The last header in the input headers control list should be unconditional.
- All other headers in the list should be conditional.
- The first header that tests TRUE in the list is applied.
- If none of the headers in the control list test TRUE on a page, then no header will be created on that page.
- Input header sections can be expandable (Refer to **Make an Input Header Section Expandable** for more information).

The detail section that follows the input header section, will be the first valid detail section in the Followed By list of the input header section.

**Working with Detail Sections**

**What do you want to do?**

- Add Detail Sections
- Make a Detail Section Expandable

**What do you want to know about?**

- About Defining Detail Sections
- Rules for Creating Multiple Detail Sections
### About Defining Detail Sections

You can create additional detail sections when the content of line items varies within the page. For example, an invoice may contain subtotal lines, blank lines or description lines in addition to the regular line items. Three different detail section types are shown in the following example.

<table>
<thead>
<tr>
<th>type 1</th>
<th>APT103</th>
<th>Bamboo Blinds</th>
<th>1020.00</th>
<th>10</th>
<th>10200.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>type 1</td>
<td>AT1C39</td>
<td>Umbrellas</td>
<td>30.00</td>
<td>80</td>
<td>2400.00</td>
</tr>
<tr>
<td>type 2</td>
<td>*** 9 units shipped, balance with next order</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>type 2</td>
<td>APT103</td>
<td>Black Dragon Vase</td>
<td>199.00</td>
<td>10</td>
<td>1990.00</td>
</tr>
<tr>
<td>type 2</td>
<td>*** hold for collection at Nunawading warehouse</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>type 3</td>
<td>Subtotal</td>
<td>12590.00</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>type 1</th>
<th>APT103</th>
<th>Tea Chests</th>
<th>799.00</th>
<th>4</th>
<th>3196.00</th>
</tr>
</thead>
<tbody>
<tr>
<td>type 1</td>
<td>APT103</td>
<td>Black Dragon Vase</td>
<td>199.00</td>
<td>10</td>
<td>1990.00</td>
</tr>
<tr>
<td>type 2</td>
<td>*** replacement of returned items ***</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>type 2</td>
<td>*** replacement of returned items ***</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>type 1</td>
<td>AT1C78</td>
<td>Cane Baskets</td>
<td>50.00</td>
<td>5</td>
<td>250.00</td>
</tr>
<tr>
<td>type 1</td>
<td>AT1C38</td>
<td>Black Dragon Set</td>
<td>1600.00</td>
<td>1</td>
<td>1600.00</td>
</tr>
<tr>
<td>type 3</td>
<td>Subtotal</td>
<td>7036.00</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Figure 5.16: An example of irregular line items.*

The details of lines are as follows:

- type 1 is the primary line item containing the item details, quantity and price
- type 2 is a descriptive line relating to the previous type 1 line
- type 3 is a subtotal line

In particular note that:

- type 1 lines are not always followed by type 2 lines
- type 2 lines can only follow type 1 lines
- type 2 lines always contain “***” at the start of each line
type 2 can be one or more lines
• type 3 is always two lines
• type 3 lines can follow either type 1 or 2 lines
• type 3 lines can occur at any position
• type 3 lines always contain the text string “Subtotal”

These observations form a set of rules that define the input file structure. The process of building a DataMap involves translating these observations or rules into section properties. You must create a new section for each of the line types you observe in the file.

Note
Use the Show All Instances command to examine all instances of the section in the input file. Refer to Examining How Sections are Populated for more information.

Add Detail Sections

There are many possible ways of creating DataMaps for the same input file. The type of sections defined will depend not only on the content of the input file, but also on how the input data will be used in the project.

To define additional detail sections
1 Identify the first instance where a new section is required.
2 Select the section immediately before (above) where the new section is required.
3 From the Main menu, select Input > New Section After. The New Data Section dialog will be displayed.
4 In the Name field, type the new section name.
5 In the Size field, type the size of the section in rows.
6 Click OK. The new section will be displayed in the Input Window.
7 Select the new section.
8 Create the data variables required to define the data in the new section (Refer to Create Data Variables in a Detail Section for more information).
9 Create any additional data variables that are required to assist in distinguishing this section from all other detail sections. You only need to create additional data variables if the data variables created in the previous step are not suitable. For example, you might test when a particular character position is blank, or when a character string contains a particular substring, or a combination of tests using boolean operators. Refer to Boolean Operators for more information.

10 From the Main menu, select Input > Section Properties. The Input Section Properties dialog will be displayed.

11 Click the Edit button to display the Condition Builder dialog and create a condition that tests TRUE when this section is valid. Refer to Chapter 11, Expressions and Conditions for more information.

12 Define the sections that can follow this section in the This section can be followed by field by adding, removing and ordering sections with the controls provided. The order in which the sections appear in this list is very important: the first valid section in this list will be the next section created after this section. Refer to Display and Edit Input Section Properties for more information.

13 Click OK.

The definition of the new section will be applied to the entire file and displayed in the Input Window.

Note

It is good design practice to create a positive condition for every detail section you create, even if the condition is not immediately required to identify the section.

Make a Detail Section Expandable

In cases where the number of rows in a detail section is variable e.g., repeated comment lines, you can make the detail section expandable.

To make a detail section expandable

1 In the Input Window, double-click the detail section. The Input Section Properties dialog will be displayed.

2 In the Size field, type the minimum size of the section in rows.
3 Select the Expandable checkbox.

4 Click OK.

The section will now automatically expand in size, testing each row below the section, until a condition in the following detail section tests TRUE. Ensure that all sections that are permitted to follow the section contain a suitable condition.

Note

You can also make data variables expandable in an expandable section. Refer to Make Data Variables Expandable for more information.

Rules for Creating Multiple Detail Sections

The procedures outlined in Add Detail Sections can be applied when adding further detail sections. The rules applying to multiple detail sections are:

- The detail section that follows the input header section, will be the first valid detail section in the Followed By list of the input header section.
- The first valid detail section in the previous detail section Followed By list is applied next.
- An unconditional detail section will always be applied if tested in the previous detail section Followed By list.
- If there are no valid sections in the last Followed By list, no further detail sections will be applied to that page.
- Detail sections can be expandable (Refer to Make a Detail Section Expandable for more information).

Working with Input Footer Sections

What do you want to do?

- Adjust the Input Footer Section Size
- Add Input Footer Sections
What do you want to know about?

- Rules for Creating Multiple Input Footer Sections

**Adjust the Input Footer Section Size**

As with the input header section, you must adjust the size of the input footer section so that it contains all footer text and no text that belongs in a detail section.

---

**Note**

*Use the Show All Instances command to examine all instances of the section in the input file. Refer to Examining How Sections are Populated for more information.*

---

**To adjust the input footer section size**

1. Select the input footer tab on the Status Bar to select and display the input footer section.

2. Click-and-drag the resize handle on the top border of the input footer section to make the section bigger or smaller.

**Add Input Footer Sections**

In cases where the content of the input footer section changes between pages, you can add and use additional input footer sections. The additional input footer sections will be added to the input footers control list. Only one can be used on each page.
To define additional input footer sections

1. From the Main menu, select Input > Input Footers. The Input Footers Control List dialog will be displayed.

2. Click the Add Row button to display the New Footer Section dialog.

3. In the Name field, type the footer section name.

4. In the Size field, type the number or rows required for the new input footer section.

5. Click OK to close the New Footer Section dialog. Do not close the Input Footers Control List dialog.

The input footers control list now has two input footer sections defined. Both input footer sections are currently unconditional (the Condition field is empty). If the first in the list is unconditional, it will always be created. So the first footer must be conditional. If the condition tests TRUE then the first input footer is applied, if the test fails then the second input footer is applied.

6. Click the Edit button for the first input footer to display the Input Section Properties dialog.

7. In the Condition section, click to display the Condition Builder dialog and create a condition that tests TRUE when this section is valid. Refer to Chapter 11, Expressions and Conditions, for more information.

8. Click OK to close the Input Section Properties dialog.

9. Click OK to close the Input Footers Control List dialog.

The definition of the new input footer section will be applied to the entire file.
Note

The Condition Builder makes available a number of useful system variables and conditions, for example the condition Sys.LastPageOfSet will test TRUE on the last page of each set.

Rules for Creating Multiple Input Footer Sections

The procedures detailed in Add Input Footer Sections can be applied when adding further input footer sections. The rules applying to multiple input footer sections are:

- The first input footer that tests TRUE in the control list is applied
- If none of the input footers in the control list test TRUE on a page, then no input footer will be created on that page
Designing for XML Input Files

The input design process for XML files involves identifying the different elements of the XML input file; this information is recorded in the DataMap. A DataMap for an XML input file is denoted by the .xmp6 file name extension.

What would you like to know about?

- XML File Structure
- Input File Properties
- Defining Sets
- Defining Sections
- Working with Data Variables

To create the XML sample project

1. To start the wizard, click the New Project button on the Main toolbar.
2. From the Type drop-down, select XML from the available file types.
3. Click to display the Select Input File dialog and select the file Chapter5Sample.xml from the <install dir>\CF6Samples\Tutorials folder.
4. Click Next.
5. Select the Create a new DataMap radio button and click Next. A new DataMap will be created.
6. Ensure the Set headers and footers checkbox and the Table with headers and footers checkbox are cleared and click Next.
7. Click Finish. The new sample project will be displayed in the Input Window.
XML File Structure

To be properly interpreted, the XML file should be “well-formed” and adhere to the published standards. An example of a well-formed XML file is shown below:

Table 5.1:

<table>
<thead>
<tr>
<th>XML Element Type</th>
<th>Line</th>
<th>XML Source</th>
</tr>
</thead>
<tbody>
<tr>
<td>XML declaration</td>
<td>1</td>
<td>&lt;?xml version=&quot;1.0&quot; encoding=&quot;ISO8859-1&quot; ?&gt;</td>
</tr>
<tr>
<td>Comment</td>
<td>2</td>
<td>&lt;!-- Member Updates--&gt;</td>
</tr>
<tr>
<td>root tag with attributes</td>
<td>3</td>
<td>&lt;update total=&quot;2&quot;&gt;</td>
</tr>
<tr>
<td>child element start tag with attribute</td>
<td>4</td>
<td>&lt;member count=&quot;1&quot;&gt;</td>
</tr>
<tr>
<td>subchild element tag</td>
<td>5</td>
<td>&lt;ID&gt;1984&lt;/ID&gt;</td>
</tr>
<tr>
<td>subchild element start tag</td>
<td>6</td>
<td>&lt;changes&gt;</td>
</tr>
<tr>
<td>nested subchild element tag</td>
<td>7</td>
<td>&lt;street&gt;1667 Elm Street&lt;/street&gt;</td>
</tr>
<tr>
<td>nested subchild element tag</td>
<td>8</td>
<td>&lt;email&gt;<a href="mailto:fred.krueger@craven.com">fred.krueger@craven.com</a>&lt;/email&gt;</td>
</tr>
<tr>
<td>subchild element end tag</td>
<td>9</td>
<td>&lt;/changes&gt;</td>
</tr>
<tr>
<td>child element end tag</td>
<td>10</td>
<td>&lt;/member&gt;</td>
</tr>
<tr>
<td>child element start tag with attribute</td>
<td>11</td>
<td>&lt;member count=&quot;2&quot;&gt;</td>
</tr>
<tr>
<td>subchild element tag</td>
<td>12</td>
<td>&lt;ID&gt;1886&lt;/ID&gt;</td>
</tr>
<tr>
<td>subchild element start tag</td>
<td>13</td>
<td>&lt;changes&gt;</td>
</tr>
<tr>
<td>nested subchild element tag</td>
<td>14</td>
<td>&lt;title&gt;Mr&lt;/title&gt;</td>
</tr>
<tr>
<td>nested subchild element tag</td>
<td>15</td>
<td>&lt;first&gt;Edward&lt;/first&gt;</td>
</tr>
<tr>
<td>nested subchild element tag</td>
<td>16</td>
<td>&lt;last&gt;Hyde&lt;/last&gt;</td>
</tr>
<tr>
<td>subchild element end tag</td>
<td>17</td>
<td>&lt;email&gt;<a href="mailto:henry.jekyll@stevenson.com">henry.jekyll@stevenson.com</a>&lt;/email&gt;</td>
</tr>
<tr>
<td>subchild element end tag</td>
<td>18</td>
<td>&lt;/changes&gt;</td>
</tr>
<tr>
<td>child element end tag</td>
<td>19</td>
<td>&lt;/member&gt;</td>
</tr>
<tr>
<td>end root tag</td>
<td>20</td>
<td>&lt;/update&gt;</td>
</tr>
</tbody>
</table>

The elements and structure of the XML file are interpreted according to an underlying set of rules that determine how the XML elements will be applied in the output project. These initial settings can be changed with the following commands:

Table 5.2:

<table>
<thead>
<tr>
<th>To do this</th>
<th>Select</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change formats of date and numeric data</td>
<td>Input &gt; File Properties (refer to Input File Properties for more information)</td>
</tr>
<tr>
<td>Ignore selected XML tags in source file</td>
<td>Input &gt; File Properties (refer to Input File Properties for more information)</td>
</tr>
</tbody>
</table>
Table 5.2:

<table>
<thead>
<tr>
<th>To do this</th>
<th>Select</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change how sets are created</td>
<td>Set &gt; Define (refer to Defining Sets for more information)</td>
</tr>
<tr>
<td>Change how sections are created</td>
<td>Input &gt; Tag Properties (refer to Defining Sections for more information)</td>
</tr>
<tr>
<td>Rename a section</td>
<td>Input &gt; Tag Properties (refer to Defining Sections for more information)</td>
</tr>
</tbody>
</table>

**Input File Properties**

The input file properties determine the input format for dates and numbers, and which tags will be ignored when the input file is processed.

**To change the input file properties**

1. Select the Input Window by clicking anywhere inside the input window frame.

2. From the Main menu, select Input > File Properties. The Input File Properties dialog will be displayed.

---

![Figure 5.17: XML Input File Properties dialog](image)
3 In the Data format section, select the format used for date and decimal values in the input file.

4 In the Ignored Tags section, use the toolbar buttons to add the tags you want to ignore or remove the tags you want to include.

5 Click **OK**.

The changes will be applied to the input file and the input window will be refreshed.

**Defining Sets**

You can select one tag to indicate where a new set will be created:

To define sets
1 From the Main menu, select Set > Define. The Define Set dialog will be displayed.
2 Select the tag that defines the start of a new set.
3 Click **OK**.

**Defining Sections**

You can select one or more tags to indicate where a new data section will be created:

To define sections
1 In the Input Window, select a tag that defines the start of a new section.
2 From the Main menu, select Input > Tag Properties. The Tag Properties dialog will be displayed.
3 Type the name of the section.
4 Click **OK**.

Follow the same procedure to unselect section tags.
To rename a section

1. In the Input Window, select the tag that defines the start of the section.
2. From the Main menu, select Input > Tag Properties. The Tag Properties dialog will be displayed.
3. Type the new name in the Name field.
4. Click OK.

Working with Data Variables

Data variables are created automatically from the tag attributes and data elements in the input file. The data variables created are shown in the Input Tree view:
110 * INPUT DESIGN

- Designing for XML Input Files

What would you like to know about?

- Changing the Properties of Data Variables
- Changing the Input Data Format
- Copying Data Variables to the Project

Figure 5.18: Data variables created from the sample XML input file
Changing the Properties of Data Variables

To change the properties of data variables

1. In the Input Window, double-click the data variable. The Data Variable Properties dialog will be displayed.

2. With the Data Variable Properties dialog you can:
   - Change the name of the data variable by typing a new name in the Variable Name field.
   - Select the data type from the Data Type drop-down. Refer to Changing the Input Data Format for more information on how Create!form Transform recognizes date and numeric formats.

3. Click OK.

![Data Variable Properties dialog](image)

Figure 5.19: Data Variable Properties dialog

Changing the Input Data Format

Create!form Designer interprets dates and numeric data in the input file using the data formats defined by the input file properties. For example, you can change the decimal separator to a comma, or the date order from year-month-day to month-day-year.

To change the input data format

1. From the Main menu, select Input > File Properties. The Input File Properties dialog will be displayed.

2. From the Date order drop-down, select the required date format.
3  From the Decimal symbol drop-down, select the required numeric format.
4  Click OK.

**Copying Data Variables to the Project**

Data variables can be displayed in the project by dragging the data variable from either the Input Window, or the Input Tree, into the Design Window.

**To copy a data variable to the project**
1  In the Input Window, select the data variable.
2  Drag-and-drop the selected variable from the Input Window across into the Design Window.

![Figure 5.20: Dragging a data variable into the Design Window](image)

Refer to **Creating Objects** for more information on adding text variables and other objects to the project.
Designing for JDE PDF Input Files

The J.D. Edwards PDF format is a self-defining proprietary PDF format generated by PeopleSoft EnterpriseOne. The contents of the PDF file are pre-mapped, which Create!form Designer automatically translates into sections and data variables.

The input design process for JDE PDF files involves defining how sets are created and mapping data variables to the output; this information is recorded in the DataMap. A DataMap for an JDE PDF input file is denoted by the .jmp6 file name extension.

To view the input file elements mapped by the DataMap

- Click the Input Tree on the Main toolbar or select View > Input Tree from the Main menu.

What would you like to know about?

- Input File Properties
- Defining Sets
- Input Sections
- Data Variables

Input File Properties

Non-breakable input sections and the date order format are defined by the input file properties.

To add and remove non-breakable input sections

1. Select the Input Window by clicking anywhere inside the input window frame.
2. From the Main menu, select Input > File Properties.
3. To add a section to the Non-breakable sections, click the Add Row button, click the drop-down button on the new row, and select the section from the list.
4. To remove a section, select the section in the Non-breakable sections list, and click the Delete Row button.

5. Click OK.

To change the input file date format
1. Select the Input Window by clicking anywhere inside the input window frame.
2. From the Main menu, select Input > File Properties.
3. Select the required format from the Date order field.
4. Click OK.

Defining Sets
Defining sets involves specifying when a new set will commence. Typically a new set commences every time the page numbering restarts, but you can also specify that a new set commences when data such as the customer number or invoice number changes.

- You can use the following means to determine when a new set starts:
  - when the value of a page number variable is equal to 1
  - when the value of a variable changes
  - one set per page
  - no sets

To define sets
1. From the Main menu, select Set > Define. The Define Set dialog will be displayed.
2. Select one of the radio button options to determine when a new set starts:
   - This project does not contain sets
   - New set occurs when:
     From the Section drop-down, select the name of the section containing the variable you want to use to define sets, then an option and the required variable from the Condition field:
Page number variable ... equals 1
Value of variable ... changes

• New set starts on every page.

3 Click OK.

Input Sections

Input sections are created automatically from the pre-mapped contents of the input file. The sections defined in the input file are shown in the Input Tree view. The properties of input sections in a JDE PDF input file cannot be changed.

Data Variables

Data variables are created automatically from the pre-mapped contents of the input file. The data variables are shown in the Input Tree view. The properties of data variables in a JDE PDF input file cannot be changed.

To copy a data variable to the project

1 In the Input Window, select the data variable.

2 Drag-and-drop the selected variable from the Input Window across into the Design Window.

Refer to Creating Objects for more information.
Creating Derived Variables

Derived variables are expressions that are used to combine and manipulate the values of data variables. To create a derived variable, select Input>Derived Variables from the Main menu to display the Derived Variables dialog. Refer to Expressions for more information.

Examples:

<table>
<thead>
<tr>
<th>Derived Variables</th>
<th>Expression</th>
</tr>
</thead>
<tbody>
<tr>
<td>TotalPrice</td>
<td>(UnitPrice+SalesTax)*Qty</td>
</tr>
<tr>
<td>LastChar</td>
<td>substring(ProdDesc,length(ProdDesc),1)</td>
</tr>
<tr>
<td>AddressLine1</td>
<td>Title+FirstName+LastName</td>
</tr>
<tr>
<td>DaysInMonth</td>
<td>Day(date(year(Sys.Today),month(Sys.Today)+1,1)-1)</td>
</tr>
</tbody>
</table>

Refer to Creating Objects for more information on how to use Derived Variables.
PROJECT SETTINGS

Before you start designing your project, you should review and edit the project properties, the project page style and the project background; otherwise, you may have to redesign your project if these settings are changed later.

- Project Properties
- Project Page Style
- Project Background
Project Properties

Project properties include various print options and default styles which apply to the whole project.

What do you want to know about?

- Collate Options
- Duplicates
- About Format Styles

To edit project properties

1. From the Main menu, select Project > Properties. The Project Properties dialog will be displayed.
2. Define the Collate Options.
3. Define the Duplicates options.
4. Create format styles. Refer to About Format Styles for more information.
5. In the Pages per sheet field, select the number of pages you want to be printed on each sheet. Refer to Project Page Style for more information about setting the page size and orientation.
6. Click OK to save the project properties.

Collate Options

There are three ways to order the output of pages:

- uncollate
- collate
- (collate) By Set

The dynamic image on the Project Properties dialog gives a graphical representation of the selected collate option.
Duplicates

By specifying a value greater than one in the Number of Duplicates field, you can set the project to process the input file multiple times. By using this option, you can generate multiple copies at the printer, rather than sending all copies from the server.

---

Note

You can also specify that the spool file is process multiple times using Create!stream. For more information see the Create!stream User Guide and the Create!form Server User Guide. The collate options apply to multiple copies, regardless of how the number of copies is specified.

---

About Format Styles

You can create format styles that customize the way numbers, dates and currencies are displayed. Format styles allow you to specify such things as:

- Whether a period (.) or comma (,) is used as a decimal symbol
- The currency symbol
- Whether the date will be displayed as day-month-year or month-day-year

Format styles are global; once you have created a style you can apply it in any project.

When you install Create!form Transform, some format styles are automatically created (including the appropriate one for the regional settings of your computer). You can customize these format styles or create new ones.

What do you want to do?

- To create a format style
- To Customize a format style
- Set the Default Format Style for New Objects
To create a format style
1 In the Project Properties dialog, select Manage Format from the Default format style drop-down. The Manage Format Styles dialog will be displayed.
2 Click Create. The Create Format Style dialog will be displayed.
3 Type a name for the style.
4 Choose whether to base the initial style settings on:
   • A Windows locale, and choose a locale or
   • A previously defined format style. The locale selected will determine the regional sort. Refer to Sorting Modes for more information.
5 Click OK. The <name of format style> dialog will be displayed.
6 Make all required settings for numbers, currency and dates and click OK. The Manage Format Styles dialog will be displayed.
7 When you have finished managing your styles, click Close to return to the Project Properties dialog.
8 Click OK to return to the project.
You can also manage format styles with the Tools > Format Styles command.

To Customize a format style
1 In the Project Properties dialog, select Manage Formats from the Default format style drop-down.
2 Select the format style you want to customize and click Edit.
3 Make the necessary changes and return to the project. All objects using the edited format style will be updated.

Set the Default Format Style for New Objects
When you set the default, it will be the default for all objects created in that project. When you change the default, all objects using the (Project Default) format style will be updated.

To set the default format style
1 In the Project Properties dialog, select the format you want as the default for all new objects in the Default format style field.
2 Click **OK**.

Refer to **Text Properties** for information on applying different format styles to particular objects.
Project Page Style

The Page Setup dialog provides the page settings for the following options:

- Page size
- Page control

These settings will apply to all pages in the project.

To set the page style

1. From the Main menu, select File > Page Setup. The Page Setup dialog will be displayed.
2. In the Page size field, type the Width and Height in columns and rows.
3. In the Page control field, select one of the following options:
   - Form feeds - a form feed character will be used
   - Fixed height - blank lines will be inserted to give a fixed page height
   - None - the output file will not be paginated

Note

*Changing the page size may cause objects to be repositioned. You must manually reposition objects that are affected.*
Project Background

The page view consists of two superimposed layers:

- Background layer: contains fixed content.
- Design layer: contains all variable content i.e., variable text and variable subform objects.

The background layer will appear on every page, and is overprinted by the design layer.

To add text to the background

Click the Project Background tab and edit the page. Refer to Chapter Nine, Objects, for more information on inserting objects.

Note

When you double-click the Project Background tab, the Page Setup dialog will be displayed with which you can alter the page size and other properties.
PROJECT SETTINGS

- Project Background

-
SECTIONS

Sections are defined both in the input and the output. The following topics explain how to create different types of sections in the output.

The following topics are covered:

• About Sections
• Data Sections
• Header and Footer Sections
• Alternate Sections
• Inserted Sections
• Setting Section Properties
About Sections

Each type of section displays a particular type of information or occupies a particular space on the page. Sections typically have many occurrences, and where you make layout or format changes to once occurrence, the changes are automatically made to all other occurrences.

In Chapter Five, Input Design, you were introduced to the types of input sections:

- Detail sections, which typically contain information such as line item data
- Input header and input footer sections, which typically bracket detail sections

These sections are used to define the input data.

In the project (viewed in the Design Window), you can use the following types of sections to manipulate the display of data:

- Data Sections
- Header and Footer Sections
- Alternate Sections
- Inserted Sections
Data Sections

When you create a project, all sections in the input file are automatically copied across to the project. This type of section is called a data section and each data section has the same name as the corresponding section in the input file.

You cannot delete a data section but you can hide it so it does not apply. This is done from the Section Properties dialog.

What do you want to know about?

• Data Section Display Options
• Setting Section Properties

Data Section Display Options

You can specify a data section to display:

• Always
• Never
• On Condition

By default, data sections are set to always display.

To set the display properties of a data section

1 From the Main menu, select Section > Properties. The Section Properties dialog will be displayed.

2 Click the Display tab.

3 Select one of the radio button options:
   • Always (to display the section unconditionally)
   • Never (to hide the section unconditionally)
   • On Condition and create the condition (to display the section unconditionally) (Refer to Chapter 11, Expressions and Conditions, for more information)
To prevent data from the section being used in calculations when the section is hidden, select the ignore data from this section when hidden checkbox.

**Viewing the Properties of Sections that are not Displayed**

If a section is set to never display, or conditionally, and the conditions are never met, the section properties can only be displayed by double-clicking on the section in the **Project Tree**.
Header and Footer Sections

Creating header and footer sections provides the basic page layout structure and makes designing your project easier.

You can create header and footer sections around the following units:

- The project
- A set
- A page
- a table

Once created, you can format header and footer sections like any other section.

What do you want to know about?

- Continuation Header and Footer Sections
- The Display Order of Header and Footer Sections

What do you want to do?

- Create Set Headers and Footers with the Wizard
- Create and Remove Header and Footer Sections
- Create Header and Footer Sections From an Input Section

Create Set Headers and Footers with the Wizard

When a Standard Project is created, you are given the option of creating set headers and footers. When this option is selected, the first occurrence of the input header section on the first page of the set will be used as the source for the set header. Similarly, the last occurrence of the input footer section in the set will be used as the source for the set footer.
Continuation Header and Footer Sections

As well as header and footer sections, you can also create continuation header and continuation footer sections. Continuation headers and footers appear wherever there is a page break within that header/footer unit. For example a set continuation header appears on every continuation page of a set. Continuation header and footer sections can have the same content and design as the header/footer section, or be totally different.

Refer to Create and Remove Header and Footer Sections for more information.

Create and Remove Header and Footer Sections

This procedure deals with headers and footers for the project, sets and pages.

To create header and footer sections for the project, sets or pages

1. From the Main menu, select the appropriate menu option:
   - Project > Headers and Footers
   - Set > Headers and Footers
   - Page > Headers and Footers

2. From the relevant dialog, select the appropriate checkbox to create:
   - A header
   - A continuation header, and it so whether the continuation header will be the same as the header of different
   - A footer
   - A continuation footer, and if so whether the continuation footer will be the same as the footer or different
   - For set headers and footer, you have the option of creating an Additional first page footer. This is useful for things like a payment advice where you may want to print a check on the bottom of the first page

3. To copy all text objects from another data section, click Create from. Refer to Create Header and Footer Sections From an Input Section for more information.
4 Click OK to close the Header/Footer dialog. The sections you have selected will be created and displayed in the Design Window and the Project Tree. You can now format the newly created sections.

**To turn a header or footer section off**

Header and footer sections can be turned off (deleted) or turned on (created) at any time. This is done from the relevant headers and footers dialog.

---

**Create Header and Footer Sections From an Input Section**

The Create From function lets you copy the contents and size of another section into header and footer sections in the project. When you use this function, the following occurs:

- All text objects from the specified section and its corresponding original section in the input file are cut and pasted to the new header/footer section. (If objects appear in the specified section and its original section in the input file, Create!form Designer uses the instance from the specified section.)
- The section you copied the variables and properties from is set to never display.

**To use the Create From function**

1 From the relevant Header/Footer dialog or Table dialog, click Create From. The Create From dialog will be displayed.

2 In the Source field, select the data section from which you want to copy the contents and dimensions.

3 In the Occurrence field, specify the occurrence of the data section you want to map from. For headers, this will usually be the first occurrence, and for footers, the last occurrence.

4 Click **OK** to return to the originating dialog.
The Display Order of Header and Footer Sections

It is possible to have multiple header and footer sections on the same page. Their display order is governed by rules. To understand these rules, consider the following hypothetical project that contains:

- Two pages
- One set
- A table that runs over both pages
- A project, set, page, and table header/footer sections

The header/footer rules would dictate the following display order:

<table>
<thead>
<tr>
<th>Table 7.1:</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Page 1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>project header</td>
<td>project continuation header</td>
<td></td>
</tr>
<tr>
<td>set header</td>
<td>set continuation header</td>
<td></td>
</tr>
<tr>
<td>page header</td>
<td>page header</td>
<td></td>
</tr>
<tr>
<td>table header</td>
<td>table continuation header</td>
<td></td>
</tr>
<tr>
<td>data section</td>
<td>data section</td>
<td></td>
</tr>
<tr>
<td>table continuation footer</td>
<td>table footer</td>
<td></td>
</tr>
<tr>
<td>page footer</td>
<td>page footer</td>
<td></td>
</tr>
<tr>
<td>set continuation footer</td>
<td>set footer</td>
<td></td>
</tr>
<tr>
<td>project continuation footer</td>
<td>project footer</td>
<td></td>
</tr>
</tbody>
</table>
Alternate Sections

Where you have a data section that has a different layout and content in different occurrences, you can create alternate sections to cater for those different occurrences. When certain user-defined conditions are met, the alternate sections will replace the original data section. All alternate sections share the same source and variables as the sections they are alternates for.

There are many possible and equally valid ways of varying content and format of a section based on its content. Here are some other methods that you may find useful:

- Create multiple detail sections in the input design (Refer to Working with Detail Sections for more information.)
- Conditionally display text and drawing objects (Refer to General Properties for more information.)
- Use variable subforms (Refer to Use a Variable to Display Different Subforms for more information.)

To create an alternate section

1. Select the data section you want to create an alternate for.
2. From the Main menu, select Section > Alternates. The Alternates <section> dialog will be displayed.
3. To create the condition (Refer to Conditions for more information.) for displaying the alternate, click the Condition button. You can edit this condition at any time. Click OK to return to the Alternates <section> dialog.
4. The Alternate Section Name field contains the default name for the new alternate section. You can type another name in here if you want, but be sure to use one that will clearly associate it with the original data section.
5. If necessary, click the Add Row button to create another condition and another alternate section.
6. If, necessary use the arrow buttons to change the order that Create!form Designer evaluates the conditions.
7. Click OK. Where the conditions are met, the alternate sections will replace the data section.
8 Add data variables (Refer to Adding Text to the Page for more information) and format the alternate section.

**To delete an alternate section**

1 From the Alternates <section> dialog, select the row that refers to the alternate section you want to delete.

2 Click Delete.

3 Click OK. The alternate section will be removed from the project.
Inserted Sections

You can insert one or more sections before and after a detail section. Inserted sections have the following properties:

- Always keeps with the parent detail section
- User variables are defined independently from the parent section
- The primary source is the parent section
- No alternates are permitted

Inserted sections will otherwise act like a normal detail section, and can be edited in the same way.

To insert a section before or after another section

1. In the Design Window, select the section you want to insert the new section before or after.
2. From the Main menu, select Section > Inserted Sections. The Insert Sections dialog will be displayed.
3. Use the tools provided to add, remove and rearrange inserted sections in the Inserted before <section> and Inserted after <section> list boxes.
4. Click OK.

The Design Window will refresh with the new inserted section(s) displayed.
Setting Section Properties

What do you want to know about?

- Section Positioning Options
- Adjusting Section Size
- Fixed and Auto-Expanding Sections
- About Parent/Child Relationships
- Keeping Sections Together
- Setting Repagination Control
- About Sources
- Adding Sources

To display the Section Properties dialog

- In the Design Window in Graphics view, double-click in the active section where there are no objects
- Double-click on the section tab at the bottom of the Design Window
- In the Project Tree, right-click on the section name and select Properties

Section Positioning Options

Depending on the type of section, you may be able to:

- Fix the section in a location on the page
- Float the section immediately after the previous section, regardless of where the previous section is.
- Sink the section so that it, along with any sections that follow it, are forced to the bottom of the page.

None of these options will change the order of the sections, only their positioning.
The following rules apply to the different section types

- Data sections, alternate sections and inserted sections can either float or be fixed.
- Table header sections can either float or be fixed. Other header sections can only float.
- All footer sections can either sink or float.

To specify section positioning, click the appropriate button on the General tab of the Section Properties dialog.

**To position a fixed section**

- In the Design Window, select the section and use the top handle of the section to move it up or down the page.

**Adjusting Section Size**

**To adjust the size of a section do one of the following**

- In the Design Window, drag the bottom handle of the selected section
- Specify the size of the General tab of the Section Properties dialog

**Fixed and Auto-Expanding Sections**

By default, every occurrence of each section type will be the same size. Alternatively, you can set the following sections to auto-expand:

- Data
- Alternate
- Project Headers
- Set Headers
- Table Headers
- Page Headers

When you set a section to auto-expand, you specify that a minimum distance between the bottom of the lowest text object and the bottom of the section will
be maintained, regardless of the size of variable objects in the section. If the number of lines in a variable text object increases or decreases, the size of the section will change accordingly.

**To auto-expand a section**

1. On the General tab of the Section Properties dialog, select Auto-expand checkbox.

2. In the Gap between lowest object and section bottom field, type the minimum distance between the lowest text object and the bottom of the section.

3. In the Size field, specify a minimum overall section size.

4. Click **Ok**.
About Parent/Child Relationships

You can define sections as having a parent/child relationship with other sections. A parent section can have multiple sections. There are several reasons for doing this:

- When you create parent/child relationships, it enables the "keep with" function, so that you can keep sections together, where they might otherwise be forced onto another page.

- To enable the creation of a table involving more than one section type. When the parent is used to define a table, the child section is automatically included in the table. This is the only way a sub-detail section can be included with its parent-detail section in a table.

- From the parent section, you can use section specific variables from the first occurrence of each associated child section that follows the parent.

Parent/Child Relationship Requirements

- The parent/child relationship will only be preserved if the child follows immediately after the parent or another child of the parent.

- All child sections must be set to float.

Alternate Sections and Parent/Child Relationships

Alternate sections inherit the parent/child relationships of the section they are alternates for. However, the Keep With setting of a parent/child relationship is not inherited.

Keeping Sections Together

Sections can be associated by a parent/child relationship so they keep together. Refer to About Parent/Child Relationships for more information.
Auto-Expanding Sections and the Keep With Option

When you set the auto-expanding section to break over the end of a page, the Keep With setting will be ignored.

To define a parent/child relationship

1. Open the Section Properties dialog of the section that will be the parent.
2. Click the Repagination tab.
3. For each section you want to be a child
   - Select the checkbox in the Child Section column
   - Type an alias or leave blank. The alias is used within expressions and conditions to resolve problems with duplicates names in child or source sections.
4. Select the Keep With checkbox for any children you want to keep with the parent.
5. Click OK.

Setting Repagination Control

To start a new page when a specific section occurs

1. Double-click the section tab to display the Section Properties dialog.
2. Select the Repagination tab.
3. Select the Start new page checkbox.
4. Click OK.

To control repagination of auto-expanding sections

If the section size is auto-expanded, you can specify various pagination controls for the section (Refer to Fixed and Auto-Expanding Sections for more information).

1. Double-click the section tab to display the Section Properties dialog.
2. Select the Repagination tab.
3. To allow the section to break over the page, select the Break auto-expanding section and overflow to next page checkbox.

4. To specify the minimum number of lines kept together at the start of a broken text object, select the Orphan control checkbox and type the value in the Minimum lines field.

5. To keep the paragraphs together without splitting, select the Don’t split paragraphs checkbox.

6. Click Ok.

**About Sources**

All data variables, user variables and derived variables used within a section are derived from the section source(s). The section source(s) are other sections. To view a section source(s), open the Source tab of the Section Properties dialog.

The primary source of each section, is the section itself. If you change the name of the section, the change is reflected in the primary source also, but the content remains the same and is a reflection on what type of section it is. The following table explains the content of the primary source for each section type.

<table>
<thead>
<tr>
<th>Section type</th>
<th>Content of primary source</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td>The corresponding detail section in the input file.</td>
</tr>
<tr>
<td>Alternate</td>
<td>The same primary source as the section it is an alternate for. (The alternate section also inherits any secondary source that exist in the original section.)</td>
</tr>
<tr>
<td>Inserted</td>
<td>The same primary source as the section it is inserted from. (The inserted section also inherits any secondary sources that exist in the original section.)</td>
</tr>
<tr>
<td>Header/footer</td>
<td>The primary source of a header or footer section is the section itself. You can add source(s) when you are creating the header/footer section using the &quot;create from&quot; function, or from the Source tab.</td>
</tr>
</tbody>
</table>
Adding Sources

At any time you can add data sections from within the project as additional sources. Each additional source can have an alias name used to qualify any data variable used in conditions or expressions in that section. The alias is used within expressions and conditions to resolve problems with duplicate names in child or source sections.

When defining an additional source you must also specify the occurrence. For example, the first occurrence means the source is the first occurrence of that section in the set.

Typically when a section has been defined as a source for another section, to prevent duplication, the source section should be set not to display.

To add a section as a source

1. Open the Section Properties dialog (Refer to Setting Section Properties for more information).
2. Select the Source tab.
3. Click Add Source. A new row will be added.
4. From the section drop-down, select the section you want to add as source.
5. Type an alias or leave blank. The alias is used within expressions and conditions to resolve problems with duplicate names in child or source sections.
6. In the Occurrence column, select which occurrence of the selected option within the set that you want as source.
7. Click OK.
Tables allow you to group repeated data sections so they can be labelled, outlined, sorted and summarized.

The following topics are covered in this chapter

- About Tables
- Working with Tables
- Table Properties
About Tables

You can create a table around related repeated sections. Tables provide a robust structure for designing projects. They allow you to:

- Sort data into different groups
- Create header and footer sections for the different groups of data within the table
- Draw table objects such as lines and boxes, that dynamically fit around the table
- Calculate sub-totals and totals for the different groups of data you have created (Refer to Summarizing Data in Headers and Footers for more information.)

Tables are the best way of handling repeated sections. For example in an invoice project, it is recommended that you define a table for the data sections.

What do you want to know about?

- Working with Tables
- Table Properties
Working with Tables

What do you want to do?

- Create Tables with the Wizard
- Create a Table
- Change Table Properties
- Delete a Table

Create Tables with the Wizard

When a Standard Project is created, you are given the option of creating tables. When this option is selected, a table is created for the data sections in each set. The project initially only has one data section defined. The table header and footer positions will change as the set definition is changed.

Create a Table

To create a table

1. Select the section you want to create the table for. If the table will include multiple sections, this will be the parent.

2. From the Main menu, select Table > New. The New Table <section> dialog will be displayed.

3. In the Table name field, type the table name. The table name will for the basis for:
   - Any table header or footer section names. For example, where the table is called Invoice Data, the header and footer sections will be called InvoiceData Header, InvoiceData Footer.
   - The table levels that follow. For example, where the table is called InvoiceData, the levels will be called InvoiceDataL1, InvoiceData L2, etc.
4 To sort the contents of the table or level, click in the grid or click the Add Row button. A new level will be created. Refer to Table Levels for more information.

In the new row specify:
- The data variable you want to sort or group by
- The sort order. If the order is already correct, select None
- The sort mode. Refer to Sorting Modes for more information.

5 Create headers and footers for the table or a level. Refer to Header and Footer Sections for more information.

6 Select the required Grouping Options.

7 Specify pagination controls for each table level. Refer to Setting Table Pagination Controls for more information.

8 To add further levels repeat steps 4 to 7.

9 When you have finished adding levels and setting table properties, click OK. In the Design Window, new tabs will be created for new:
- Header section
- Footer section
- Continuation header section if it is not set to be Same as first header
- Continuation footer section if it is not set to be Same as last footer

**Change Table Properties**

**To change the properties of a table**

1 Click inside any table section.

2 From the Main menu, select Table > Properties. The Table Properties <section> dialog will be displayed.

3 In the Table Name field, type the table name. You can change the name of the table at any time.

4 To change how the table is sorted, click an existing table level or, to add a new level, click the Add Row button. Refer to Table Levels for more information.
In the level row, specify:

- The data variable you want to sort or group by
- The sort order. If the order is already correct, select None.
- The sort mode. Refer to Sorting Modes for more information.

5 Create or remove headers and footers for a table or a level.

6 Select the required Grouping Options.

7 Refer to Setting Table Pagination Controls to Specify pagination controls for each level.

8 When you have finished modifying the table properties click OK.

Delete a Table

When you delete a table, only the definition of the table and its corresponding header and footer sections is deleted. The data sections the table is built around are preserved in their original state.

To delete a table

1 Select any section contained in the table.

2 From the Main menu, select Table > Delete. A confirmation dialog will be displayed.

3 Click OK to delete the selected table.
Table Properties

What do you want to know about?

- Table Levels
- Sorting Modes
- Header and Footer Sections
- Grouping Options
- About Parent/Child relationships
- Setting Table Pagination Controls

Table Levels

Within a table you can create multiple levels. Levels are the mechanism that allows the data to be sorted and grouped.

Refer to Change Table Properties to create a table level.

Examples of how you can use table levels can be found in the following topics:

- Header and Footer Sections
- Grouping Options
- Setting Table Pagination Controls
Sorting Modes

The following table demonstrates the ASCII regional and numeric sort codes.

Table 8.1:

<table>
<thead>
<tr>
<th>Unsorted Sample</th>
<th>Sort Mode</th>
<th>ASCII</th>
<th>Regional</th>
<th>Numeric</th>
</tr>
</thead>
<tbody>
<tr>
<td>(space)</td>
<td>(space)</td>
<td>(space)</td>
<td>(space)</td>
<td></td>
</tr>
<tr>
<td>02</td>
<td>02</td>
<td>02</td>
<td>A</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>1</td>
<td>1</td>
<td>B</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>10</td>
<td>10</td>
<td>C</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>2</td>
<td>a</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>3</td>
<td>c</td>
<td></td>
</tr>
<tr>
<td>A</td>
<td>A</td>
<td>A</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>B</td>
<td>B</td>
<td>a</td>
<td>02</td>
<td></td>
</tr>
<tr>
<td>C</td>
<td>C</td>
<td>B</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>a</td>
<td>a</td>
<td>C</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>c</td>
<td>c</td>
<td>c</td>
<td>10</td>
<td></td>
</tr>
</tbody>
</table>

The sort order when using regional mode can vary with the Windows locale on which the project’s default format style is based. Refer to About Format Styles for more information.

Header and Footer Sections

You can create or remove header and footer sections for the table as a whole and for specific levels within the tables.

To create or remove header and footer sections

1 In the Table Properties dialog, select the level you want to create or remove headers and footers for. Refer to Change Table Properties for more information.

2 Select or clear the appropriate checkbox for:
   - Header before every new grouping in that level
Continuation header for a continuation of a group in that level, and if so, whether it will be the same section as the header or different

Footer after every grouping in that level

Continuation footer for a continuation of a group in that level, and if so, whether it will be the same section as the footer or different

To create a header or footer section using the content and size of an existing data section, click the Create From button. Refer to Create Header and Footer Sections From an Input Section for more information.

Grouping Options

You can control how sections within a table or table level are grouped and sorted from the following options on the Table Properties dialog. Refer to Change Table Properties for more information.

Selecting the Use only first checkbox and typing a value in the characters for sorting/grouping field can have two functions:

- If you are sorting the data, it will qualify the sorting process to only use the number of characters specified. If you set it to use only the first three characters, it will only sort based on those first three characters of every value.

- If you are using headers for the level, it will group the values based on the number of characters specified.
Note

Create a derived variable in the input design if you want to sort or group the data using other criteria.

The example below shows the various sections within a table when you use the group data sections using only the first character and specifying level one headers and footers.

**Table 8.2:** An example of grouping in tables

<table>
<thead>
<tr>
<th>Page 1</th>
<th>Page 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table Header</td>
<td>Table Cont. Header</td>
</tr>
<tr>
<td>Level 1 Header</td>
<td>Level 1 Cont. Header</td>
</tr>
<tr>
<td>A</td>
<td>B</td>
</tr>
<tr>
<td>A</td>
<td>Level 1 Footer</td>
</tr>
<tr>
<td>Level 1 Footer</td>
<td>Level 1 Heading</td>
</tr>
<tr>
<td>Level 1 Heading</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>C</td>
</tr>
<tr>
<td>B</td>
<td>C</td>
</tr>
<tr>
<td>Level 1 Cont. Footer</td>
<td>Level 1 Footer</td>
</tr>
<tr>
<td>Table Cont. Footer</td>
<td>Table Footer</td>
</tr>
</tbody>
</table>

**About Parent/Child relationships**

Tables can contain a parent data section and associated children sections. You must create parent/child relationships if:

- The table will contain multiple section types
- You want to keep sections together

Refer to **About Parent/Child relationships** for more information.
To Create a table containing multiple section types

1. Create a parent/child relationship between the different sections and select the Keep With function to keep the child section with the parent section. Refer to Keeping Sections Together for more information.

2. Create a Table around the parent.

Setting Table Pagination Controls

You can specify pagination controls for the table as a whole or individual levels within the table.

To set table pagination controls

1. From the Table Properties dialog, select the level you want to specify pagination controls for.

2. In the Pagination Control section, specify your pagination controls:
   - To start a new page when a new group of the level appears, select the New page checkbox.
   - To specify a minimum number of occurrences of sections in that level that can appear on the top of the page, select the Top orphan control checkbox, and type the minimum number.
   - To prevent a group from splitting over a page, select the Keep together checkbox. If the group is too large to fit on a page, it will start on the next page.
   - To specify a minimum number of sections in the group that can appear at the end of a page, select the Bottom orphan control checkbox and specify the minimum number.
OBJECTS

You can enhance your project by adding text to pages. The following topics are covered in this Chapter:

- About Objects
- Creating Objects
- Editing and Formatting Objects
- Setting Object Properties
- Selecting and Editing Objects in Graphics View
About Objects

The contents of objects can be static, or you can use variables to control the content of certain objects.

Create!form Transform allows you to create, format and edit objects in many ways; the method you choose will depend on a number of different factors including the type of object you are creating, where the data used to define the object is being sourced from, whether the object is visible, and your own preferences for how you want to work in the Design Window.

Before you can begin to create objects, you should be familiar with the following topics:

- About Objects and Sections
- Selecting Objects in Different Views
- Using Variables to Control Objects
- Window Display Preferences

What do you want to know about?

- Creating Objects
- Editing and Formatting Objects
- Setting Object Properties
- Selecting and Editing Objects in Graphics View

About Objects and Sections

When you create an object it will belong to the currently selected section, regardless of where the object is located on the page. You can select and work with objects belonging to the currently selected section. The object will be displayed in every occurrence of that section. Editing the object in any occurrence of a section changes the object in all occurrences of the same section.
Selecting Objects in Different Views

You can select and edit objects that are visible in the Graphics View directly with the cursor.

When objects are not displayed, or are obscured or hidden

Alternatively, if the objects are not displayed, or are obscured or hidden, you can select objects in either the Listing view or the Project Tree; both of these views offer a non-graphical list of all objects in the section. Follow the procedures detailed in Setting Object Properties to display and edit the properties of any object from any view, including the position, size, content and format of objects.

When sections are not displayed

If a section is not displayed, the objects it contains can still be edited from the Project Tree. Follow the procedures detailed in Edit Objects on Sections that are not Displayed to display and edit objects in hidden sections.

Using Variables to Control Objects

You can use variables in a variety of ways to control the content and display of objects on the page, including:

- To provide the content of text objects (Refer to Adding Text to the Page for more information)
- To control when objects are visible (Refer to General Properties for more information)

The types of variables available, and when to use them are summarized below.

<table>
<thead>
<tr>
<th>Use</th>
<th>To display</th>
</tr>
</thead>
<tbody>
<tr>
<td>data variables</td>
<td>text, numbers and dates copied directly from input sections (Refer to Chapter Five, Input Design, for more information)</td>
</tr>
<tr>
<td>user variables</td>
<td>text, numbers and dates that are manipulated or calculated with functions and user defined expressions (Refer to User Variables for more information)</td>
</tr>
<tr>
<td>global user variables</td>
<td>information derived from elsewhere in the project (Refer to Global User Variables for more information)</td>
</tr>
</tbody>
</table>
You can customize the way objects are edited and displayed by selecting the Tools > Preferences command. With the options displayed in the panes of the Preferences dialog you can:

- Always display the object Properties dialog whenever an object is created
- Turn on and off rulers
- Turn on and off outlines
- Highlight text variables in red
- Show variable names instead of values
- Control how objects are displayed in selected and unselected sections

<table>
<thead>
<tr>
<th>Use</th>
<th>To display</th>
</tr>
</thead>
<tbody>
<tr>
<td>system variables</td>
<td>project page numbers, date, time, file and user attributes and other system values (Refer to System Variables for more information)</td>
</tr>
<tr>
<td>lookup variables</td>
<td>information derived from external databases (Refer to Lookup Variables for more information)</td>
</tr>
<tr>
<td>environment variables</td>
<td>information derived from the operating environment (Refer to Environment Variables for more information).</td>
</tr>
</tbody>
</table>
Creating Objects

To create an object

1. From the Object toolbar, select the tool for the type of object you want to create.

2. Click and drag to create the initial position and size of the object. An object will be created using the default attributes. Refer to Set Default Properties for more information.

Table 9.1: Object Tools

<table>
<thead>
<tr>
<th>Command</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>To insert static text</td>
</tr>
<tr>
<td></td>
<td>To insert static text containing variables</td>
</tr>
<tr>
<td>Variable Text</td>
<td>To insert a single variable as text</td>
</tr>
<tr>
<td>Subform</td>
<td>To insert an existing subform</td>
</tr>
<tr>
<td></td>
<td>Create Subforms</td>
</tr>
<tr>
<td>Variable Subform</td>
<td>Use a Variable to Display Different Subforms</td>
</tr>
</tbody>
</table>

Adding Text to the Page

There are two types of text objects that you can insert:

- Text objects that can contain both static text and variables
- Variable text objects that can contain only a single variable
Static text is the text that you type directly into the project from the keyboard, whereas can contain text, numbers and dates from the input file and other sources. Refer to Using Variables to Control Objects for information on the types of variables you can use.

You can add text and variable text objects to the page in several ways:

**By using the Object toolbar**
- To insert static text
- To insert static text containing variables
- To insert a single variable as text

**By copying all data variables from an input section**
- Copy Data Variables from an Input Section

**By drag and drop from the Input Window**
- Drag and Drop Variables from the Input Window

**To insert static text**
1. In the Design Window, click on the section where you want to insert the text object.
2. Click the text button in the Object toolbar. The cursor will change to the text window.
3. In the Design Window, click and drag the cursor to create a text box. A text box will be displayed in text edit mode.
4. Type in the text you want.
5. Click outside the text object to exit text edit mode.

Refer to Change the Display Properties of Any Object and Edit and Format the Contents of a Text Object for more information on formatting and editing text objects.

**To insert static text containing variables**
1. In the Design Window, click on the section you want to place the text object in.
2. Click the Text button in the Object toolbar. The cursor will change to the text symbol.
3 In the Design Window, click and drag the cursor to create a text box. A text box will be displayed in text edit mode.

4 Type the required text, and as required, click the Insert Variable button on the Text toolbar.

5 From the Variable drop-down, select the required variable from the available sources. The Variable drop down displays all currently available variables for that section. Refer to About Sources for more information on making variables available from another source.

6 Click OK.

7 Continue typing or add further variables.

8 Click outside the object to exit text edit mode. Refer to Change the Display Properties of Any Object and Edit and Format the Contents of a Text Object for more information on formatting and editing text objects containing variables.

To insert a single variable as text

1 In the Design Window, click on the section you want to place the variable text object in.

2 Click the Variable Text button in the Object toolbar. The cursor will change to the variable text symbol.

3 In the Design Window, click and drag the cursor to create a text box. A variable text object is created and Variable Text Properties dialog will be displayed.

4 From the Variable pane, click the Variable drop down button and select the required variable from the available sources. The Variable drop down displays all currently available variables for that section. Refer to About Sources for information on making variables available from another source.

5 Edit the object properties on the General (General Properties), Variable (Variable Properties) and Text (Text Properties) panes as required.

6 Click OK.
Copy Data Variables from an Input Section

Instead of inserting one variable at a time, you can copy all variables that have been defined in the corresponding section of the input file, or for the entire project. A variable text object will be created for each data variable that is not already copied to the project.

To copy variables from a section

1. In the Design Window, click on the section corresponding to the input section where the variables are located.

2. Do one of the following:
   - From the Main menu, select Section > Copy Data Variables
   - Right click on the section to display the shortcut menu and select Copy Data Variables.

To copy all variables from the project

- From the Main menu, select Project > Copy Data Variables

Once the variables have been copied, you can reposition, resize and reformat as required on the page. Refer to Format a Variable Text Object for more information.
**Note**

*You can synchronize the display in the Input Window with selections made in the Design Window. Refer to Input (CSV) Window Preferences for more information.*

---

**Drag and Drop Variables from the Input Window**

You can create variable text objects by using the cursor to drag and drop data variables from the Input Window to the Design Window. To copy more than one data variable at a time, select the data variables while holding down the Shift key, or drag a box around a group of data variables, and then drag and drop the group into the Design Window.

![Figure 9.1: Drag and Drop method of copying data variables to the project](image)

Refer to Select Objects and Select Hidden Objects for more information about selecting groups of objects.

If the section you are dragging from is not a source for the section you are dragging to, you will be prompted to add the section as a source. When you confirm the operation, the Section Properties dialog will open at the Source tab, with the section added as a source. Click **OK** to add the source.
Adding Subforms

If you intend to use the same text in several locations in the same project, or in several projects, you only need to create it once as a subform.

- About Subforms

What do you want to do?

- To insert an existing subform
- Convert Text Files into Subforms
- Create Subforms
- Use a Variable to Display Different Subforms

About Subforms

Subforms are commonly used for items that are repeated in the project or appear in multiple projects. When you modify that subform, all the occurrences where it is used will be automatically updated.

Figure 9.2: Subforms used in a project
Subform Storage

By default, subforms are stored in a common project directory, however they can also be stored in the current project directory. Refer to General Preferences for information on changing the common project directory and the project directory.

To insert an existing subform

1. Click the Subform tool located in the Object toolbar.
2. Position the cursor on the Design Window and click and drag to define the initial subform position. The Subform Properties dialog will be displayed.
3. In the Subform pane, click Select.
4. Select the subform file (.cff6) from the common project directory or project directory and click Open.
5. Set other properties as required. Refer to Setting Object Properties for more information.
6. Click OK. The subform will be displayed in the project.

Convert Text Files into Subforms

You can convert one or more text files into subforms and place them on either the design layer or the background layer.

To insert a text file as a subform

1. Click the Subform tool located in the Object toolbar.
2. Position the cursor on the Design Window and click and drag to define the initial subform position. The Subform Properties dialog will be displayed.
3. In the Subform pane, click Import.
4. Navigate to and select the text file you want to use.
5. Click Open. The subform will be saved to the common project directory. Clear the Save to common form project directory checkbox to save the project directory.
6. Set other properties as required. Refer to Setting Object Properties for more information.
7. Click OK. The subform will be displayed in the project.
To convert multiple text files into subforms

1. From the Main menu, select Tools > Create Subform > Import. The Import dialog will be displayed.

2. Either select or clear the Save to common form project directory checkbox. If cleared, the subforms will be saved to the project directory.

3. To add a prefix to each file as it is saved, select the Add prefix checkbox and type the prefix you want; the prefix will help you identify and manage the files in the project folders.

4. Navigate to the folder where the files are stored and select the images you want to convert. You can select multiple files in the same folder by holding down the Ctrl key.

5. Click Open. Each of the selected files will be converted in turn and saved to the chosen directory.

The subforms can then be placed on the page individually (To insert an existing subform), or displayed using a variable subform object (Use a Variable to Display Different Subforms).

Create Subforms

Subforms are made of other Create!form Transform objects.

To create a subform

1. Click the Subform tool located in the Object toolbar.

2. Position the cursor on the Design Window and click and drag to define the initial subform position. The Subform pane of the Subform Properties dialog will be displayed.

3. In the Subform pane, click Design New. The New Subform dialog will be displayed.

4. In the Name field, type the subform name and click OK.

5. Use the Create!form Designer tools to create the image or text you want.

6. Select File > Save. The Subform file (.cff6) will be saved to the common project directory.

Close the subform window and return to your project. The subform will be displayed in the project.
Use a Variable to Display Different Subforms

Use the Variable Subform tool from the Object toolbar when you want to place different subforms on the page depending on the value of a variable.

For example, a data variable which stores the part number for each line item of a product catalog, can be used for descriptions to each part. If the part number values are say, AT12P9, AY345W and BRG200F, the variable subform will look for the files AT12P9.cff6, AY345W.cff6 and BRG200F.cff6 in the common project directory, and display the subform corresponding to the part number in each occurrence of the data section.

Refer to Adding Subforms for more information.

To create a variable subform object

1. Click the Variable Subform tool, located in the object toolbar.
2. Position the cursor on the Design Window and click and drag to define the initial height, width and location for the subform. The Variable Subform Properties dialog will be displayed.
3. From the Variable field, select the variable that will provide the subform name values.
4. Click OK.

The variable subform object will be created. If the value in the variable corresponds with the name of a subform, the subform will be displayed.

Copying Objects from other Resources

You can copy objects already created from existing projects and subforms.

What do you want to do?

- Copy Objects from Other Projects
Copy Objects from Other Projects

To copy an object from another project, open the project and copy and paste the objects that you want from one project document to the other.

Note

You can also apply the output design from one project to another, which will copy all the objects, sections, tables, variables and page styles defined in that project.
Editing and Formatting Objects

When working interactively in the Design Window, a selection of frequently used formatting functions are available from the toolbars. The full range of formatting functions can be accessed from the Properties dialog. The functions available, and how you find them, are described below.

What do you want to do?

- Change the Display Properties of Any Object
- Edit and Format the Contents of a Text Object
- Format a Variable Text Object
- Change Number, Date and Currency Formats
- Edit the Contents of a Subform

Change the Display Properties of Any Object

The following display options can be accessed from the General pane of the object properties dialog.

- **Origin** - displays the position of the object in the section
- **Size** - displays the horizontal and vertical dimensions of the object
- **Description** - used to identify the object in other views
- **Display condition** - applies conditions when the object is visible

The properties specific to each type of object will be displayed on the Text, Subform, Variable, and Subform Variable panes of the object Properties dialog, depending on the type of objects selected. Refer to Setting Object Properties for information on how to display and edit these options.

You can also move, resize, copy, and align objects interactively; for more information refer to Selecting and Editing Objects in Graphics View.
Edit and Format the Contents of a Text Object

If the text is static, you can edit and format individual characters and words; however for variable text, you can only apply formatting to the entire variable.

To edit and format the contents of a text object

1. Select the text object.
2. Click again inside the text object to start text edit mode.
3. Select the characters or words you want to edit, replace or format.
4. Type the new text and use the formatting tools from the Text toolbar to format as required.
5. To format a variable in a text object, select the variable and use the formatting tools from the Text toolbar to format as required.
6. To edit other properties of a variable in a text object, double click the variable. The Edit Variable dialog will be displayed from which you can change the variable name and edit the properties of a variable, which may include:
   - Format as - display as text, number date or currency (Change Number, Date and Currency Formats)
   - Ignore blank lines - removes blank lines from the text
   - Strip leading spaces - trims spaces from start of text string
   - String trailing spaces - trims spaces from end of text string
   - Wrap (ignore end of line) - wraps text over multiple lines (Refer to Variable Properties for more information.)
7. Click OK to close the Edit Variable dialog and apply the changes.
8. Click outside the object to exit text edit mode.
To change other text properties

Double click the object to display the Text Properties dialog. The following options are available from the Text pane, and any changes will be applied to the object as a whole:

- Alignment - text alignment tools
- Line spacing - changes the spacing between lines of text
- Kerning - changes the spacing between characters
- Format Style - changes how currencies, dates and numbers are displayed

Refer to Text Properties for more information.

Format a Variable Text Object

Any changes to formatting will be applied to the variable as a whole.

To format a variable text object

1. Select the object.
2. Use the formatting tools from the Text toolbar to format as required.
3. To access the full range of formatting options, double click the object to display the Variable Text Properties dialog.
4. Select the Text pane to display and edit these properties:
   - Alignment - text alignment tools
   - Line spacing - changes the spacing between lines of text
   - Kerning - changes the spacing between characters
   - Format Style - changes how currencies, dates and numbers are displayed.

Refer to Text Properties for information on how to use the above options.

5. Select the Variable pane to display and edit these properties:
   - Format as - display as text, number, date or currency (Refer to Change Number, Date and Currency Formats for more information)
   - Ignore blank lines - removes blank lines from the text
• Strip leading spaces - trims spaces from start of text string
• Strip trailing spaces - trims spaces from end of text string
• Wrap (ignore end of line) - wraps text over multiple lines
• Keep paragraphs - preserves paragraph structure of text string

Refer to Variable Properties for more information on how to use the above options.

Change Number, Date and Currency Formats

You can apply customized format styles that control the way numbers, dates, and currencies are displayed. For example whether currencies are displayed with a $ or £ symbol, or dates are displayed in month-day-year or day-month-year order. Different format styles can be applied to objects in the same project, allowing you to create output for offices or customers in multiple regions with one design project. Refer to About Format Styles for information on creating and managing format styles.

To select the format style
1 Double click the object to display the object Properties dialog.
2 Select the Text properties pane.
3 Select a style from the Format Style drop down.
4 Click OK.

Refer to Text Properties for more information on applying format styles.

To format a variable text object as a number, date or currency
1 Double click the object to display the object Variable Text Properties dialog.
2 Select the Variable properties pane.
3 Select a format from the Format as drop down. Selecting the Text format will leave the input data in its original format.
4 Click OK.
To format a variable in a text object as a number, date or currency

1 Select the text object.
2 Click again inside the text object to start text edit mode.
3 Double click the variable you want to edit. The Edit Variable dialog will be displayed.
4 Select a format from the Format as drop down. Selecting the Text format will leave the input data in its original format.
5 Click OK.
6 Click outside the object to exit text edit mode.

Edit the Contents of a Subform

To edit a subform

1 Do one of the following:
   • Use the selection tool to double click on the subform to display the Subform Properties dialog. In the Subform pane, click Edit. The subform will be displayed.
   • Select File > Open. From the Open dialog, in the File of type drop down select Subforms (*.cff6). Select the required file(s) and click Open. The subform will be displayed.
2 Use the Objects tool to edit the subform.
3 Save and close the subform. The changes will be reflected in all projects that use the subform.
Setting Object Properties

What do you want to do?

• Display and Edit Object Properties
• Edit the Properties of Multiple Objects
• Set Default Properties

What do you want to know about?

• About Property Classes

Display and Edit Object Properties

The position, size, rotation, content, format and display properties of objects can be displayed and edited from the <object type> Properties dialog. When you edit and format objects interactively, the content of the object Properties dialog will be updated when the object properties are changed.

You can display the object Properties dialog from the Design Window in either the Graphics View or the Listing View, or from the Project Tree.

To display the object Properties dialog

From any view, do one of the following:

• Double-click on the object.
• Right-click on the object and select Properties from the shortcut menu.
• Click on the object and select Edit >Properties from the Main menu.
• Click on the object and select the Properties button from the Main toolbar.

Choose the method that best suits the way you work.
Edit the Properties of Multiple Objects

You can edit the properties of multiple selected objects, including different object types, at the same time.

To edit the properties of multiple objects

1. Select the objects you want to edit.
2. Click the Properties button from the Main toolbar. The object Properties dialog displays the properties of all selected objects.
3. Edit the properties from the dialog panes displayed.
4. Click **OK** to apply the changes. Properties that are common to more than one object will be applied to all objects that share those properties, and properties that are unique to one object will be applied only to that object.
About Property Classes

Objects can belong to several property classes, which can be common to other objects. Each property class will be displayed as a separate pane in the object Properties dialog.

The object Properties dialog displays the property classes for all of the selected objects. For example, if you simultaneously edit a text object and a variable subform, their properties will be displayed on the General, Text and Subform Variable property panes:

Table 9.2:

<table>
<thead>
<tr>
<th>Object Type</th>
<th>Property Class</th>
<th>General</th>
<th>Variable</th>
<th>Text</th>
<th>Subform</th>
<th>Variable Subform</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td></td>
<td>4</td>
<td>4</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Variable Text</td>
<td></td>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Subform</td>
<td></td>
<td>4</td>
<td></td>
<td></td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Variable Subform</td>
<td></td>
<td>4</td>
<td>4</td>
<td>4</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

General Properties

The General pane of the object Properties dialog displays the following options that are common to all objects:

Origin and Size

You can position objects relative to a section, or to the page. The position and size of the object will be displayed in units columns (characters) and rows (lines). Object position and size are controlled by the following properties:

- **Origin**
  - The object position relative to the section or page origin (1,1) will be displayed in the X and Y fields, measured from the top left corner of the section, or the page, to the top left corner of the object.

- **Fix to page**
  - By default, the object is positioned relative to the section. Select this option to fix the position of the object on the page. Take care not to fix any object that may have more than one occurrence on a page, as it will be redrawn in the same position for every occurrence.
• **Size**

The object Width and Height will be displayed.

**Scaling**

For subforms, you have the option of scaling the size of the object along both the horizontal and the vertical axis. The value of the scale is relative to the original object size when first created. When the object is created, the scaling is set to 1. When you change the scaling value, the size of the object will be factored by the scaling value along each axis respectively. For example, if a subform has an initial size of 2" high by 3" wide, when the scale is changed to 2 on the vertical axis, and 0.5 on the horizontal axis, the size of the subform will change to 4" high by 1.5" wide.

**Description**

You can type a label in the Description field that will help identify the object in the Listing view mode of the Design Window and the Project Tree.

**Display Condition**

Objects can be set to display when specified conditions are met. For example, you can create a condition so that a text object will only display when a data variable has a particular value. Refer to **Building Conditions** for more information.

**Variable Properties**

The variable used to control the content of variable text, variable subform and variable barcode objects will be displayed on the Variable pane of the object Properties dialog.

The following additional options are only displayed for variable text objects, and are also available from the Edit Variable dialog. Refer to **Edit and Format the Contents of a Text Object** for more information.

**Format as**

Select whether to treat the variable data as Number, Date or Currency. If you select Text, no format style will be applied. Refer to **Text Properties** for more information.

**Ignore blank lines**

When selected, blank lines will be removed from the text.
Strip leading spaces
When selected, trims spaces from the start of the text string.

Strip trailing spaces
When selected, trims spaces from the end of the text string.

Wrap (ignore end of line)
When selected, wraps the text over multiple lines according to the object width. If a variable is inserted in a text object and the Wrap (ignore end of line) checkbox is clear, any text that follows the variable will start on a new line.

Keep paragraphs
When selected, preserves new line feeds within the text string.

Text Properties
A selection of text formatting tools are also available from the Text toolbar. Refer to Understanding the Screen Elements for more information.

The Text pane of the object Properties dialog displays the following tools and options:

Alignment tools

Refer to Advanced Object Selection for more information about aligning objects on the page.

Line Spacing
When the Fixed checkbox is selected, the value in the Line spacing field is the spacing, in rows, between the bottom of one line and the bottom of the next line. A line spacing of “0” makes the lines overprint. A line spacing of “1” makes the lines print at one line per row.

When the Fixed checkbox is cleared, the value in the Line spacing field is the gap, in rows, between the bottom of one line and the top of the next line. The line spacing interval is measured in rows. A line spacing of “0” makes the
lines print at one line per row. A line spacing of “1” adds one row between lines.

**Kerning**

Kerning is a typesetting term that defines the distance between characters, measured in columns. Kerning allows you to space text across a text box. A kerning of “1” inserts a character space between each letter. A kerning of “-1” makes the text overprint.

**Format Style**

You can apply different format styles to variables in text and variable text objects. Format styles determine how currencies, dates and numbers are displayed. When you apply a format style to an object, it applies to all variables contained in the object.

By default, all new text objects will be created with the current default format style. Refer to About Format Styles for information on setting the default format style.

Select the Manage Formats option from the Format style drop list to create, edit, rename and delete format styles.

**Subform Properties**

Refer to Adding Subforms for information on creating and using subform objects. The following command buttons are displayed on the Subform pane of the Properties dialog:

**Select**

Displays the subform files available to be inserted in the project.

**Import**

Allows you to import one or more text files, and saves the selected files as subforms in the common project directory or the project directory.

**Edit**

Opens a subform for editing in Create!form Transform. Any changes made will be reflected in all projects that use the subform.

**Design New**

Creates a new subform for editing in Create!form Transform.
Subform Variable Properties

Import
Allows you to import one or more text files, and saves the selected files as subforms in the common project directory or the project directory.

Set Default Properties

The following command buttons are displayed on various panes of the object Properties dialog.

Set as Default
Select this button to use the current properties as the default for the current property class. The default properties will be applied when creating new objects, in all projects.

Apply Defaults
Select this button to apply the current default settings for this property class to the selected objects.
Selecting and Editing Objects in Graphics View

What do you want to do?
- Select Objects
- Select Hidden Objects
- Edit Objects on Sections that are not Displayed
- Move Objects
- Resize Objects
- Copy Objects
- Align Objects
- Advanced Object Selection

Select Objects

Use the Selection tool to select one or more objects. (To unselect an object and select the Selection tool, press the Spacebar.)

To select multiple objects

1. Select the first object you want to include in the selection.
2. Hold down the Shift key and click on the next object.
3. Continue to select additional objects in the same way.

To deselect an object

1. Hold down the Shift key, and click on the selected object. The object will be unselected.
Select Hidden Objects

Objects can be hidden behind each other or difficult to identify because of their content. For example, variable objects may have no content. The following are methods for selecting and identifying these types of object. They all require that the section the object belongs to is selected:

Ctrl+A
Press the Ctrl and A keys together to select all objects in the active section.

Click-and-drag
If you know the approximate location of the object you are trying to locate, you can use the Selection tool to click-and-drag an area. All objects fully within the area will be selected.

Select Objects Shortcut
Use this method when selecting overlapping objects. Right-click the overlapping objects and choose Select Objects from the shortcut menu, then choose the appropriate object.

Using the Listing View or Project Tree
The Listing View (Refer to the Design Window for more information) and the Project Tree both offer a non-graphical list of all objects in a section. By selecting an object in either of these views, the same object is selected in the Graphics View.

Edit Objects on Sections that are not Displayed

You can still view and edit the objects on sections that are not displayed. There can be several reasons why sections may not be displayed in the design:

- The input file does not contain an instance of a particular section
- The conditions for the display of an alternate section are not met
- Continuation headers and footers do not occur
To edit the contents of a section that is not displayed

1. In the Project Tree, right-click the section you want to edit, and select Edit Form from the shortcut menu. The section, and the objects it contains, will be displayed in a separate view pane.

2. Add, edit and delete objects as required.

3. When you have completed your edits, close the section edit pane by clicking the close button ( ) at the top right corner of the view pane.

---

Note

All sections, including all possible continuation headers and footers and alternate sections, are listed in the Project Tree.

---

Move Objects

There are several methods of moving objects.

Use the cursor

Use the Selection tool to select and drag an object to the desired location.

- You can constrain movement to increments of 45 degrees from the original location, by holding down the Shift key while dragging.
- Movements will snap to the nearest column and row position.

Use the arrow keys

You can move any selected object(s) using the arrow keys.

Use the Move tool

This method is useful where a precise movement is required.

1. Select the object.

2. From the Main toolbar, click the Move Objects button or select EditMove from the Main menu. The Move dialog will be displayed.

3. Specify the amount of horizontal and vertical movement that you want. Negative numbers move the object(s) left and up.
You can also
Set the location of an object from the General pane of the Properties dialog. Refer to General Properties for more information.

Resize Objects

To resize one or more objects
1 Select the object(s) to resize.
2 Position the cursor over one of the object’s sizing handles.
3 Click and drag outwards to increase the size or inwards to decrease the size.
4 Release the mouse button when the object(s) are the size required.

You can also
• Set the exact size of an object from the General pane of the Properties dialog (Refer to General Properties for more information)
• Use the arrow keys while holding down the SHIFT or CTRL keys to adjust the size of an object
• Make the width and height the same as a control object

Note
To resize the object(s) proportionally, hold down the Shift key while dragging a corner handle.

Copy Objects

To copy one or more objects
1 Select the object(s) to copy.
2 From the Main menu, select Edit > Copy, or press Ctrl+C.

From the Main menu, select Edit > Paste, or press Ctrl+V. The object(s) will be pasted into the currently selected section.
The new object will be pasted in front of, but fractionally offset from the original.

---

**Note**

*To create a copy of an object and move it at the same time, hold down the Ctrl button and “drag” a copy of the object away from the original.*

---

**Align Objects**

The alignment tools enable you to accurately line up objects. The Align toolbar is positioned on the lower left side of the screen by default. In order to use the alignment tools, you must understand the concept of control objects.

**The control object**

The control object is the object that other objects move around, when you are performing any sort of alignment.

- If you’ve selected the objects using the shift and click method, the control object is the last one selected.
- If you’ve selected the objects using the click-and-drag or select all method, the control object is the last object created.

Handles around the control object have a thicker black border than the handles on the other selected objects.

**Alignment tools**

The following table explains the alignment tools when used with fully selected objects. These tools will perform different functions when used with the Handle Selection tool. Refer to Advanced Object Selection for more information.
Selecting and Editing Objects in Graphics View

To align objects

1. Select the objects you want to align.
2. Select the control object.
3. Click the appropriate tool in the Align toolbar. The selected objects will be aligned with the control object.

Table 9.3:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Left</td>
<td>Aligns the left sides of all objects with the left side of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Horizontal Center</td>
<td>Aligns the horizontal centers of all objects with the horizontal center of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Right</td>
<td>Aligns the right sides of all objects with the right side of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Top</td>
<td>Aligns the tops of all objects with the top of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Vertical Center</td>
<td>Aligns the vertical centers of all objects with the vertical center of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Bottom</td>
<td>Aligns the bottoms of all objects with the bottom of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Left to Right</td>
<td>Aligns the left sides of all objects with the right side of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Right to Left</td>
<td>Aligns the right sides of all objects with the left side of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Top to Bottom</td>
<td>Aligns the tops of all objects with the bottom of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Bottom to Top</td>
<td>Aligns the bottom of all objects with the top of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Width</td>
<td>Resizes all objects to the width of the control object.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Height</td>
<td>Resizes all objects to the height of the control object.</td>
</tr>
</tbody>
</table>
Advanced Object Selection

The Handle Selection tool is an advanced feature that enables you to simultaneously align and re-size objects. By allowing you to select some object handles and not others, the Handle Selection tool lets you dictate which parts of an object are static and which parts can be moved or re-sized.

When used in conjunction with multiple objects, the Handle Selection tool allows you to fix the spatial relationship between non-selected handles on different objects.

**Anchor points**

When a handle is selected, the handle diagonally opposite the selected handle becomes the anchor point. Anchor points are fixed in position.

![Figure 9.4: A box object with one handle selected](image)

When two handles are selected, the opposite two handles become anchor points.

![Figure 9.5: A box with two selected handles](image)

When a line object is selected, two handles are positioned on the perimeter of the object. When you select one handle, the other handle becomes the anchor point.
Selecting and Editing Objects in Graphics View

To select handles

1. Activate the Handle Selection tool.
2. Position the cursor on an object’s handle and click.
3. To select other handles (on the same or different objects), hold down the shift key and click on the required handles. To select multiple handles at once, you can click-and-drag an area.

The handles of multiple objects become selected as shown below.

To deselect handles

1. Using the Handle Selection tool, hold down the Shift key and click the selected handle you want to deselect.
To re-size one object while moving another
1 Activate the Handle Selection tool.
2 Partially select handles of the object to be resized.
3 With the Shift key held down, click in the middle of the second object to select the entire object.

For example:

![Selected handles and an entire object](image)

Both objects can now be manipulated simultaneously.
4 Click and drag downwards to increase the size of one object while moving the second object.

To align handles of objects
When individual handles are selected with entire objects or handles on other objects, the Alignment toolbar may be used to align selected handles. Objects can be automatically resized and aligned with the edge of a control object.
1 Select the handles of the objects you wish to align.
2 Select the control object last. (Refer to Align Objects for more information.)
3 Click one of the tools on the alignment toolbar.
For example:

Figure 9.9: Aligning object handles using the Top tool on the Alignment toolbar
You can use variables to control the content of the project, either as objects on a page, or as arguments in expressions and conditions that you can use to control the display of objects, sections and pages.

The following topics are covered:

- About Variables
- Data Variables and Derived Variables
- User Variables
- Global User Variables
- System Variables
- Lookup Variables
- Environment Variables
- Job Ticket Variables
About Variables

Variables can be used to create text objects, or as arguments in conditions and expressions. There are several different types of variables that you can use in a project; the type of variable you use will depend on where you want to source your data and how it will be applied in the project:

- Data Variables and Derived Variables
- User Variables
- Global User Variables
- System Variables
- Lookup Variables
- Environment Variables
- Job Ticket Variables
Data Variables and Derived Variables

Data variables and derived variables are created in the Input Design. To view the data variables defined in a section, select Section > Data Variables from the Main menu.
User Variables

User Variables are defined by users and derive their value from functions and expressions using other variables as arguments. User variables are created in and belong to a section. User variables can only derive values from data in the source of the section. They can be used for a wide variety of tasks.

Example

You might create a user variable to display a post-tax total. The user variable can take the pre-tax total (a value obtained by a data variable), and multiply it by the sales tax amount.

<table>
<thead>
<tr>
<th>Net Value</th>
<th>Tax (%)</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>£5,000.00</td>
<td>10%</td>
<td>£5,500.00</td>
</tr>
<tr>
<td>£26,002.00</td>
<td>10%</td>
<td>£28,602.20</td>
</tr>
<tr>
<td>£5,577.00</td>
<td>10%</td>
<td>£6,134.70</td>
</tr>
</tbody>
</table>

User variable that combines the value of the data variable, with the constant tax rate of 10%.

Figure 10.1: An example of how user variables can be used

User variables can be used in other sections, provided the section it belongs to is a source for the section where it will be used. Refer to About Sources for more information.
To create a user variable

1. In the Design Window, select the section you want the user variable to be available in/belong to.

2. From the Main menu, select Section > User Variables. The User Variables dialog will be displayed.

3. If required, click the Add Row button. A new variable is created.

4. To create a condition, click the Condition button in the Condition column. Refer to Conditions for more information.

5. In the Variable Name column, type a name for the user variable.

6. Click the Expression button to create the expression that will generate the variable value. The Expression Builder will be displayed. Refer to Using the Using the Expression Builder for more information.

7. Click OK. Once you have created a user variable, you can use it in text objects, variable text objects or to build other expressions or conditions.
Global User Variables

Global user variables enable you to create a variety of dynamic fields and use them in any section in the project. Global user variables have an initial value and are passed sequentially from section to section. In each section they can have their value changed.

Global user variables are typically used in conjunction with user variables. Global user variables can provide values for user variables, or derive values from user variables.

When to use global variables

Global user variables can be used in the following types of task:

- To perform calculations that involve data from unrelated sections in the project.
- For conditional based decision making that involves data from an unrelated section in the project.

To create a global user variable

1. From the Main menu select Project > Global User Variables. The Global User Variables dialog will be displayed.
2. Click the Add Row button.
3. In the Variable Name column, type a name.
4. In the Initial Value column, type an initial value.
5. In the Reset column, select whether you want the global user variable reset every page, set or document.
6. Click OK.
System Variables

Create!form Transform provides pre-defined variables that you can use to determine information about the project and the operating environment. The following table describes the system variables available in the input and output of the design:

Table 10.1:

<table>
<thead>
<tr>
<th>System Variable</th>
<th>Description</th>
<th>Input</th>
<th>Output</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sys.PreviousSection</td>
<td>Name of previous section</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Sys.DocPageNum</td>
<td>Current page number in the document</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Sys.DocSetNum</td>
<td>Current set number in the document</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Sys.SetPageNum</td>
<td>Current page number in the current set</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Sys.PageNum</td>
<td>Collated page number sequence in Next Copy projects</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Sys.SetNumPages</td>
<td>Total number of pages in the current set</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>Sys.Today</td>
<td>Current date value supplied by the system</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.Time</td>
<td>Time of merge supplied by the system</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.Username</td>
<td>Username property of spool file</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.Hostname</td>
<td>Name of host server where queue resides</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.OSVersion</td>
<td>Version of operating system running on host</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.SpoolID</td>
<td>Spool file ID on the merge queue</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.DocName</td>
<td>Name of spool file</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.QueueName</td>
<td>Name of print queue where merge occurs</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.DeviceName</td>
<td>Name of destination port, queue or device</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.ProjectName</td>
<td>Name of current project</td>
<td>4</td>
<td>4</td>
</tr>
<tr>
<td>Sys.ProductVersion</td>
<td>Details about Create!form Server installed on host</td>
<td>4</td>
<td>4</td>
</tr>
</tbody>
</table>
System variables can be displayed as variable text objects or used as arguments in expressions and conditions.

**Examples:**

- This expression tests for odd or even numbered pages in a document:
  \[ \text{round}(\text{Sys.DocPageNum}/2,0)*2-\text{Sys.DocPageNum} \]

- This expression tests if the date stored in InvDate is in the current month:
  \[ \text{month}(\text{InvDate}) == \text{month}(\text{Sys.Today}) \]
Lookup Variables

Lookup variables retrieve values from external databases. For example you can use lookup variables to retrieve a customer telephone number from a database. Lookup variables can be inserted directly into the project or used as part of an expression or condition.

Lookup variables are created in and belong to a section. They can be used in other sections, provided the section it belongs to is a source for the section where it will be used.

Requirements

To use lookup variables you require a DSN connection to an ODBC database. To enable production printing, you must also create a permanent connection between the e-forms server and the database(s). For more information see the Create!form Server User Guide.

To create a lookup variable

1. From the Create!form Transform main menu, select Section >Lookup Variables. The Lookup Variables dialog will be displayed.
2 From the drop-down list under the Database (DSN) field, select the DSN for the database you want to retrieve data from, or click New to create a new DSN. Setup procedures for databases will vary.

3 If multiple tables/views exist in the database, select the appropriate one from the Table/view drop-down.

4 In the Select records where field, define a query by selecting:
   • the Database Field from the database table that will be searched in and;
   • the Variable from the project containing the value that will be searched with. Ensure the query will only match with one record. If you need to add further qualifiers, clicking the Add Row button and select further fields and variables.
5 In the Assign to variables field, define the response to the above query by:
   • typing the Variable Name in the project to assign to and;
   • selecting the Database Field from the database table to assign from.

   It is possible to return more than one response from that particular record in the database by clicking the Add Row button and defining further Variable Names and Fields.

6 By clicking the Refresh button at the bottom right of the dialog the returned value(s) from the lookup query will be displayed in the Content column.
Environment Variables

Environment variables are common to all projects in the production environment. Environment variables may be the same for all output destinations, or can be changed for individual print queues. Typical uses of environment variables include setting values that are used in all projects, like a company name, or using different page styles in the same project depending on whether the destination is a printer, fax, email or archive server port.

Storage

Environment variables are stored in the EnvironmentVars.data file in the SystemResource folder, which will be sent to the e-forms server when the project is published.

To create an environment variable

1. From the Main menu, select Tools > Environment Variables. The Environment Variables dialog will be displayed.
2. To create a new environment variable, click the Add Row button.
3. Type the name of the environment variable in the Name field.
4. Type the value of the environment variable in the Value field.
5. Click OK.
Job Ticket Variables

All the job ticket values passed through with the spool file, or added by the e-forms server are available wherever system variables are available in the design. The job ticket variables available to a project must be defined in the following configuration files found in the Win32User folder:

- Text, CSV and XML input files: HeaderParams.cfg
- JDE PDF input files: JDEHeaderParams.cfg

You can edit these files, and add variables in a text editor, e.g. Notepad. Any changes you make to configuration files on the design workstation will be transferred to the e-forms server with the project. Refer to Transferring Projects to the e-forms Server for more information.

---

**Note**

*If you edit the configuration file, you must restart the program.*
VARIABLES

- Job Ticket Variables

-
CHAPTER 11: EXPRESSIONS AND CONDITIONS

You can create expressions and conditions to combine and manipulate text, calculate values, summarize data in tables and test when objects, sections and pages should be displayed.

The following topics are covered:

- Expressions
- Conditions
- Building Blocks
- Syntax and Order of Precedence Rules
- Summarizing Data in Headers and Footers
Expressions

What do you want to know about?

• Building Expressions
• Using the Expression Builder
• Navigating and Editing Expressions

Building Expressions

Expressions are built using the Expression Builder dialog (referred to as the Expression Builder), which is opened whenever you click the button from either the Derived Variables dialog (input) or the User Variables dialog (output). The Expression Builder provides a range of operators and functions used to build expressions that evaluate values, called arguments, in a specific order, or syntax.

Expressions are evaluated from left to right subject to the syntax and order of precedence rules detailed. Refer to Syntax and Order of Precedence Rules for more information.
Using the Expression Builder

You must build an expression in a particular order. Generally you will follow the list boxes from left to right. The operators, functions and variables available to you are context sensitive. For example, when you select a variable with a numeric value, only functions that can process numbers will be available to you.

The following procedure explains how to build a simple expression to add the text “Inc.” to a user variable called “Company_Name”.

1. From the Main menu, select Section > User Variables.

2. From the User Variables dialog, in the Variable Name field, type the name of the variable you want to create.

3. Click to open the Expression Builder.

4. From the Expression Builder, click concat in the Function section.

5. In the Variable section, expand and select the user variable.

6. Click on the Edit Value button and type the text you want to add to the user variable.

   The Expression Builder will display: concat(Company_Name," Inc.")

7. Click OK to close the Expression Builder.

When you close the Expression Builder, you will be returned to the User Variables dialog where the expression will be displayed in the Value field, and the value the expression returns in the current section will be displayed in the Content field. The same procedure applies when building expressions from the Derived Variables dialog.

To enable direct editing of the expression in the dialog that calls the Expression Builder. Refer to General Preferences for more information.
Navigating and Editing Expressions

- To move around the expression, use the arrow buttons, keyboard arrow keys and the cursor.
- To expand or reduce the selection, use the Level Up button or the Level Down button.
- To add text or number values, use the Edit Value button.
- To delete parts of an expression, select the part of the expression to be deleted and click the Delete button.
- To enclose parts of an expression in parentheses, select the part of the expression to be enclosed and click the Group button.

You can also enable direct editing of the expression in the dialog that calls the Expression Builder. Refer to General Preferences for more information.
Conditions

A condition is a special type of expression which produces a TRUE or FALSE value. Conditions allow you to vary the output of the project, depending on data within the input file. For more information about the ways you can use conditions, see the usage examples below.

Usage examples

Conditions can be used to determine:

- When input sections are created (refer to Add Detail Sections for more information and Add Input Header Sections)
- When sets are created (refer to Defining Sections for more information)
- When sections are displayed (refer to Data Section Display Options for more information)
- Which section will be displayed, when using alternates (refer to Alternate Sections for more information)
- When objects are displayed (refer to General Properties for more information)
- When defining derived values
- When calculating values or manipulating data in user variables

What do you want to know about?

- Building Conditions
- Using Expressions as Conditions
Building Conditions

The Condition Builder is used to build and edit expressions in much the same fashion as the Expression Builder. Refer to Expressions for more information. The Condition Builder can be opened from numerous dialogs, either by clicking the Edit button next to a condition field, or by clicking the button.

The following procedure explains how to build a simple condition to test whether the user variable called “Item_type” contains the word “new”.

To build a simple condition test

1. From the Condition Builder, click contains in the Function section.
2. In the Variable section, expand and select the user variable.
3. Click on the Edit Value button and type “new”. The Condition Builder will display: contains(Item_type,"new")
4. Click OK to close the Condition Builder.

When you close the Condition Builder, you will be returned to the originating dialog where the expression will be displayed. Refer to General Preferences for information on how to enable direct editing of the expression in the dialog that calls the Condition Builder.

Using Expressions as Conditions

Any expression that evaluates to a non-zero value when true can be used as a condition. For example, the expression A-B is equivalent to the condition A!=B as both expressions return a zero value when A equals B and a non-zero value when A is not equal to B.
Building Blocks

The Expression Builder and Condition Builder dialogs contain list boxes containing the building blocks from which you can build an expression. The content of these dialogs is context sensitive; the building blocks displayed or available will depend on the task you are performing:

- Boolean Operators
- Operators
- Functions
- Variables
- System Conditions

Boolean Operators

Boolean operators are only available in the Condition Builder. The syntax of an expression involving boolean operators begins with the first argument, followed by the operator, and the second argument, separated by spaces:

condition1 OPERATOR condition2

Arguments can be other user defined conditions or system conditions. The following table describes the boolean operators available.
Other boolean operations can be performed by combining AND and OR operators in expressions with the negation operator NOT (Refer to Operators for more information); for example, a boolean difference operation is performed by the expression:

NOT condition1 AND condition2

### Operators

The usual syntax of an expression involving operators begins with the first argument, followed by the operator, and the second argument, with or without separating spaces:

argument1 OPERATOR argument2

The negation operators are the only exceptions to this rule, as they precede a single argument. Arguments can be numbers, text strings, variables or other functions or expressions. The following table describes the operators available.
### Operators and Their Meanings

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
<th>Syntax and Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>==</td>
<td>equal to</td>
<td>Compares the values of two numbers or two strings and returns TRUE if equal. Case sensitive when comparing strings.</td>
</tr>
<tr>
<td>!=</td>
<td>not equal to</td>
<td>Compares the values of two numbers or two strings and returns TRUE if not equal. Case sensitive when comparing strings.</td>
</tr>
<tr>
<td>&gt;</td>
<td>greater than</td>
<td>Compares the values of two numbers and returns TRUE if A is greater than B.</td>
</tr>
<tr>
<td>&lt;</td>
<td>less than</td>
<td>Compares the values of two numbers and returns TRUE if A is less than B.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>greater than or equal to</td>
<td>Compares the values of two numbers and returns TRUE if A is greater than or equal to B.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>less than or equal to</td>
<td>Compares the values of two numbers and returns TRUE if A is less than or equal to B.</td>
</tr>
<tr>
<td>*</td>
<td>multiply</td>
<td>Multiplies two numbers.</td>
</tr>
<tr>
<td>/</td>
<td>divide</td>
<td>Divides A by B.</td>
</tr>
<tr>
<td>+</td>
<td>add</td>
<td>Adds two numbers, or concatenates two strings.</td>
</tr>
<tr>
<td>-</td>
<td>subtract</td>
<td>Subtracts B from A.</td>
</tr>
<tr>
<td>NOT</td>
<td>logical negation</td>
<td>Reverses the logical value of an expression.</td>
</tr>
<tr>
<td>- (neg)</td>
<td>arithmetic negation</td>
<td>Reverses the sign of a numeric value, i.e. -B=-1*B</td>
</tr>
</tbody>
</table>

For the syntax rules governing the evaluation of expressions using parentheses, multiple operators and mixed data types. Refer to Syntax and Order of Precedence Rules for more information.
Functions

The syntax of a function begins with the function name, followed by an opening parenthesis, the arguments for the function separated by commas, and a closing parenthesis.

function(argument1,argument2,...)

Arguments can be numbers, text strings, variables, functions and expressions. The following tables describe the functions available.

Logical Functions

Logical functions can be used as conditions returning a TRUE or FALSE value. When used as arguments in expressions, logical functions return a value of 1 if true, and 0 if false.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax and usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>contains</td>
<td>contains(string,find_text)</td>
</tr>
<tr>
<td></td>
<td>Returns TRUE if string contains find_text.</td>
</tr>
<tr>
<td></td>
<td>Example: contains(&quot;Heath;Adele;Mrs;;;OK;;&quot;,&quot;OK&quot;) = TRUE</td>
</tr>
<tr>
<td>exists</td>
<td>exists(name)</td>
</tr>
<tr>
<td></td>
<td>Returns TRUE if the variable name exists.</td>
</tr>
<tr>
<td>isnumeric</td>
<td>isnumeric(name)</td>
</tr>
<tr>
<td></td>
<td>Returns TRUE if the variable name contains at least one numeral and any of the</td>
</tr>
<tr>
<td></td>
<td>characters , ( ) + - $ % or space. The test will fail if the variable contains</td>
</tr>
<tr>
<td></td>
<td>any other character.</td>
</tr>
<tr>
<td></td>
<td>Examples:</td>
</tr>
<tr>
<td></td>
<td>isnumeric(&quot;$ 1,234.56&quot;) = TRUE</td>
</tr>
<tr>
<td></td>
<td>isnumeric(&quot;$US1,234.56&quot;) = FALSE</td>
</tr>
</tbody>
</table>
Text and Numeric Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax and Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>aswords</td>
<td>aswords(number,option)</td>
</tr>
<tr>
<td></td>
<td>Converts a number into words. Specifying &quot;a&quot; in the second argument will generate a number phrase with “and” e.g. “Five hundred and twenty seven”</td>
</tr>
<tr>
<td></td>
<td>Examples:</td>
</tr>
<tr>
<td></td>
<td>aswords(&quot;123&quot;,&quot;&quot;) = &quot;One hundred twenty three&quot;</td>
</tr>
<tr>
<td></td>
<td>aswords(&quot;123&quot;,&quot;a&quot;) = &quot;One hundred and twenty three&quot;</td>
</tr>
<tr>
<td>at</td>
<td>at(row,column,length)</td>
</tr>
<tr>
<td></td>
<td>Returns a string of a specified length, starting at the specified row and column position in the current input page.</td>
</tr>
<tr>
<td></td>
<td>Example: if row 5 of the input page contains the letters of the alphabet in columns 1 to 26, then</td>
</tr>
<tr>
<td></td>
<td>at(5,12,3) = &quot;LMN&quot;</td>
</tr>
<tr>
<td>concat</td>
<td>concat(string1,string2)</td>
</tr>
<tr>
<td></td>
<td>Joins two text strings.</td>
</tr>
<tr>
<td></td>
<td>Example: concat(&quot;Adele &quot;, &quot;Heath&quot;) = &quot;Adele Heath&quot;</td>
</tr>
<tr>
<td>find</td>
<td>find(string,find_text,start_char)</td>
</tr>
<tr>
<td></td>
<td>Finds one text string within another text string, starting from character position start_char, and returns the starting position. The first character in string is position 1. Returns 0 if find_text is not found in string.</td>
</tr>
<tr>
<td></td>
<td>Example: find(&quot;Mrs Adele Heath&quot;,&quot; &quot;,5) = 10</td>
</tr>
<tr>
<td>length</td>
<td>length(string)</td>
</tr>
<tr>
<td></td>
<td>Returns the length of a text string, including spaces.</td>
</tr>
<tr>
<td></td>
<td>Example: length(&quot;Mrs Adele Heath&quot;) = 15</td>
</tr>
<tr>
<td>lower</td>
<td>lower(string)</td>
</tr>
<tr>
<td></td>
<td>Converts a text string to lower case.</td>
</tr>
<tr>
<td>ltrim</td>
<td>ltrim(string)</td>
</tr>
<tr>
<td></td>
<td>Trims leading spaces from a text string.</td>
</tr>
<tr>
<td></td>
<td>Example: ltrim(&quot; left trim &quot;) = &quot;left trim &quot;</td>
</tr>
<tr>
<td>mod</td>
<td>mod(number,base)</td>
</tr>
<tr>
<td></td>
<td>Returns the remainder after number is divided by base.</td>
</tr>
<tr>
<td></td>
<td>Example: mod(51,7) = 2</td>
</tr>
<tr>
<td>Function</td>
<td>Syntax and Usage</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------</td>
</tr>
<tr>
<td>num</td>
<td>num(string)</td>
</tr>
<tr>
<td></td>
<td>Converts a text string into a number.</td>
</tr>
<tr>
<td></td>
<td>Examples: num(&quot;12ab3&quot;) = 123</td>
</tr>
<tr>
<td></td>
<td>num(&quot;18+9/3&quot;) = 1893</td>
</tr>
<tr>
<td></td>
<td>num(&quot;nine&quot;) = 0</td>
</tr>
<tr>
<td>pad</td>
<td>pad(string,length)</td>
</tr>
<tr>
<td></td>
<td>If string is shorter than length, extends string to length with spaces.</td>
</tr>
<tr>
<td></td>
<td>If string is longer than length, truncates string to length.</td>
</tr>
<tr>
<td></td>
<td>Examples: pad(&quot;abc&quot;,&quot;6&quot;) = &quot;abc  &quot;</td>
</tr>
<tr>
<td></td>
<td>pad(&quot;abc&quot;,1) = &quot;a&quot;</td>
</tr>
<tr>
<td></td>
<td>pad(&quot;abc&quot;,-2) = &quot;abc&quot;</td>
</tr>
<tr>
<td></td>
<td>pad(&quot;abc&quot;,&quot;def&quot;) = &quot;&quot;</td>
</tr>
<tr>
<td>proper</td>
<td>proper(string)</td>
</tr>
<tr>
<td></td>
<td>Capitalizes the first letter of each word in a text string.</td>
</tr>
<tr>
<td>previous</td>
<td>previous(var_name)</td>
</tr>
<tr>
<td></td>
<td>Returns the value of variable var_name in the previous occurrence of the current section.</td>
</tr>
<tr>
<td>retrieve</td>
<td>retrieve(string,ordinal_position,delimiter_char)</td>
</tr>
<tr>
<td></td>
<td>Extracts text from delimited fields in a text string. When the space character is used as a delimiter, leading spaces are ignored and sequential spaces are treated as a single delimiter.</td>
</tr>
<tr>
<td></td>
<td>Examples: retrieve(&quot;Abc;De:F;;;Ghij;;;&quot;,6,&quot;;&quot;) = &quot;Ghij&quot;</td>
</tr>
<tr>
<td></td>
<td>retrieve(&quot; Abc De F&quot;,2,&quot; &quot;) = &quot;De&quot;</td>
</tr>
<tr>
<td></td>
<td>Use the following arguments when specifying these delimiters: ArgumentDelimiter</td>
</tr>
<tr>
<td></td>
<td>\new line</td>
</tr>
<tr>
<td></td>
<td>\tab</td>
</tr>
<tr>
<td></td>
<td>&quot;double quotation mark (&quot;</td>
</tr>
<tr>
<td></td>
<td>\backslash ()</td>
</tr>
<tr>
<td></td>
<td>Example: retrieve(var,1,&quot;\t&quot;) returns the value before the first tab in the text variable var</td>
</tr>
</tbody>
</table>
### Date Functions

The result of a date function depends on the current date order setting. Refer to Set Input Data Formats for more information.

Refer to the Syntax and Order of Precedence Rules for more information.

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax and Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>rfnd</td>
<td>rfnd(string,find_text,start_char)</td>
</tr>
<tr>
<td></td>
<td>Finds one text string within another text string by searching from the right to the left, starting from character position start_char, and returns the starting position. The first character in string is position 1. Position 0 specifies the last character in string. Returns 0 if find_text is not found in string.</td>
</tr>
<tr>
<td></td>
<td>Example: rfnd(&quot;Heath,Adele,Mrs&quot;,&quot;&quot;,0) = 12</td>
</tr>
<tr>
<td>round</td>
<td>round(number,num_digits)</td>
</tr>
<tr>
<td></td>
<td>Rounds a number to a specified number of decimal places.</td>
</tr>
<tr>
<td></td>
<td>Examples:</td>
</tr>
<tr>
<td></td>
<td>round(1234.567,2) = 1234.57</td>
</tr>
<tr>
<td></td>
<td>round(1234.56,0) = 1234</td>
</tr>
<tr>
<td></td>
<td>round(1234.56,-2) = 1200</td>
</tr>
<tr>
<td>rtrim</td>
<td>rtrim(string)</td>
</tr>
<tr>
<td></td>
<td>Trims trailing spaces from a text string.</td>
</tr>
<tr>
<td></td>
<td>Example: rtrim(&quot; right trim &quot;) = &quot; right trim&quot;</td>
</tr>
<tr>
<td>sentence</td>
<td>sentence(string)</td>
</tr>
<tr>
<td></td>
<td>Converts a text string to sentence case.</td>
</tr>
<tr>
<td>substitute</td>
<td>substitute(string,old_text,new_text)</td>
</tr>
<tr>
<td></td>
<td>Replaces all occurrences of existing text with new text in a text string.</td>
</tr>
<tr>
<td></td>
<td>Example: substitute(&quot;Contact &lt;N&gt; for quote&quot;,&quot;&lt;N&gt;&quot;,&quot;Chris&quot;) = &quot;Contact Chris for quote&quot;</td>
</tr>
<tr>
<td>substring</td>
<td>substring(string,start_char,length)</td>
</tr>
<tr>
<td></td>
<td>Returns a portion of a text string.</td>
</tr>
<tr>
<td></td>
<td>Example: substring(&quot;Telephone: 303-8783 2054&quot;,12,3) = &quot;303&quot;</td>
</tr>
<tr>
<td>trim</td>
<td>trim(string)</td>
</tr>
<tr>
<td></td>
<td>Trims leading and trailing spaces from a text string.</td>
</tr>
<tr>
<td></td>
<td>Example: trim(&quot; trim &quot;) = &quot;trim&quot;</td>
</tr>
<tr>
<td>upper</td>
<td>upper(string)</td>
</tr>
<tr>
<td></td>
<td>Converts a text string to upper case.</td>
</tr>
</tbody>
</table>
Any non-numeric parsing character is permitted in a string representing a date value, for example, the strings "19 4 03" and "19.04.2003" will return the same value when used as arguments in a date function.

Refer to the Syntax and Order of Precedence Rules for more information on using the addition and subtraction operators with data values.

**Statistical Functions**

Table functions are defined in a header or footer, and perform calculations on variables that occur within the part of the document associated with the header or footer. Refer to Summarizing Data in Headers and Footers for more information on how to use statistical functions to summarize data in tables, pages and sets.
EXPRESSIONS AND CONDITIONS

Building Blocks

Variables

The types of variables that can be used in conditions as arguments of operators and functions are summarized below:

<table>
<thead>
<tr>
<th>Variable Type</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>data variable</td>
<td>input data (refer to Design Principles for more information)</td>
</tr>
<tr>
<td>user variable</td>
<td>user defined expressions relating to section data (Refer to User Variables for more information)</td>
</tr>
<tr>
<td>global user variable</td>
<td>user defined expressions relating to other sections or the whole project (Refer to Global User Variables for more information)</td>
</tr>
<tr>
<td>system variable</td>
<td>system supplied data (Refer to System Variables for more information)</td>
</tr>
<tr>
<td>lookup variable</td>
<td>data from an external database (Refer to Lookup Variables for more information)</td>
</tr>
<tr>
<td>environment variable</td>
<td>data that applies to all projects (Refer to Environment Variables for more information)</td>
</tr>
<tr>
<td>job ticket variable</td>
<td>job file attributes (Refer to Job Ticket Variables for more information)</td>
</tr>
</tbody>
</table>

Function Syntax and usage

<table>
<thead>
<tr>
<th>Function</th>
<th>Syntax and usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>count</td>
<td>count(name) counts the number of times the variable occurs within part of a document.</td>
</tr>
<tr>
<td>max</td>
<td>max(name) finds the maximum value of a variable within part of a document.</td>
</tr>
<tr>
<td>min</td>
<td>min(name) finds the minimum value of a variable within part of a document.</td>
</tr>
<tr>
<td>sum</td>
<td>sum(name) sums a variable within part of a document.</td>
</tr>
</tbody>
</table>
The variables that are available to you at any time, will depend on the type of expression you are building, and where you are building it from. User variables and data variables are available only in the section they are defined in.

**System Conditions**

Create!form Transform provides pre-defined conditions that you can use to:

- Conditionally apply an input section (Text and JDE PDF)
- Conditionally display text objects or variable text objects
- Conditionally define derived variables (Text and JDE PDF)

System conditions will only be displayed in the Condition Builder when you are performing one of the above tasks. The following table describes the system conditions available.

<table>
<thead>
<tr>
<th>Pre-defined conditions</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sys.FirstPageOfDoc</td>
<td>Returns TRUE when the current section is on the first page of the project.</td>
</tr>
<tr>
<td>Sys.ContPageOfDoc</td>
<td>Returns TRUE when the current section is not on the first page or the last page of the project.</td>
</tr>
<tr>
<td>Sys.LastPageOfDoc</td>
<td>Returns TRUE when the current section is on the last page of the project.</td>
</tr>
<tr>
<td>Sys.FirstPageOfSet</td>
<td>Returns TRUE when the current section is on the first page of the set for the project.</td>
</tr>
<tr>
<td>Sys.ContPageOfSet</td>
<td>Returns TRUE when the current section is not on the first page or the last page of the set for the project.</td>
</tr>
<tr>
<td>Sys.LastPageOfSet</td>
<td>Returns TRUE when the current section is on the last page of the set for the project.</td>
</tr>
</tbody>
</table>
Syntax and Order of Precedence Rules

Expressions are evaluated using a specific set of rules, or syntax, that depends on the operators and functions you use in the expression. The Condition Builder and Expression Builder dialogs will assist you in building expressions with a valid syntax; however you must follow a few basic rules to ensure the expression will perform the way you expect:

- Mixed Data Types
- Addition Operator
- Subtraction Operator
- Comparing Text Strings
- Order of Precedence
- Nested Functions
- Parsing
- Names of Variables

Mixed Data Types

Avoid mixing text, numeric and date values in the same expression as this can produce unexpected results. All variable data is stored as a string, but will be interpreted as a number in an arithmetic operation. For example:

"-2"*"3" evaluates to the number -6
2*"3A4" evaluates to the number 68
2*"3-4" evaluates to the number 68
2*"3A4-" evaluates to the number -68
"two"*"three" evaluates to the number 0
Addition Operator

The addition operator (+) is a special case. The rules governing the addition of numeric, text and date arguments are:

- if both arguments of an addition are numeric, an addition is performed. For example: 1+1 evaluates to the number 2.
- if either argument of an addition is a string, the arguments are concatenated. For example: 1+'1' evaluates to the text string "11".
- if one argument is a date and the other is a number, a date addition is performed. For example: if Today is a date variable (m-d-y) with a value of 9-6-2004, the expression Today+1 evaluates to the date value 9-7-2004, whereas the expression "9/6/2004"+1 evaluates to the string "9/6/20041".

Subtraction Operator

The subtraction operator (-) is a special case. The rules governing the subtraction of numeric, text and date arguments are:

- if both arguments of a subtraction are either numeric or text, a subtraction is performed. For example: "a5"-2 evaluates to the number 3.
- if the first argument is a date and the second is a number, a date subtraction is performed. For example: if Today is a date variable (m-d-y) with a value of 9-6-2004, the expression today-1 evaluates to the date value 9-5-2004, whereas the expression "9/6/2004"-1 evaluates to the number 962003.
- if both arguments are dates, a date difference is performed. For example: Sys.Today-InvDate evaluates to the number of days difference between today’s date and the date variable InvDate, whereas the expression "9/6/2004"-"9/6/2003" evaluates to the number 1.
Comparing Text Strings

Avoid using the comparison operators <=, >=, <, > to compare text strings as this can produce unexpected results. The rules governing comparisons of numeric, text and date arguments are:

- if either argument of a comparison is a number, a numeric comparison is performed. For example: "10">2 returns TRUE.
- if both arguments are strings, a string comparison is performed based on the ASCII collating sequence, and is case sensitive. For example: "10">"2" returns FALSE.
- if both arguments of a comparison are dates, a date comparison is performed.

Order of Precedence

Expressions are evaluated in the following order of precedence:

- Operations inside parentheses ( ) are evaluated first, followed by
- - (negation)
- *, /
- +, -
- ==, !=, <=, >=, <, >
- NOT
- AND, OR

Operators with the same order of precedence e.g. + and -, are evaluated from left to right. For example, the expression 3*2+6/-2 evaluates to 3, whereas 3*(2+6/-2) evaluates to -3.
Nested Functions

Functions can be used as arguments for other functions, and can be nested. For example, if the variable A has a value of "Andersch,Jorge", then the expression:

\[
\text{length(substring(A,find(A,"",1)+1,length(A)-find(A,"",1)))}
\]

will return the value 5 (the length of the substring "Jorge").

Parsing

Certain characters or combinations of characters, when included in text strings, can have specific meanings in an expression:

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;</td>
<td>text delimiter</td>
<td>quotation marks are used to define the start and end of a text string</td>
</tr>
<tr>
<td>\</td>
<td>quotation mark</td>
<td>quotation marks are treated literally when preceded by a backslash</td>
</tr>
<tr>
<td>\</td>
<td>backslash</td>
<td>the backslash character is treated literally when preceded by another backslash</td>
</tr>
<tr>
<td>\n</td>
<td>new line</td>
<td>inserts a line feed</td>
</tr>
<tr>
<td>-</td>
<td>minus sign</td>
<td>when a minus sign is adjacent to a number, the number is interpreted as a negative in an arithmetic operation. A minus sign embedded inside a number is ignored.</td>
</tr>
</tbody>
</table>

For example,

"the literal "\\" is ignored" evaluates to the literal "\\" is ignored
"C:\\Program Files\\Create!form" evaluates to C:\Program Files\Create!form
2*"1A2B3-" evaluates to -246
2*"1A2-3" evaluates to 246

Names of Variables

Avoid using function names as names of variables as this can produce unexpected results. Refer to Functions for more information.
Summarizing Data in Headers and Footers

You can use the statistical functions `count`, `max`, `min` and `sum` (refer to Functions for more information) for calculations in any header or footer section. The function is performed over the part of the document associated with the header or footer. For example, when defined as a variable in a set header, the expression `sum(Price)` will sum all occurrences of the data variable `Price` within the set.

Rules for Calculating Statistical Functions

- In **page header** and **footer** sections, the functions will calculate based on the content of the page.
- In **set header** and **footer** sections, the functions will calculate based on the content of the set.
- In **set continuation header** and **footer** sections, the functions will calculate based on the content of the set, up to that point.
- In **table level header** and **footer** sections, the functions will calculate based on the content of the level.
- In **table level continuation header** and **footer** sections, the functions will calculate based on the content of the level up to that point.

To use a statistical function in a header of footer section

1. In the header or footer section, create the user variable (refer to User Variables for more information) and use the Expression Builder to build an expression using the `count`, `max`, `min` and `sum` functions. For example, create a user variable called `AvgPrice` using the expression `sum(Price)/count(Price)`, where `Price` is a data variable which occurs in data sections that are repeated within a table.

2. Insert the user variable as a text object or variable text object (refer to Creating Objects for more information) in a header or footer section. The header or footer section can be of a table, a page, or a set.
**Important**

*By definition, the use of calculations within the project will create new data values in your output. Common uses of the calculations feature include page sub-totaling and calculation of line item tax rates. Please note that it is always recommended that critical page data should only be modified from within your originating financial ERP system. Create!form is not responsible for the misuse of this feature and suggests any calculated data conditions are tested to ensure proper results.*

---

**Example**

The following table provides examples of what values will be created in each header and footer section using the count and sum functions.

**Table 12.1:**

<table>
<thead>
<tr>
<th>Page 1</th>
<th>Page 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>(count, sum)</td>
<td>(count, sum)</td>
</tr>
<tr>
<td>Set Header (8,20)</td>
<td>Set Cont. Header (4,9)</td>
</tr>
<tr>
<td>Page Header (4,9)</td>
<td>Page Header (4,11)</td>
</tr>
<tr>
<td>Table Header (8,20)</td>
<td>Table Cont. Header (4,9)</td>
</tr>
<tr>
<td>Table Level Header (3,7)</td>
<td>Table Level Cont. Header (1,2)</td>
</tr>
<tr>
<td>Data section value: 3</td>
<td>Data section value: 2</td>
</tr>
<tr>
<td>Data section value: 3</td>
<td>Data section value: 1</td>
</tr>
<tr>
<td>Data section value: 1</td>
<td>Table Level Footer (3,5)</td>
</tr>
<tr>
<td>Table Level Footer (3,7)</td>
<td>Table Level Header (2,8)</td>
</tr>
<tr>
<td>Table Level Header (3,5)</td>
<td>Data section value: 5</td>
</tr>
<tr>
<td>Data section value: 2</td>
<td>Data section value: 3</td>
</tr>
<tr>
<td>Table Level Cont. Footer (4,2)</td>
<td>Table Level Footer (2,8)</td>
</tr>
<tr>
<td>Table Cont. Footer (4,9)</td>
<td>Table Footer (8,20)</td>
</tr>
<tr>
<td>Page Footer (4,9)</td>
<td>Page Footer (4,11)</td>
</tr>
<tr>
<td>Set Cont. Footer (4,9)</td>
<td>Set Footer (8,20)</td>
</tr>
</tbody>
</table>
You can customize the look and feel of the Create!form Transform interface, set language options and other user preferences.

The following chapters are covered in this topic:

- User Preferences
- Spelling and Language
- Colors
User Preferences

You can customize the look, feel and behavior of Create!form Transform to suit the way you work. User preference settings are specific to the local copy of Create!form Transform; changes made to user preferences are not saved with the project.

All user preferences are set from the Preferences dialog, which will be displayed by selecting Tools > Preferences from the Main menu. The categories of settings available are displayed in the tree view on the left of the dialog. Select the category in the tree view to display the corresponding controls on the right.

![Preferences dialog categories available. Dialog changes for each category selected in the tree view.](image)

Figure 12.1: Preferences dialog
CUSTOMIZING

User Preferences

- General Preferences
- Section Borders Preferences
- Input Source Preferences
- Design Window Preferences
- Design Window Sections Preferences
- Thumbnail Preferences
- Input (CSV) Window Preferences
- Input (JDE PDF) Window Preferences
- Input (JDE PDF) Window Sections Preferences
- Input (Text) Window Preferences
- Input (Text) Window Sections Preferences
- Input (XML) Window Preferences

General Preferences

Select Tools > Preferences from the Main menu to display the Preferences dialog and select General in the tree view.

The following general preferences settings are available:

**Default Project Directory**
Click the file open button to change the Project Directory.

**Common Project Directory**
Click the file open button to change the Common Project Directory.

**Spell Check Language**
To select a different language for checking spelling, choose a language from the drop down list in the Spell check language field. (Refer to Spelling and Language for more information)

**Events to be Recorded**
Select the level required for logging. To use the level set in Create!form Server, select Default to printer settings.
**Allow Direct Editing of Expressions and Conditions**
Select the checkbox to enable direct editing of expressions and conditions in dialogs without opening the Expression Builder or the Condition Builder.

**Display Dialog on Creating Objects**
Select the checkbox to display the Properties dialog whenever a new text, line, grid, box and ellipse object is created from the Object toolbar (Refer to Creating Objects for more information). You can also display the Properties dialog of an object when you:

- double click the object
- right click the object and select Properties from the shortcut menu
- select Edit > Properties from the Main menu

**Make Backup on Save**
Select the checkbox to make a backup copy of the project and DataMap files when the project is saved. Refer to Saving a Project for more information.

To use a backup version of a project file and a DataMap file, you must manually change the extension of the backup files.

**Restore Suppressed Messages**
Select this option to restore messages that have previously been suppressed. A message is suppressed when the "Do not show this message again" option is selected on a message dialog.

**Generate log file**
Select this option to record events in a log file.

**Section Borders Preferences**
Select Tools > Preferences from the Main menu to display the Preferences dialog and select General > Section Borders in the tree view. The following preferences settings are available:

- The color of a section when it is selected
- The color of the corresponding section in an inactive window
- The thickness of a border
Input Source Preferences

Select Tools > Preferences from the Main menu to display the Preferences dialog and select General > Input Source in the tree view. The following preferences settings are available:

**Display Font**
- Select the input file source view display font in the drop down.
- Select the font Size.
- Select the Monospace only checkbox to restrict the fonts available in the font drop down.

**Colors**
Select the colors for the text and the background.

**Scroll bars**
Display and hide the horizontal and vertical scroll bars.

Design Window Preferences

Select Tools > Preferences from the Main menu to display the Preferences dialog and select Design in the tree view. The following preferences settings are available.

**View**
To set the default page view magnification, choose Fit to Width, Fit in Window or Actual Size from the View drop down list.

**Rulers**
Horizontal and vertical rulers are available to assist in object layout and placement.

**Unit of Measure**
The page is always measured in columns (characters) and rows (lines).

**Nudge Offset**
Type the offset distance in the current units of measure applied when nudging objects with the arrow keys. Refer to Move Objects for more information.
**Synchronize with Input Window**
Select the checkbox to synchronize the page and section display in the Design Window with selections made in the Input Window. You can also separately synchronize the display in the Input Window with selections made in the Design Window. (Refer to Input (CSV) Window Preferences for more information)

**Show Variables in Red**
Select the checkbox to highlight variable text objects in red in the Design Window.

**Show Text Object Outline**
Select the checkbox to display the frame of all text and variable text objects.

**Show Variable Names**
Select the checkbox to display the actual variable names on screen in place of the values.

**Enable Tooltips**
Select the checkbox to display tooltips.

**Design Window Sections Preferences**
Select Tools > Preferences from the Main menu to display the Preferences dialog and select Design > Sections in the tree view. The following preferences settings are available.

**Section Borders**
- Select the Show checkbox to display section borders in the Design Window.
- Select the section border line style from the Style drop down.

**Selected Section**
- Select the Highlight background checkbox to display the selected section in the background color shown. To change the background color, click the background color field to display the Color Picker dialog. Refer to Colors for more information.
- Select the Show repeats checkbox in the Objects section to display all objects in all occurrences of the selected section.
Unselected Sections

- Select the Highlight background checkbox to display unselected sections in the background color shown. To change the background color, click the background color field to display the Color Picker dialog. Refer to Colors for more information.

- Select the Show checkbox in the Objects section to display all objects in unselected sections.

- Select the Gray checkbox in the Objects section to gray out objects in unselected sections.

Thumbnail Preferences

Select Tools > Preferences from the Main menu to display the Preferences dialog and select Design > Thumbnails in the tree view.

To change the background color, click the color drop down to display the Color Picker dialog.

Input (CSV) Window Preferences

Select Tools > Preferences from the Main menu to display the Preferences dialog and select Input (CSV) in the tree view. The following preferences settings are available:

Input File Size

To limit the size of an input data file to be used as a sample, select the Limit to checkbox and enter the maximum number of lines you want to use. To most accurately represent the sample data, it is recommended that you don’t limit the number of lines unless the number of lines affects the processing speed.

Whenever you open a project where the input file size exceeds the limit, you will be prompted to truncate the input file.

Header

- Select the Show checkbox to display the CSV input file header in the Input Window.

- To change the background color, click the Background color field to display the Color Picker dialog. Refer to Colors for more information.
Detail

- Select the Show row numbers checkbox to display the row number in the Input Window.
- To alternate the background color between consecutive sets, select different colors for odd and even sets.

Synchronize with Design Window

Select the checkbox to synchronize the display in the Input Window with selections made in the Design Window. You can also separately synchronize the display in the Design Window with selections made in the Input Window. Refer to Design Window Preferences for more information.

Input (JDE PDF) Window Preferences

Select Tools > Preferences from the Main menu to display the Preferences dialog and select Input (JDE PDF) in the tree view. The following preferences settings are available:

View

To set the default page view magnification, choose Fit to Width, Fit in Window or Actual Size from the View drop down list.

Input File Size

To limit the size of an input data file to be used as a sample, set the Limit to checkbox and enter the maximum number of lines you want to use. To most accurately represent the sample data, it is recommended that you don’t limit the number of lines unless the number of lines affects the processing speed.

Whenever you open a project where the input file size exceeds the limit, you will need to be prompted to truncate the input file.

Show Rulers

Horizontal and vertical rulers are available to measure column (character) and row (line) positions on the input page.

Enable Tooltips

Select the checkbox to display names as the cursor moves over data variables in the Input Window.
Synchronize with Design Window
Select the checkbox to synchronize the page and section display in the Input Window with selections made in the Design Window. You can also separately synchronize the display in the Design Window with selections made in the Input Window. Refer to Design Window Preferences for more information.

Input (JDE PDF) Window Sections Preferences
Select Tools > Preferences from the Main menu to display the Preferences dialog and select Input (JDE PDF) > Sections in the tree view. The following preferences settings are available.

Section borders
• Select the Show checkbox to display section borders in the Input Window.
• Select the section border line style from the Style drop down.

Selected section
• Select the Highlight background checkbox to display the selected section in the background color shown. To change the background color, click the background color field to display the Color Picker dialog. Refer to Colors for more information.
• To change the variable background color, click the Variable Background color field to display the Color Picker dialog.
• To change the selected variable frame color, click the Select variable frame color field to display the Color Picker dialog.

Unselected sections
• Select the Highlight background checkbox to display the unselected sections in the background color shown. To change the background color, click the background color field to display the Color Picker dialog. Refer to Colors for more information.
Input (Text) Window Preferences

Select Tools > Preferences from the Main menu to display the Preferences dialog and select Input (Text) in the tree view. The following preferences settings are available.

View
To set the default page view magnification, choose Fit to Width, Fit in Window or Actual Size from the View drop down list.

Input File Size
To limit the size of an input data file to be used as a sample, select the Limit to checkbox and enter the maximum number of lines you want to use. To most accurately represent sample data, it is recommended that you don’t limit the number of lines unless the number of lines affects the processing speed.
Whenever you open a project where the input file size exceeds the limit you will be prompted to truncate the input file.

Grid
A grid can be displayed in the Input Window to assist in mapping sections and data variables. The grid lines correspond to the column and row numbering displayed on the rules.
Use the Grid options to:
• Hide and show a grid
• Show grid as points
• Change the grid line style

Rulers
Horizontal and vertical rulers are available to measure column (character) and row (line) positions on the input page. User the Rulers option to:
• Hide or show ruler
• Change the cursor indicator color

Display Font
• Select Monospace only checkbox to restrict the fonts available in the font drop down.
• Select the input file display font in the drop down.
Enable Tooltips
Select the checkbox to display names as the cursor moves over data variables in the Input Window.

Synchronize with Design Window
Select the checkbox to synchronize the page and section display in the Input Window with selections made in the Design Window. You can also separately synchronize the display in the Design Window with selections made in the Input Window. Refer to Design Window Preferences for more information.

Input (Text) Window Sections Preferences
Select Tools > Preferences from the Main menu to display the Preferences dialog and select Input (Text) > Sections in the tree view. The following preferences settings are available:

Section borders
- Select the Show checkbox to display section borders in the Input Window.
- Select the section border line style from the Style drop down menu.

Selected section
- Select the Highlight background checkbox to display the selected section in the background color shown. To change the background color, click the background color field to display the Color Picker dialog. Refer to Colors for more information.
- To change the variable background color, click the Variable background color field to display the Color Picker dialog.

Unselected sections
- Select the Highlight background checkbox to display the unselected sections in the background color shown. To change the background color, click the background color field to display the Color Picker dialog. Refer to Colors for more information.
- To change the variable background color, click the Variable background color field to display the Color Picker dialog.
Input (XML) Window Preferences

Select Tools > Preferences from the Main menu to display the Preferences dialog and select Input (XML) in the tree view. The following preferences settings are available:

**Tooltips**
You can choose to display tooltips when the cursor hovers over an XML element, and optionally, the tooltip will display values, variable and section names, and the type of node.

**Initial Document View**
When the document is opened, choose if the whole tree is expanded, or only the first level.

**Colors**
Select a component of the tree to display the current color setting. To customize colors, clear the User system color checkbox and click the color field to display the Color Picker dialog.

**Synchronize with Design Window**
Select the checkbox to synchronize the page and section display in the Input Window with selections made in the Design Window. You can also separately synchronize the display in the Design Window with selections made in the Input Window. Refer to Design Window Preferences for more information.
Spelling and Language

Create!form Transform is able to check each section for spelling errors occurring in text objects. You cannot check the spelling of variable data that is mapped from the input data file.

- Checking Spelling
- Languages
- User Dictionaries

Checking Spelling

1. Select the section you want to check spelling for.
2. From the Main menu, select Tools > Spelling. To only check specific text objects in a section, select those text objects to spell check. If no text objects are selected, Create!form Transform will check the entire section.

Check Spelling dialog options

<table>
<thead>
<tr>
<th>Dialog item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not in Dictionary</td>
<td>Indicates that a misspelled word was found. The word is considered misspelled because it was not located in any open dictionaries, or was found in an exclude dictionary.</td>
</tr>
<tr>
<td>Ignore</td>
<td>Causes this occurrence of a misspelled word to be skipped.</td>
</tr>
<tr>
<td>Ignore All</td>
<td>Causes this and all further occurrences of a misspelled word to be skipped.</td>
</tr>
<tr>
<td>Change to</td>
<td>Contains a work which will replace a misspelled word when you select the Change or Change All buttons.</td>
</tr>
<tr>
<td>Suggestions</td>
<td>Contains a list of suggested replacements for the word reported as misspelled. A word selected in this list will automatically be copied to the Change To field, where it can be substituted for the misspelled word by clicking the Change button.</td>
</tr>
<tr>
<td>Change</td>
<td>The misspelled word will be replaced with the word in the Change to field.</td>
</tr>
<tr>
<td>Change All</td>
<td>This and all following occurrences of the misspelled word will be replaced with the word in the Change To field.</td>
</tr>
<tr>
<td>Suggest</td>
<td>Causes a group of suggested replacements for misspelled words to be displayed in the Suggestions list.</td>
</tr>
</tbody>
</table>
Languages

Create!form Transform can check spelling in a project using any installed language. For a Typical installation, English-US and English UK are installed.

To install another language from the installation CD

1 Insert the installation CD and navigate to the \Utilities\Language directory. This directory contains a separate sub-directory for each of the available languages.

2 Locate the sub-directory for the language required.

3 Copy the language directory from the installation CD into the \<install dir>\Win32User\MainLexicon directory.

4 The language(s) will be available the next time you start Create!form Transform. To use the new language(s), make the settings in the Preferences dialog.

User Dictionaries

There are four types of dictionary. When you create a dictionary, you must specify the type. The type indicates what happens when a word is found in that dictionary during a spell check as explained below.
Table 13.1:

<table>
<thead>
<tr>
<th>Dictionary type</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto Change</td>
<td>Words found in and Auto Change dictionary are automatically replaced with other words. Typically, Auto Change dictionaries hold frequently misspelled words and their correct replacements. Each entry in an Auto Change dictionary contains a word and the replacement, separated by a colon (e.g. recieve:receive).</td>
</tr>
<tr>
<td>Conditional Change</td>
<td>Words found in a Conditional Change dictionary are presented to you as candidates for replacement and are replaced with other words if you request.</td>
</tr>
<tr>
<td>Exclude</td>
<td>Words found in an Exclude dictionary are always considered misspelled, even if they are defined in other dictionaries.</td>
</tr>
<tr>
<td>Ignore</td>
<td>Words found in an Ignore dictionary are considered correctly spelled.</td>
</tr>
</tbody>
</table>
Colors

The default color palette provides a standard range of colors to choose from. The current color selection on a dialog option will be shown on the color button.

To display the Color Picker dialog, click the color drop down. The default color palette is shown on the Basic tab. To customize the color palette, select the Custom tab on the Color Picker dialog and use the controls to mix the colors you want.

Figure 12.1: The Color Picker dialogs
GLOSSARY

This appendix provides a list of commonly used Create!form terms.
# Glossary

The following table explains many of the terms specific to Create!form.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>alias</td>
<td>An alternative name for a source or child section used to resolve problems with duplicate variable names in child and source sections.</td>
</tr>
<tr>
<td>alternate section</td>
<td>A section that alternates with a data section when user-defined conditions are met. The characteristics and content of an alternate section are independent of the section they alternate for.</td>
</tr>
<tr>
<td>argument</td>
<td>The component of a function or expression that defines value.</td>
</tr>
<tr>
<td>common project directory</td>
<td>The directory used to store shared project resources.</td>
</tr>
<tr>
<td>condition</td>
<td>A user-defined logical test that results in either a true or false value. Conditions enable the project to behave differently according to the content of the input file or the production environment.</td>
</tr>
<tr>
<td>data section</td>
<td>A section that is brought into the project from the input file.</td>
</tr>
<tr>
<td>DataMap</td>
<td>A DataMap records how the different parts of an input file are identified and labelled.</td>
</tr>
<tr>
<td>data variable</td>
<td>A variable defined in the input file.</td>
</tr>
<tr>
<td>data copying</td>
<td>The creating of variable text objects in the project, using data variables from the input file.</td>
</tr>
<tr>
<td>derived variables</td>
<td>A user-defined expression, defined in the input.</td>
</tr>
<tr>
<td>detail section</td>
<td>A section in the input file containing repeating line items.</td>
</tr>
<tr>
<td>e-forms server</td>
<td>The system that hosts Create!form Server, which merges the project with incoming spool files.</td>
</tr>
<tr>
<td>enterprise server</td>
<td>ERP system or other application that is the originator of the input files.</td>
</tr>
<tr>
<td>expression</td>
<td>A user-defined statement that performs calculations and derives values from the input data.</td>
</tr>
<tr>
<td>form project</td>
<td>See project.</td>
</tr>
<tr>
<td>function</td>
<td>A pre-defined formula that performs a calculation from user defined arguments.</td>
</tr>
<tr>
<td>global user variable</td>
<td>A user-defined variable, global to the project.</td>
</tr>
<tr>
<td>input file</td>
<td>A sample file from the enterprise server, used to build the DataMap.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>inserted section</td>
<td>An inserted section is created by the user and attached to a data section.</td>
</tr>
<tr>
<td>lookup variable</td>
<td>A variable that derives its value from an external database.</td>
</tr>
<tr>
<td>standard project</td>
<td>A project that utilizes all the design features of Create!form Transform.</td>
</tr>
<tr>
<td>object</td>
<td>Text, graphic or barcode object inserted in the project.</td>
</tr>
<tr>
<td>operator</td>
<td>A component of an expression or condition that defines an arithmetic, logical or text operation on adjacent arguments.</td>
</tr>
<tr>
<td>overlay project</td>
<td>A project where the data from the input file will be displayed in the project without change.</td>
</tr>
<tr>
<td>project</td>
<td>A project is a record of the way you want to redesign the input file. Also referred to as a form project.</td>
</tr>
<tr>
<td>project directory</td>
<td>The directory where the project resources are stored.</td>
</tr>
<tr>
<td>repagination</td>
<td>The process of expanding or condensing pages in the project depending on the space required.</td>
</tr>
<tr>
<td>repeated section</td>
<td>A data section that appears more than once in a set.</td>
</tr>
<tr>
<td>set</td>
<td>A user-defined construct that divides the input file into its basic document units, that the project is designing.</td>
</tr>
<tr>
<td>simple project</td>
<td>A project where only limited reformatting of the input file is required.</td>
</tr>
<tr>
<td>source</td>
<td>Where a section derives its data from. The source of a section can be a section from the input file, or another section in the project.</td>
</tr>
<tr>
<td>subform</td>
<td>A subform is a user defined graphical object.</td>
</tr>
<tr>
<td>system variable</td>
<td>System variables are predefined and relate to the project. They include such items as the number of pages in the set or document.</td>
</tr>
<tr>
<td>table</td>
<td>A table is a user created structure that enables you to better organize and display a series of consecutive data sections.</td>
</tr>
<tr>
<td>template</td>
<td>A project, used to define other projects.</td>
</tr>
<tr>
<td>user variable</td>
<td>User variables are user-defined expressions that relate only to the section they were created in.</td>
</tr>
</tbody>
</table>
GLOSSARY
- Glossary
-
A

About Defining Detail Sections 98
About Format Styles 119
   To create a format style 120
   To customize a format style 120
About Parent/Child Relationships 139
   To define a parent/child relationship 140
About Sections 126
About Sources 141
About Tables 144
About Variables 190
Add Detail Sections 99
   To define additional detail sections 99
Add Input Footer Sections 102
   To define additional input footer sections 103
Add Input Header Sections 95
   To create an additional input header section 95
   To delete an input header section 96
Adding Sources
   To add a section as a source 142
Addition Operator 220
Adjust the Input Footer Section Size 102
   To adjust the input footer section size 102
Adjust the Input Header Section Size 93
   To adjust the input header section size 94
Adjusting Section Size 137
Advanced Object Selection 185
Align Objects 183
Allow Direct Editing of Expressions and Conditions 228
Alternate Sections 133
   To create an alternate section 133
   To delete an alternate section 133, 134
Alternate Sections and Parent/Child Relationships 139
Auto-Expanding Sections and the Keep With Option 140
B
Boolean Operators 209
Building Blocks 209
Building Conditions 208
Building Expressions 204

C
Change Number, Date and Currency Formats 170
Changing the Input Data Format 71, 111
   To change the input data format 71, 111
Changing the Properties of Columns 71
   To change the properties of a column 71
Changing the Properties of Data Variables 111
   To change the properties of data variables 111
Chapter 1
   Introducing Create!form Transform 13
Collate Options 118
Colors 240
Common Input Section Tasks 88
Common Project Directory 27, 227
   To change the common project directory 28
Comparing Text Strings 221
Conditions 207
Continuation Header and Footer Sections 130
Controlling When an Input Section is Generated 91
   To control when an input section is generated 91
Copy Data Variables from an Input Section 160
Copy Data Variables to the Project 86
   To copy a data variable to the project 86
Copy Objects 182
Copy Objects from other Projects 166
Copying Data Variables to the Project 72, 112
   To copy a data variable to the project 72, 112
Create and Remove Header and Footer Sections 130
   To create header and footer sections for the project, sets or pages 130
   To turn a header and footer section off 131
Create Data Variables
   To create a data variable 83
Create Data Variables 83
   To change the size and position of a data variable 84
   To delete a data variable 86
   To display and edit data variable properties 85
Create Data Variables in a Detail Section 86
Create Header and Footer Sections From an Input Section 131
   To use the create from function 131
Create Set Headers and Footers with the Wizard 129
Create!form Transform Features 15
Creating a Project 29
Creating Derived Variables 116
CSV File Structure 66

D
Data Section Display Options 127
   To set the display properties of a data section 127
Data Sections 127
Data Variables 115
   To copy a data variable to the project 115
Data Variables and Derived Variables 191
Data Variables in Detail Sections 71
Data Variables in the Input Header Section 71
DataMap Options 31
   Copy a DataMap from another project 31
   Create a new DataMap 31
   Select a shared DataMap 31
DataMap Options When Creating a New Project 62
DataMap Options While Designing a Project 62
DataMap Types and Options 61
Date Functions 215
Default Project Directory 227
Defining Sections 69, 108
   To define sections 108
To rename a section 109
Defining Sets 69, 82, 108, 114
   To define sets 69, 82, 108, 114
Deleting Input Sections 92
Design Flowchart 33
Design Prerequisites 16
Design Principles 76
Design Window 48
Design Window Preferences 229
Design Window Section Preferences 230
Designing for CSV Input Files 66
   To create the CSV sample project 66
Designing for JDE PDF Input Files 113
Designing for Text Input Files 73
   To create the text sample project 73
Designing for XML Input Files 105
   To create the XML sample project 105
Designing from the Top-Down 76
Display and Edit Input Section Properties 88
   To display the Input Section Properties dialog 89
Display Dialog on Creating Objects 228
Drag and Drop Variables from the Input Window 161
Duplicates 119

E
Edit a Shared DataMap 63
Edit an Embedded DataMap 63
   To copy a DataMap from another project 63
   To share a DataMap with other projects 63
Edit Objects on Sections that are not Displayed 180
Edit the Contents of a Subform 171
Embed a DataMap 64
   To embed a DataMap 64
Embedded and Shared DataMaps 61
Environment Variables 200
Events to be Recorded 227
Examining How Sections are Populated 76
Expressions 204

F
Fixed and Auto-Expanding Sections 137
   To auto-expand a section 138
Functions 212

G
General Preferences 227
Getting Help 18
Global User Variable 194
Global User Variables
   To create a global user variable 194
   To create a glocal user variable 194
Glossary 242
Grouping Options 150

H
Header and Footer Sections 129, 149
   To create or remove header and footer sections 149
How the Page Size is Calculated 80

I
Input (CSV) Window Preferences 231
Input (JDE PDF) Window Preferences 232
Input (JDE PDF) Window Sections Preferences 233
Input (Text) Window Preferences 234
Input (Text) Window Sections Preferences 235
Input (XML) Window Preferences 236
Input Design 55
   Before You Start 56
   Design Flowchart 77
   Input Sets 115
Input File Properties 68, 107, 113
To add and remove non-breakable input sections 113
To change the input file data format 114
To change the input file properties 68, 107

Input file Type 30
Input Sections 75
Input Source Preferences 229
Input Window 48
Inserted Sections 135
  To insert a section before or after another section 135

Installation Requirements 22
Installing Create!form Transform 23

J
Job Ticket Variables 201

K
Keeping Sections Together 139
Key Input Design Concepts 58

L
Languages 238
Logical Functions 212
Lookup Variables 197

M
Make a Detail Section Expandable 100
  To make a detail section expandable 100
Make an Input Header Section Expandable 94
  To make an input header section expandable 94
Make Backup on Save 228
Make Data Variables Expandable 87
  To define an expandable data variable 88
Managing Project Files 43
Mixed Data Types 219
Move Objects 181
N
Names of Variables 222
Navigating and Editing Expressions 206
Nested Functions 222
New Project Wizard 29  
   To start the new Project Wizard 29

O
Objects
   About 154
   About Objects and Sections 154
   About Property Classes 174
   Adding Text to the Page 157
   Changing the Display Properties 167
   Copying from other Resources 165
   Display and Edit 172
   Edit the properties of multiple objects 173
   Editing and Formatting 167
   Editing and Formatting the Contents of 168
   Formatting a Variable Text Object 169
   General Properties 174
   Selecting in Different Views 155
   Setting Properties 172
   Text Properties 176
   Using Variables to Control 155
   Variable Properties 175
   Windows Display Preferences 156
Opening a Project 39
   To open a project 39
Operators 210
Order of Precedence 221
Other Input File Settings 80
Output Structure Options 32
Overlay Project 32
P
Packing Projects 41
  To save a project as a packed project 41
Paginated CSV Files 67
Parent/Child Relationship Requirements 139
Parsing 222
Printing and Previewing Projects 40
  To preview the project 40
  To print a project 40
Production Prerequisites 17
Project Background 123
  To add text to the background 123
Project Directories 27
  To change the default project directory 27
Project Page Style 122
  To set the page style 122
Project Properties 118
  To edit project properties 118
Project Type 31

R
Resize Objects 182
Restore Suppressed Messages 228
Rules for Creating Multiple Input Header Sections 97
Rules for Calculating Statistical Functions 223
Rules for Creating Multiple Detail Sections 101
Rules for Creating Multiple Input Footer Sections 104

S
Saving a Project 38
  To save a project 38
Section Borders Preferences 228
Sectioning Positioning Options 136
Select Hidden Objects 180
Selecting a Different Input File 56
  To select a different input file 56
Selecting and Editing Objects In Graphics View 179
Set Default Properties 178
Set Input Data Formats 83
  To change the input data format 83
Set the Default Format Style for New Objects 120
  To set the default format style 120
Setting Repagination Control 140
Setting Section Properties 136
  To display the section properties dialog 136
Setting the Input Page Size 78
  To define the input file page width and length 79
Share a DataMap with other Projects 63
Simple Project 32
Sources
  Adding 142
    To add a section as a source 142
Spell Check Language 227
Spelling and Language 237
Standard Project 31
Starting Create!form Transform 24
Statistical Functions 216
Subform Properties 177
Subform Variable Properties 178
Subforms
  About 162
  Adding 162
    Convert Text Files Into 163
    Creating 164
      Insert an existing Subform 163
    Storage 162, 163
      Using a Variable to Display 165
Subtraction Operator 220
Summarizing Data in Headers and Footers 223
Synchronize with Design Window 232
Syntax and Order of Precedence Rules 219
System Conditions 218
System Variables 195

T
Tables
   About Parent/Child Relationships 151
   Change Table Properties 146
   Create a Table 145
   Delete a Table 147
   Properties 148
   Setting Pagination Controls 152
   Sorting Modes 149
   Table Levels 148
Tables with Headers and Footers 32
Text and Numeric Functions 213
The Display Order of Header and Footer Sections 132
Thumbnail Preferences 231
Transferring Projects to the e-forms Server 42
   To transfer a project to the e-forms server 42

U
Understanding the Screen Elements
   status bar 50
Use a Shared DataMap 64
   To use a shared DataMap 64
User Dictionaries 238
User Guide Conventions 19
User Preferences 226
User Variables 192
   To create a user variable 193
Using an Existing Project as a Template 30
Using Expressions and Conditions 208
Using the Create!form Sample Projects 56
Using the Expression Builder 205
V
Variables 217
Viewing and Navigating 45
   Input File Source View 49
Viewing the Input File Source 57
Viewing the Properties of Sections that are not Displayed 128

W
What is a Data Variable? 59
What is a DataMap? 58
What is a Derived Variable? 60
What is a Project? 26
What is a Section? 59
What is a Set? 59
Who is this Guide for? 14
Working with Data Variables 70, 83, 109
Working with Detail Sections 97
Working with Input Footer Sections 101
Working with Input Header Sections 93
Working With Multiple Input Sections 91
Working with Tables 145
Working With the Input File Header Section 92
   To adjust the input file header section size 93
   To create an input file header section 93

X
XML File Structure 106